Adjusting cruise speed

I have change ARSPD_FBW_MAX from 22 to 19 and ARSPD_FBW_MIN from 9 to 6(during flight). the plane did not slow down. throttle stick at lowest position
I set TRIM_ARSPD_CM at 12M/S. as it says this param is not supposed to change as the PID tuning base on it. so i left it as default and TRIM_THROTTLE set to 30.

I think I followed the struction. but I probably misunderstood something. can anyone tell me what is right to adjust the cruise speed.

I’m not sure what kind of plane you’re flying here, but be careful with 6 m/s for your min speed. That’s going to put you close to a stall on many airframes.

Do you have an airspeed sensor? Is it calibrated?

What mode are you testing this in? Are you trying to slow the plane down in cruise mode or FBW-B?

The plane was flying is a Sonicmodel binary. The 6m/s is for test only and it did not work. So I set it back to 9m/s.

Yes, I have 4525 air speed sensor. It was Calibrated.

The model I was tested, they were RTL,cruise,auto. Yes, I was trying to slow down the airplane to have better efficiency for long distance flying.

perhaps just to rule things out disable the air speed sensor so it’s only using your set cruise speed.

I can try that. but what would be the next step after that?

As I recall there is also a Minimum airspeed setting too. Maybe that one is set to high overriding your other speed settings??

This is my setting. I have tried with the min to 6M/S. The speed did not change.

I’ll poke around tonight see if I see anything you might be missing. Isn’t there a ‘cruise’ throttle as well?? I know how it goes! easy to miss something. I recall cruise throttle was the minimum percentage of throttle it would apply in any guided mode.So if that was set higher than your ARSPD_FBW_MIN|9| it might override this… just a thought. and I’m not looking a list of params right now… cruise throttle was what I remember from many version ago. I fly nitro… no air speed sensor so that’s how I set my min throttle. There was no actual speed set it was just throttle percentage. I liked the simplicity of that no accidental killing of a nitro engine.

what about THR_PASS_STAB have you looked at that?? and ‘cruise’ is gone I think it got renamed TRIM_THROTTLE check those maybe. I think I’d start with setting trim throttle to say %30 or so like you had it [ depending on how fast you want to fly ] and disable the air speed sensor just to see if you can adjust to your desired speed and go from there. Small chance but if you had THR_PASS_STAB on and never touched your TX throttle it would just keep that TX 3ch speed in FBWA… I think.

cruise throttle was 30 I set( it was 40 then I lower it to 30). I can post the param here. tell me iif you found anything would work.binary ardupilot.param (26.7 KB)

Without airspeed, TRIM_THROTTLE will set the speed (by virtue of the motor speed). However, I see you have THROTTLE_NUDGE = 1. So if you have the throttle control above 50% it will increase the motor speed because it’s assuming you are trying to fly faster.

Make sure when you are testing FBWB or CRUISE, that you have the throttle below half to see what the actual controlled speed is going to be. Or set THROTTLE_NUDGE = 0.

yes. I need THROTTLE_NUDGE = 1 on. in case plane shows the sign to stall. i can still increase throttle.

when I adjust arspd from min to max. I adjust the throttle position to min. but the speed did not slow down. I tried cruise, AUTO

You already have stall prevention turned on, and just increasing the throttle is not the best way to correct for a stall. Stall is an issue with angle of attack, not speed, so you need to lower the nose. Proper use of throttle can prevent stall, but it’s not the best way to get out a developing stall.

With the airspeed sensor turned off, settings like ARSPD_FBW and TRIM_ARSPD do nothing to change the speed in auto-throttle modes. It’s all based on TRIM_THROTTLE. If you’ve lowered that to 30 already then maybe something else is going on that’s not letting the motor slow down. It’s possible you’ve already slowed down to a point where the stall prevention is not letting the throttle go that low. Try flying the plane straight and level in FBWA and see what the minimum throttle is you can cruise at, and still maintain altitude without using excessive nose up attitude.

I tried. it was 28-30thr with not so much wind day. do you suggest that I can lower trim_throttle?

I did not turn off airspeed when I was changing ARSPD_FBW_MIN and MAX.

Try turning airspeed sensor off. I find it just complicates things more than it needs to. I know my plane cruises most efficient at %35 throttle so I just set my trim throttle to that. No airspeed sensor. If I was trying to set up my plane to land itself I think it would be much more relevant.

I gave another try this afternoon. by lowering the trim_throttle to 25%. The speed dropped from 60km to 55km something. But I don’t feel comfortable to lower to below of 25%… I guess I cannot disable the air speed as it helps in the windy day flying. It probably involve the tec tuning section. I will look into again.

The parameter file you posted had the airspeed use set to 0. So this is getting confusing.

Please post a log file (.bin) of your test flight if you want more assistance. No videos are needed, just the log file from the controller.

1 Like

Hi Allister,

Thank you so much. I did not think it over when I found Airspeed showing on the screen. I thought it is working now. I need to set ARSPD_USE to 1. I will fly the plane again this afternoon.

this is bin file!Ai_XT63sPXkHxSdqAO2a0LIMTeNW?e=Z4Ao12

I’ve been looking at your log and I think you have too much going on at once to get the speed dialled in. It’s also hard to see what’s going on because the only auto throttle mode in that log (after tuning) was loiter. In the loiter turn the throttle will be higher to help maintain speed to prevent stall and altitude loss. The portion of the flight in Cruise (before tuning) is showing a lot of oscillations in pitch and throttle to maintain altitude. It seems to be holding altitude well, but it looks like it’s working hard to do it.

My suggestions:

  • Get the tune sorted out. The roll looks good but the pitch needs some work. Your elevator servo seems to have a lot of trim in it so I would investigate the position of the elevator linkage, and confirm your C of G. Work on getting the plane flying as true as possible mechanically first, and then get the PID tune sorted out.
  • After tuning, to see your cruise speed you’ll need to fly the plane in FBWB or Cruise, and try to do it straight and level for as long as possible to see what it’s doing. Don’t get caught up about the increased speed in a turn.
  • Consider what is realistic for the plane for a slower speed? From what I’ve seen here is that when your throttle is at the lower settings (less that 35%) the plane is generally losing altitude or the pitch is hunting to maintain altitude. It seems to hold altitude better above 35%. If you can get the plane to fly stable with a slightly higher throttle setting (and better tuning) you may actually get a more efficient/longer flight than by simply lowering the throttle. If you really want to get serious about increasing the endurance beyond this then get a subscription to eCalc and figure out a new motor/prop/battery combination that will give you the performance you’re looking for. Don’t assume the manufacture of the model has given you the best hardware.