Access and map auxilliary output channels on Pixhawk

Hello, I tried doing this in copter, rover and plane, and it worked in none of these firmwares.

I can configure channels 1 to 8, the main channels on the pixhawk, e.g. rc pass through, throttle, aileron, and so on.

I would like to do rc pass through on the auxiliary channels. Corresponding to channels 9 to 14 on thhe Taranis SBUS.

The Taranis is set up properly. The radio calibration shows all 16 channels receive input signals.

I followed this manual to attempt to map output channels:

I also tried to follow this video, but as explained below, the option 1 for rc pass through is not available in my mission planner (latest version) in any of the firmwares, rover, airplane or copter.

And this thread: Aux channels above 8 how to get and use them

I went into full parameter list and full parameter tree and found the rc9, rc10, rc11, etc channels.

Problem 1) The function for rc pass through should be 1, but 1 is not mentioned in the available options, it goes from 0 = do nothing to 4 = RTL. I set it to 1 anyway, but nothing happens, channel 9 (Aux 1) is dead.

Problem 2) I went ahead and set it to 19 = Gripper, assuming that this should lead to some kind of servo actuation. But nothing. A servo is connected, the controller is armed (force armed via Mission planner), but nothing happens. Servos on channels 1 to 8 work fine. Nothing on the auxilliary channels, although there is power to them via an ESC/BEC on the servo rail.

Setting up and using auxilliary channels should be a common requirement for many applications. The flight controller has 16 channels, so it should be possible to use them? May I ask if anybody has had this problem and managed to solve it?

Thank you.


I think you are looking at some old info.A YouTube video from 2016 won’t help you. Pass thru on any output is as simple as selecting what channel you want to assign to pass thru on that output. They are all assignable.

Servo out

Hi Dave, thank you so much. Exactly what was needed. So the answer is to do it in the Servo#_Function Parameter, not in RC#_Options. I guess parameters were renamed at some stage between when this video was made and now?

Anyway. It’s working now. Nice.

Thank you!

Yes, the RC inputs and outputs were split several revisions back. Totally configurable now.