Accelerometer Calibration Timeout

Hi Everyone, first time builder and poster here.

I am building a large (690mm) endurance quad and need some help with initial setup in Ardupilot. I’m running 15" carbon fiber props on a 380KV motor (all T-Motor), 4 x Tekko32 F3 35amp ESC’s, and the Kakute F& v1.5 AIO flight controller with a Matek M8Q-5883 GPS module.

Last week I flashed Betaflight onto the Kakute and grew dissatisfied, now I’m in the middle of switching to Ardupilot like i should have done from the beginning. After some frustration and 2.5 hours of fiddling with drivers and reflashing last night, i finally succeeded in flashing the most recent ArduCopter firmware ( the _BL.hex version!) and it will connect with Mission Planner on my Windows PC. Everything appears to be working fine, but last night and this morning when I try to calibrate the accelerometer, MP times out. I set the quad down on the floor, hit “Calibrate Accel”, and receive no prompts. I have the distinct feeling i am missing something quite stupid/obvious.

Can anyone suggest a fix?


Out of curiosity can you post a screen shot of the Setup>HW ID screen in Mission Planner? The question of the V1.5 version of the Kakute F7 has come up before but I don’t recall a definitive answer.

yeah, i searched fairly hard for an answer, and thought i found it a couple times but was wrong…so i ventured to make my own post.

You bet, when i get home here in a bit i’ll post a screen shot. To be clear, can you tell me where I can find that screen? Is it under the Initial Setup tab somewhere?

This is a screen shot from a Kakute F7 AIO I have on my bench. What we are looking for is the ID for the IMU.


Here you go. What do you think, Doctor? For what it’s worth, i’m going through the First Time Setup steps and haven’t been able to get the Taranis X9D+ 2019 with the full size CrossFire Transmitter to talk to Mission Planner yet. Don’t know if that matters…

The IMU is not recognized, no device ID’s. Which firmware target did you use?

“KAKUTEF7”. Here’s what i’ve been trying to do, per Oscar Liang’s post on the subject:

However, I can’t get it to do anything when I choose a target. When I set it up as in the above pic, and hit “Flash Firmware”, nothing happens. However, if I deselect the target it will let me load local firmware and flash it to the Kakute.

I did have this ship in the air, flying rather unstable (but flying!) running Betaflight over the weekend. However, Oscar recommends using the following UARTs, which I am not doing:

Kakute F7:

  • GPS module to UART 4 [My GPS is connected to UART 2]
  • Receiver to UART 6 [Crossfire Diversity connected to UART 4]
  • Telemetry to UART 1 or 2 [The ESC telem wires are on UART 7, next to the motor pads].

Do I need to re-solder these?

Did you read this about flashing Ardupilot to the Flight Controller?

The pin mapping is different between Betaflight and Ardupilot.

Yes I did, many times actually, and somehow missed that the wiring layout there is different than both what Oscar recommended and what I currently have, lol.

That doc says:

1). I can continue using R7 (serial port 5) for esc telemetry as I am now,

2). I should move my GPS to UART 3, and

3). I should move the crossfire to UART 6.

I will do that tonight and hope for the best! Thank you for your patience, I hate getting stuck on such dumb questions. :man_facepalming:

From limited experience running a Kakute F7 (not AIO, not sure it matters) once you get beyond using BetaFlight configurator to upload initial bootloader firmware you can not use USB power for much. You need to use battery power, or in my case I use a bench DC power supply, so that everything initializes and runs as it should. So I got in the habit of pulling props and hooking up bench supply anytime I wanted to do something via USB.

The AIO version runs OK on USB. At least it runs the GPS module, Rx and a ESP8266 radio OK.

And to be clear that version of firmware you show in the image you posted above is not Ardupilot. You need to grab the _with_bl.hex file from here:
and flash it with the Betaflight configurator after booting the board with the DFU button pressed. If you are succesful at this then post another shot of the HW ID screen in Mission Planner because you may not be out of the woods.

For what it’s worth the latest version of BF configurator would not flash for me in DFU mode, I had to use the dfu utility - hopefully your experience is better.

It’s interesting that you say that because I was just trying with a Kakute F7 AIO and there is no response in the configurator when the Flash Firmware button is pressed. I set it aside to work on something else thinking I would figure it out when I got back to it.

Note: Something seems to be broken in the latest version of the BF Configurator. The older version 10.4.0 works.

I had a similar issue flashing with the Kakute Mini F7, I used the INAV flash utility. Good to go! :wink:


I am officially pulling my hair out. I have tried every all of the above suggestions: I first resoldered my board as prescribed in the Arducopter Docs. Next I flashed the copy of arducopter_bl.hex file i had been using in Betaflight 10.6, and after flashing plugged in the battery and attempted to connect to Mission Planner. I was able to connect, but the HW_ID screen looks just as above. Downloaded INAV, flashed the exact copy of arducopter Dave shared above, connected to MP, same thing. Downloaded Betaflight 10.4, flashed Dave’s version, connected to MP, same thing. Tried mixing and matching the above, same thing. What the f&*% is up with this? I thought Arduocopter was supposed to be easy to use?

Does anyone have any suggestions? At this point i’m wondering if i wouldn’t be better off just buying a damn Pixhawk and moving on. Can anyone talk me off the ledge?

Thank you!

Did you wipe the flash when uploading via BF? You should just in case someing weird has snuck in.
If the IMU does not show then something is really fundamentally broken. I would suspect a hardware problem.

Andy-I think this question has come up before but does the Kakute F7 target support the V1.5 board with the MPU6000? I see a couple lines in the hwdef for it but a lot more defined for the ICM20689.

Ah no - that’s the issue!

Belay that - no it’s not the driver is the same, but I will verify the SPI bus is the same

So it sounds like the v1.5 simply cannot by made to work?