About RTK module supporting

Hi;

is this gps module supported ardurover? GPS can’t find the signal even though I made the cable connections

unicore-um980

Use the search function for “unicorecomm”.

Hi;

In the parameters list, there is an option as in the picture. I activate it but still no signal.

If you used search you would find a post about using the Dev build firmware. Maybe that will work.

Hi again;

Unfortunately, I couldn’t get a gps signal in the developer version either. I think unicore gps are supported. because it is available in the gps_type list. but i don’t understand why i can’t get signal. Has anyone experienced unicore gps with ardu rover?

It is extremely common to mix up the RX and TX wires. Check the wiring before anything else.

GPS TX must connect to autopilot RX, and vice versa.

@ramada,

Support for this GPS is very new so if GPS_TYPE is set to 24 then the autopilot will need to be running 4.4 (aka “latest”). If you’re using MP you can load “latest” by going to the Firmware Install screen and pressing Ctrl-Q. Remember though that this “latest” is today’s latest build so it has not gone through beta testing.

1 Like

Hi;

I downloaded and installed the latest version of Rover as you specified. I made the necessary settings. but still no signal. Screenshots of the version are attached. My settings are as below.

GPS_TYPE == 24
GPS_AUTO_CONFIG == 1
SERIAL3_PROTOCOL == 5
SERIAL3_BAUD == 5
SERIAL3_OPTIONS == 0

I’m using Pixhawk Cube Black. It connects to the GPS1 port on the pixhawk. wiring diagram as below

GPS Pixhawk Cube GPS 1 port
Vcc Vcc
Gnd Gnd
Tx1 Rx1
Rx1 Tx1

note: I’m powering the Pixhawk with the usb cable. There is no power input. would this be a problem?

Try:
Vcc Vcc
Gnd Gnd
Tx1 Tx1
Rx1 Rx1

Hi @ramada,

The SERIAL3_BAUD == 5 looks incorrect. This should probably be “57” but it depends upon the GPS being used. Can you provide a link to the exact GPS being used?

This is also a good suggestion, as sometimes UART peripherals have inconsistent labeling.

1 Like

Hi; @rmackay9

I typed wrong. It will be 57.

@amilcarlucas I tried but nothing changed

I guess I will wait for this issue to be resolved with the next update.

Hi Ramada,
I have only tested the UM982, not the UM980, although I expect them to be very similar.
I assume you are using a single antenna? In that case GPS_TYPE=24 is correct. The SERIALn_BAUD doesn’t matter as it will auto-baud.

From the picture you gave you are using git version 12c24df4 which does have UM98x support, so it should work now.
Have you tried connecting with the Unicore “UPrecise” windows application? That is the Unicomm equivalent of the u-blox “UCenter” tool. It is useful for testing you have the GPS module working. I used UPrecise-V1.0.639_EN.exe
Cheers, Tridge

1 Like

UPrecise is available for download here: Download Center_Service support_High Precision GNSS Board|GNSS Modules|GNSS Receiver

Hi @tridge

Unfortunately I still can’t run it. When I connect gps with Uprecise, I see satellite numbers and connection type.