About compass parameter x, y, z, fit

Hi, I’m using the Pixhawk4, and ZED-F9P RTK module.

I have finished assembling the drone, and I am in the process of calibrating the compass.
At first, no matter how many times I did it, it didn’t finish and the gauge went back to the beginning. After several attempts, the compass calibration was successful.
However, the numbers of x, y, z, and fit that come out are constantly different, so I don’t know which one is the most accurate. So I ask a question.

How should the x, y, z numbers come out at the end?
I’m guessing, does fit mean the final score of the last calibration? So, is a higher value of fit better?

Thank you for taking the time.
Your words will be of great strength to me.

Depends on where you are on earth.
They (offsets) shouldn’t deviate so much between calibrations.

No, they are offset values. A higher fit is better.

I’m writing again referring to you.

the offset of x, y, z on picture I post is okay?
I saw someone has z parameter more than 1000.

I wonder positive range.

Yes, its fine. Don’t worry. If they are not within reasonable range, you cannot calibrate your vehicle at all. Do some test flights manually at lower altitudes and in some semi autonomous modes like loiter. If you see any irregularities during flight, post the log.

My anxiety is decreasing a little. Thank you so much.
I was going to go out to fly when the sun rises, but it’s supposed to rain. If there is a problem after the flight, I will come back again :smiley:
Thank you so much for your help.
Wish you all the best.

1 Like

I’m back with bad news
I went out to finish the flight quickly before it rained, but a ‘Check mag field’ message appeared on the mission planner and I proceeded to calibrate the compass again. However, if the calibration is not completed properly and the gauge is full, it returns to zero and fills again.
Subsequently, only values ​​with a magfield parameter greater than 4000 were measured. It was the same no matter how many times I re-calibrated (a total of 8 compass calibrations were performed).

The test site is conducted in a place where there is only a distance from metal and grass, so I judge that it is not a problem of location. It seems to be a problem with the structure of my drone.
I’ve never studied electricity or electronics, so I’m asking for help.

My drone is a DJI F450 aircraft, and I use a Pixhawk4 as an FC.
A ZED-F9P (RTK) module was used to connect to the Pixhawk4, and structurally stacked on top of the Pixhawk4. And the GPS antenna is located on it.
Pictures are attached for easy understanding.

The gap between the first and second floors and the gap between the second and third floors is 2 cm. Each layer is a plate printed by a 3D printer, and the component is PLA filament. A support such as a column is a plastic support made of nylon. (I used a metal support, but I had a ‘compass offset too high’ problem, so I changed it to plastic)

Is there a problem with this structure in the opinion of the majors?
I ordered the same support 50mm to see if it would be okay if I lifted it up.

How can I fly this drone… :frowning:
I sincerely hope for your help.

Does that GPS module have a compass?
Can you set LOG_DISARMED = 1 then post a link to the .bin log file. You’ll need to upload the .bin file to somewhere like Dropbox, share it and copy the link in here.
Also post a new screenshot of that compass calibration screen with everything powered up. The last screenshot only showed one compass and that was internal to the Pixhawk4

EDIT: see if you can be outside with a GPS 3D fix for gathering that log.

Yes. There is a compass in the GPS module.
Just in case, there will be no log by re-uploading the firmware. As soon as the rain stops, I will post the .bin file after calibrating the compass with GPS 3D Fix.

The first screenshot you posted is correct. Only one GPS is picked up. However, you can check that the GPS is caught on the main screen.

In addition, this is the screen confirmed in Mission planner by connecting RTK to COM4 port and pixhawk4 to COM5 port.


I got the 3D Fix indoors, so it doesn’t show the exact coordinates. (GPS re-radiation used. Of course, compass calibration was done outdoors!)

I also had my doubts that only one GPS was caught. If so, did the Pixhawk4 not recognize the RTK and calibrate the compass only with the internal GPS, causing this problem?

You mean only one compass?

Yes. I can see only one gps same as 1st picture.

You are using the wrong names.
You do only have one GPS, but you should also have TWO compasses - 1st is internal to the Pixhawk4, the 2nd should be on the GPS board.

You need to get that second compass working, and disable the internal compass.
Then calibration should be easy.

Oh my gosh, I misunderstood!
This ZED-F9P module doesn’t seem to have a compass.
Therefore, it will be 3D Fix, but only the internal compass will be captured by the compass.
Even if I search the ZED-F9P official manual, there is nothing about COMPASS.

I tried to improve accuracy by using RTK instead of regular GPS.
Everything went wrong with my project.
I can’t use a compass with this RTK GPS, right?

So, do I need to have an internal compass (in PIXHAWK), an external compass (another GPS), and an RTK to use RTK on my drone?

yes. The internal compass is usually not precise enough.

You are using RTK GPS because you want precision. To get precision you need an external compass.

1 Like

I have one more question.
3D Fix (coordinates) uses RTK GPS coordinates, and I want to use a different gps only in compass.

However, the GPS with compass will also receive coordinates. How do I turn off the GPS, not the compass?

To disable the compass, I can disable one gps on the screen (compass of mission planner) in the top picture, but what about the gps?

Just do not configure it. Or even better do not connect it. It will have two plugs, one for the compass one for the GPS, do not connect the GPS plug.

1 Like

Sorry, I can’t understand it.

Two plugs seem to be talking about GPS using two terminals, GPS and I2C. right?
But the GPS I’m using is a GPS 10-pin and has an integrated buzzer and switch. I can separate the buzzer and the switch, but as shown in the picture, the TX, RX, SCL1, and SDA1 pins seem to be in charge of GPS and COMPASS. What should I do in this case?

In that case, just do not configure the GPS, but do configure the compass

1 Like

Sorry again. I don’t know the way.
I’ve never used compass and gps separately before. How can I configure compass but not GPS?

GPS is configured in the full parameter list screen.
Compass is configured in the compass calibration screen.

Just do not configure the GPS.