Servers by jDrones

800 size Gasoline Heli - Pos Hold Help needed

You never answered my question regarding balancing your rotor system. Do you statically balance the rotor system? I pull my entire rotor head with shaft off of the heli and put it into a prop balancer so the shaft is parallel to the ground. Of course the blades have to be tightened down and ensure they are extending straight out from the hub. then see which blade falls. You know that is the heavier side so you will have to add weight to the opposite side. monocote or tape will work.

How do you balance your rotor system?

Sorry I missed that. No I have never done that extensive balancing.
All I’ve done till now is I’ve physically weighed the blades and added weight if needed, also I’ve Balnced each blade to balance at the same point in the Centre of the blade by adding weight like tape. Also balance the flybar rod and flybar so it balance in the correct Centre where the seesaw bolt hold it.

Is what you mentioned above, is it called dynamic balancing?

Sorry I’d missed out on that. Will do your method tomorrow and check too.

Kind regards,
Adarsh.
PS: Any input for me on the rubber vib damper for mounting and the stator gator?

No it is not. Dynamic balancing is where you spin the rotor system and a computer tells you where to add weight and how much.

This is not good enough.

This is good. But you may want to pull the blades off and check the flybar as installed in the head using my prop balancer technique. Then install the blades and balance the blades as installed on the rotor system.

I have my Pixhack V3 mounted on the foam that comes with the old Pixhawks. It works pretty well. I would be careful with the cheap plates the the rubber isolators. You might want to get a little stiffer rubber isolators. I have used the thinner double sided rubber foam tape. 1/8 inch thick would be good.

Truthfully though I think the smoking gun is that you didn’t statically balance your rotor system. I think that will make a Big difference.

I don’t know much about the stator gator. If it is a simple Hall effect sensor then it should work fine.

The V5 is better, but not by much. This thread should help

Bill, tried the PSC_VELXY_D gain as you advised. Started with 0.1 and increased it by .1 every time. The Loiter definitely got better but what it did was it delayed the tbe. It stayed in the position for a bit longer and delayed the tbe. But eventually it got int the tbe. The 0.1 did not make any difference, .2 made it better but .3 made a visible change. And .4 even better. But when we tried 0.4 it was in the position for some time and the tail gave in and the nose turned by 90deg, dint want to take a chance so took over to stabilize mode and landed the Heli.
After that wanted to try 0.5 but the tail never got to stay in the heading. It was not safe to fly. Tried many yaw rate and ang parameters but the tail never held. Will look in to it on Monday and update.
But the PSC_VELXY_D gain definitely helped. It delayed the tbe effect for some more time.
Next week will work on the head balance as you suggested.
Will post the log and a short video of the Loiter in sometime.

Thanks a lot Bill. You’ve been very helpful.

Kind regards,
Adarsh

Hello,
Bill here’s the short video of the loiter mode, not sure if it was .3 or .4 of the psc D gains. If you see it held on the position for a longer time and then slowly it started building the TBE and also the tail gave in and changed the heading.

Also heres the log file link, again not sure if its with .3 or .4 psc D gains.
Monday i will start looking at balancing the rotor head and give it a over all maintainance. The Bergen helis asks for a very very regular maintainance, especially the drive train and the clutch.
The psc D gains, was i going the right way? Will try all the gains for the tail when i start flying, if nothing works, will put a GY401 external gyro to the heli. Also the tail servo i’m using is a align 655 and is heating a lot. Which tail servo would you use? most of the tail servo are in the 760 band and which i heard is not compatible with pixhawk, looking for a 1500 band tail servo, what do you recommend?

Thanks for all you help, without it, i would’nt have come so far.

Thank you and kind regards,
Adarsh

Adarsh,
Your tail isn’t set up properly. You are running out of integrator. Look at this plot


See how the integrator signal is flatlined at the IMAX value. If you look at you heading, it is more than 20 deg off from the desired value

So you need to do one of two things. First option, you could increase the IMAX value for yaw axis. Now that will allow the integrator to hold more but that can be a problem when making quick yaw movements because if it is holding a lot of integrator in one direction. it then needs to bleed it off and then after you stop put it all back in to keep the tail aligned with the desired. The other option is changing the mechanical rigging of your tail. Effectively taking up the control input required in a hover by retriming the mechanical linkages to have the neutral or trim value of the tailrotor pitch be closer to or at the value used in a stable hover. therefore it will reduce the amount of integrator being held. I would do the latter. You could adjust the mechanical linkages closer to the hover value. I think it is fine to be holding a little integrator in the hover (maybe 0.1 or so). Plus changing it mechanically gives the tail more control throw in that direction.

Ardupilot supports 760 servos. However you have to set the min, max and trim servo values before connecting and powering the servo. Otherwise you will burn up the servo. I believe min is 600, max is 1000 and trim would be 760. I am not as familiar with those servos.

Adarsh,
I’ve been meaning to put together a short video on statically balancing a rotor system. And I was able to do that this weekend. See the video below. Hopefully it is helpful

3 Likes

Thankyou very much Bill for the balancing video… you don’t know how helpful it’ll be for a novice like me. Thankyou sooo much.

As per your advice, I adjusted the linkage of my tail push rod so it changes the neutral position (also accordingly set the sevo4 so it dosent bind) with the same yaw imax (0.33) the tail held well and psc D gain at 0.5 (last time I couldn’t test the 0.5) I put the Heli on the Loiter and it did very good… Left it in the Loiter for around 60secs and the tbe dint happen. Wanted to leave it for more time but the engine note seemed to change, so took over and landed the Heli.
For the next flight I increased the yaw imax from 0.33 to 0.4 and did another flight in Loiter in this case there was a very very small tail wag but totally manageable, so went back to the previous setting of 0.33.
Will start working on the engine tuning tomorrow.
Next immediate task is getting to balance the rotor system.
And thanks to you, now I know the correct way to do a static balance on a rotor head. Will get to it.
Posting the log file and the video in sometime.

Thankyou very much Bill. Very much Appreciate your time and effort to help me out.

Kind regards,
Adarsh

Hello Bill,

Heres the log file, but i’m not able to find the video file, i thought it was on my phone. Will get it in the morning and post.

Herers my log file.

Thanks and Regards,
Adarsh

Hello Bill,

Thank you for all you help Bill, without it, i would’nt have been able to reach even till here.
Thank you very much.

I had a flight today and put it in loiter mode and kept it there for more than 4 mins and it stayed there holding position and altitude pretty good, it was quite windy too but the heli held the position good.
One doubt, few years ago i had done a nitro heli with pixhawk and tried the loiter mode and could barely move the heli inspite of giving a lot of pitch and roll input from the transmitter, hence i was told to fly in pos hold instead so we can have good control on the heli. But now with this heli, in loiter mode, just a touch of the controls moved the heli. Is this normal?

Here’s my log file and video.

Again Thanks for your help Bill, appreciate it very much.


02-06-2020.param (14.7 KB)

Kind Regards,
Adarsh

You’re welcome. Glad to see you getting some progress.

Yes this is normal for arducopter 3.6 and later. In 3.6, the loiter mode was completely redone. It was to make it feel more like poshold but retain the velocity command. Where as poshold is attitude command or exactly like stabilize when you make stick inputs but when you center the stick it povides position hold.
Logs look pretty good. Did you balance your blades yet?

You’re welcome. Glad to see you getting some progress.

[/quote]
Yes this is normal for arducopter 3.6 and later. In 3.6, the loiter mode was completely redone. It was to make it feel more like poshold but retain the velocity command. Where as poshold is attitude command or exactly like stabilize when you make stick inputs but when you center the stick it povides position hold.
Logs look pretty good. Did you balance your blades yet?
[/quote]

Hello Bill,

Yesterday removed the whole rotor assembly and put it on the prop balancer as you advised. One side was a bit heavy, but not that much, just a small tape with cyno did the job. Now seems like its balanced. I made a video of the balancing yesterday, for some reason that memory card is not opening the file. I’m on the job, Will post as soon as i recover the card.
Today, i did a small two waypoint mission, just one straight line as the place was a bit tight.
As i started the auto mission, the tail gaveup and did a left yaw about 30 odd deg, and then again corrected itself and flew to wp2 smoothly. You can see that in the video. I think i have to shift the neutral of the tail slider some more as you had suggested previously. Is it that? or something else?


What is the diff between Pos hold and loiter? Dosent both do the same thing? Both modes when your sticks are in neutral holds the position and when given input the heli moves in that direction and when sticks set neutral again it takes the new position. Isnt it? or am i mistaken?
Also, one important question on the fail safe. I use a spektrum remote receiver on the pixhawk. I have binded the receiver with the collective trims (pwm) below the normal flying position. On the ground when i check, I switch off the transmitter the gcs says failsafe but also says disarmed. I am a bit scared to try it in air thinking what if it disarms in midair. What is the correct procedure to do fail safe and how do we check on the ground if its set properly?

Tomorrow am planing to do a rectangular waypoint, but not sure if i should do RTH as the last wp or just give the home location as the last point and take over and land it in manual mode. Planning this activity in a larger open field. Any advice for me?

Here’s my log file of the flight.

Thanks and regards,
Adarsh


Your Integrator is still saturated. You haven’t adjusted the tail enough mechanically to fix the integrator problem.

They don’t control the heli the same way when the stick is not in the neutral position. As you said, with the stick in the neutral position, they both are holding aircraft position over the ground (doesn’t allow the aircraft to drift). when you move the stick out of the neutral position they are designed to do different things. From my understanding of POSHOLD, it is design to command pitch and roll attitude just like stabilize mode does when the stick is not in the neutral position. Loiter is designed to command translational rate over the ground in the direction you displace the stick. Big difference!

best way to test this is to arm the aircraft without the engine running. enable motor interlock and let it think the rotor is spooling up (wait until the H_RUNUP_TIME expires). Lift the collective and make it think it is flying by raising the aircraft off of the ground. Be sure to raise it at least to your shoulder level so it is showing the altitude change. then turn off the transmitter and wait 10 to 15 seconds. you should get the failsafe displayed in the GCS and then the mode should switch to RTL.

It is probably a good Idea to switch to RTL for the first time from stabilize or loiter with the aircraft hovering about 30 ft off the ground and monitor it as it conducts the return home and landing. If it does the landing with no issues then it will be fine to put the command at the end of the mission.

Hello Bill.

Thankyou for all your inputs. Finally i put the heli on the autonomous miision and the heli did perfect.
First;
I moved the neutral position on the tail slider mechanically.
Took off and climbed to around 10m in loiter mode and engaged RTL to check if the heli behaved, it did RTL perfectly.
Next checked the fail safe exactly how you advised me, it said no rc receiver and switched to RTL mode without disarming.

Put a simple small 5wp rectangular mission and put a 5sec hover delay at every wp. Default of 15m altitude and speed of 3m/s. Also between wp2 and wp3 i put a 25m altitude and between wp3 and wp4 back to 15m. Wanted to see how the heli responds to climb and descent.
First time i did a manual take off in stabilised mode, switched to loiter mode to check if its holding position, climbed to the default 15m altitude and then engaged auto, the heli did exactly what it was intended to do and did it perfectly and came back home and landed and disarmed itself.
Next wanted to try auto take off too for the same mission. but forgot to put the take off as the first wp, Started the heli, waited for the rotor rpm and hit auto mode. The heli tilted to the right a bit ( the wp1 was to the right of the heli) but took off safely ( it was scary) and headed to wp1 and finished the mission and landed.
Except for the take off scare, everything went smootly. There is some small wag in the tail, i checked the I gain, this time is wasnt flat lined. Will have to see to the tail.

Thank you so much Bill, Heres the video and the log. This has motivated me to work on another similar class heli but this time with a flybar less head.

Thanks again Bill.

Kind Regards,
Adarsh

You’re welcome.

Looks like that centered it enough to keep the integrator from saturating.

There was a bug in 3.6 that sets the not landed flag as soon as you enabled motor interlock. That is what caused the Heli to launch without a takeoff command. Since it already thought it was flying it proceeded to the first waypoint. This was fixed in copter 4.0. Looking at your log though, this could’ve happened with the way you set your collective stick prior to setting auto flight mode. The logic that sets the not landed flag relies on collective position being below the mid collective pitch. So it is always a good practice to keep the collective stick on the bottom stop until auto mode is set. that way it will fail the auto mode change if there isn’t a takeoff command. Unless there is some other reason you need to have the collective stick no on the bottom stop.

Hello Bill,

Seems like i have to move to 4.0 soon. I dint wanted to change anything as its flying good now. I have a demo to give next week, maybe after the demo i will change over to 4.0.
About the auto take off, I’d read earlier somewhere that to do auto takeoff, you need to keep the collective at half (or above 30%) and then hit auto and it starts the mission. I did this two years ago, but i think i had added the first waypoint as take off and given the altitude as some 35m… Then, the heli climbed straight up to 35 m and then headed to wp2, i dont exactly remember though…
If i give the first waypoint as Take off and and then as below screenshot as the mission, will it help? Will this take off the heli straight up to the desired altitude and then head to the next wp?

Thanks & Regards,
Adarsh

So you always want to have a takeoff command if you are starting with the aircraft on the ground. But instead of raising the collective before setting auto, it is better to set auto and then raise the collective. If you do as I suggest, it will not allow the flight mode change to auto if you happen to forget to add the takeoff command. It is a safer way to operate the heli. And a short explanation as to why the collective needs to be raised when going into auto. It tells the flight controller the start the mission. Instead of using the collective, you could always use the start mission command in the actions tab in mission planner. You would select the auto flight mode and then initiate the mission with the start mission command. Instead of raising the collective.

Understood and noted Bill. Will add the ‘take off’ command from hence forth. This bad habit i caught cause i flying a fixed wing last few months and always did a manual hand launch and then switched to auto. Ok noted, take off command first.

Dint know you could start the mission from the mission planner too. The tab of start mission is it in the action tab? (pls screen shot below) Or am i wrong?

Kind Regards,
Adarsh

Servers by jDrones