800 Gas Helicopter Governor help

Futaba sensor works, confirmed.
Also consider the Graupner sensor, much cheaper but same reliability.

1 Like

Two magnets give double the number of samples for the filter in the rpm library and generally works better than just one magnet.

I’m not actually sure on this. The temp sensors we use are FrSky items and send the temperature data to the RC radio, not the ground station.

Thanks just installed the Futaba 701 sensor today.

Kind regards,

Thankyou Chris.
Just installed the two magnets today, epoxy is setting as we speak. Couldn’t install it on the main shaft, hence as your advice installed it on my the main gear.
The orientation of both the magnets are the attracting side on top (outer) for the sensor to sense… (does it make a difference?)
I Should be testing out the head speed tomorrow morning. Is there any changes I should make or do in the params for gov?

Using a Futaba on these machines, will get a Futaba temp sensor for these for now… but it would be great to have a temp coming on the ground station along with other parameters.

Thank you again.

Will keep you posted tomorrow after the flight…

Kind regards,

Yes, you’ll have to set those accordingly. The throttle curve has to work right first, as the current ArduPilot governor merely applies a correction to the throttle curve for density altitude. And it relies on the throttle curve being properly set in the case where the rotor speed sensing might fail in flight.


I started the heli with the futaba sensor connected to Aux5 but it was not showing any rpm, i armed the heli and started the engine, after a few seconds i got an error saying “INTERNAL ERROR 0X2000000”. and the heli disarmed itself. Please see attached screen shot of the error. This happened everytime i used the futaba sensor to aux5.

I removed the futaba sensor and put in my stator gator to aux5 and started the engine, the GCS was showing some rpm (engine rpm of around 3000 and when given power the rpm was going to around 14000 (it was run without blades) ) but i did not get the error this time and neither did the heli go to failsafe.

Connected the futaba sensor back to aux5 and started the heli, the heli after a few seconds again displayed the same error message and went into failsafe. Neither did i get any rpm display on the GCS.

I checked the sensor proximity in futaba gv1 in sensor menu and it is showing 97% so, there is adequate signals coming from the magnet and sensor.
I am still trying in mode-3 that is throttle curve not yet gone to governor mode.
What else could be the problem?

Kind Regards,

Do you have the futaba sensor wired right for power/ground/signal and not plugged in backwards? Maybe post the settings in your helicopter (param export) to see how you have the aux ports configured, might be helpful.

The sensor is the stock sensor from futaba 701 and i have not done any crimping or soldering, so should be ok i;m guessing. Checked, The ground wire’s orientation is towards the top side of the pixhawk (cube side) thats how all the servos are connected.
Still the same error. Even when on the ground and when the engine is on, when i rotate the main gear so that the magnet (in which i’m getting signal to 97% in futaba gv1) is top of the sensor, even then the error is showing up. So it is not the ignition or any harmonics from the engine or ignition, it is the sensor doing something.
I’ve herewith attached the param file for your kind perusal.
Again i tired the stator gator, i am getting the rpm displayed on the gcs and no error. But the rpm displayed is aournd 4000 in idle and when given power it goes beyond 10000 and the rpm display is going to -1, hence i increased the max rpm from 10000 to 100000.
I even enabled the governor mode and tried, but nothing. All this was done with blades off.

What could be the problem?

Thanks & Regards,
10-12-2020.param (18.5 KB)

The main thing I wanted to see is if the relay pins are configured correctly, and it appears they are. According to Ferruccio that Futaba sensor should work so I’m at a loss to explain why it doesn’t. Your problems with the stator gator I’ve seen before, so that’s nothing new. Those things just have a really noisy circuit.

@Ferrosan any ideas why Adarsh’s Futaba sensor is doing what he describes?

@ChrisOlson @Adi_Fly the sensor from Futaba I have is this one (was included in the GV1 package):
same as the sensor provided with the 701 I believe

I had a look [here] (https://github.com/ArduPilot/MissionPlanner/blob/master/ExtLibs/Mavlink/Mavlink.cs#L3053) about the 0x2000000 internal error.
Maybe can you post a log?

Yeah, that error didn’t appear to be related. But why it happens with one sensor and not the other is confusing. Unless there is an electrical fault in the hall effect device.

Sorry, posted the wrong link : https://github.com/ArduPilot/ardupilot/blob/master/libraries/AP_InternalError/AP_InternalError.h

For some reason it is upsetting the isr, so might be faulty as Chris said .

Yeah, I don’t really know. That pin is configured as an interrupt for a hall effect speed sensor. So it’s a 0 or 1 signal, which trips the interrupt flag for that pin to interrupt the cpu to execute the routine. Doesn’t make sense as to why that should crash it.

@Ferrosan and @ChrisOlson
Yes it’s the same sensor you posted the pic above, came along with the 701 and it was new and unused. But the sensor when hooked to gv1 is showing 97% on one magnet.
Is there any correct way / orientation to install the magnets. What I did is I let the magnet attract each other, which ever surface stick to each other I marked those surfaces and while installing it on the main gear I installed it in such a way that the attracting surface (marked surface) is installed outer so that the sensor can sense that magnet side (I hope in clear :slight_smile: )
When I hook the gv1, in the sensor menu, on one magnet it shows 97% and nothing on the other magnet. Is this hr correct way to install or how?

I’ll try and get the log file as I’m not going to work till Monday, let me see if I get the log file from someone.
Have ordered the aerospire and align Sensor, will replace the Futaba with them and try t once o get them…

Thankyou to both of you. Will keep you updated on the same.

Thanks and regards,

I tried that Futaba sensor and couldn’t get it to work.

here another user with the futaba:

Might worth to try using a logic analyzer, that will provide info about voltage level and signal.

Actually, as far as that goes, I used the GV-1 back in the day on my nitro heli and it didn’t work all that great, period. The only way I could get it to work at all was to use the RSC_SETPOINT feature and the rpm was all over the place. The old three-point throttle curve worked better than the GV-1.

I used the align Governor sensor but no luck. No rpm being shown… either the sensor is faulty or I have installed the magnets wrong.
Is there a correct way to install the magnets?
The distance between the sensor and magnet is less than 2mm.
The align had a different connector, all I did was cut that and solder a servo connector to its end to connect it to aux5.
Lost as to what’s happening!!! :man_shrugging::man_shrugging:

Thanks and Regards,

Take the sensor off, hook it up to either a oscilloscope or even just a multimeter and measure what whappens when you wave a magnet in front of the sensor.

I got the internalError 0x2000000 too with futaba hall sensor
but apm doesn’t disarm

Is that some error for GPIO?