550 Trad heli Pitching, could do with some advice

I’m testing a New (to me) heli that I’ve installed a Pixhawk at 270deg. I’ve got it flying Auto, but I’m getting a sort of slow pitch. I’ve attached a video,file, any help would be welcome

param’s2017-08-13 09-59-52.log.param (13.4 KB)

1 Like

Try reducing your hovering pitch and that will raise your head speed just a bit.

David Ardis

Looking over your rate tuning I’d like to suggest a different method of making the settings for roll and pitch. First set the low-pass filters back to at least 10Hz. You have them set at 4 Hz. Suggested would be 10 on pitch, 12 on roll.

Now set the rate P, I, D gains all to zero for both pitch and roll. Set the rate VFF for both pitch and roll to a level that looks like it provides normal swash response on the ground. Suggest starting with 0.15 for both. Test fly the helicopter, fly it in some figure 8’s, make some fairly quick roll and pitch inputs on the cyclic, etc. Do this only in Stabilize flight mode.

Note: if you get any pitch bobbing with the above settings you have a mechanical problem with the heli - either blades not tracking, blades out of balance, or CG issue. Fix it before proceeding.

Pull the logs from it and look at the Rate in the logs and see how desired rate matches actual rate for pitch and roll. If it doesn’t track desired vs actual rate control, turn up the VFF until the graph lines show the two tracking each other. If the helicopter gets too responsive, then adjust these values down:

Experience says you’ll end up somewhere around 80000 to 85000 for a 550 on those settings. And VFF of .15 to .20, depending on the mechanical rate of your servo linkages and servo speed.

After you get a nice flying heli with the above, tune the PID’s one axis at at time. I suggest starting with roll because it is normally the more sensitive axis. Leaving P and I at zero, set the rate D gain to .003 and do a brief test hover a few inches off the ground. Increase the D by .001 at a time until you get a side to side shake. At whatever value you get the shake at, cut it in half and enter that as the final value for D gain. Enter the same value for pitch D gain.

Do the same thing with rate P gain, except start with .05 and raise it .01 at a time until you get the side to side shake. At the value where you get the shake, cut it in half and enter that as the final P gain value, enter the same value for pitch.

For I gain set it to the same value you used for the VFF for both pitch and roll. Ex: if you ended up at VFF .18 on roll and .20 on pitch, set the rate I for roll to .18 and pitch to .20.

Now, test fly the helicopter again just like you did in your video and see if the problem is gone.

Just for reference sake, and it is unlikely your tuning results will be the same, this is the values I use with a Trex 500 with a DDFP tail mod, stretched to a 550, swinging Rail 516’s at 1,850 rpm with a DFC head.
ATC_ACCEL_P_MAX , 86000.000000
ATC_ACCEL_R_MAX , 110000.000000
ATC_ACCEL_Y_MAX , 27000.000000

ATC_RAT_PIT_D , 0.003000
ATC_RAT_PIT_FILT , 10.000000
ATC_RAT_PIT_I , 0.200000
ATC_RAT_PIT_ILMI , 0.000000
ATC_RAT_PIT_IMAX , 0.440000
ATC_RAT_PIT_P , 0.090000
ATC_RAT_PIT_VFF , 0.200000
ATC_RAT_RLL_D , 0.002500
ATC_RAT_RLL_FILT , 12.000000
ATC_RAT_RLL_I , 0.180000
ATC_RAT_RLL_ILMI , 0.000000
ATC_RAT_RLL_IMAX , 0.440000
ATC_RAT_RLL_P , 0.080000
ATC_RAT_RLL_VFF , 0.180000



Would you suggest this tuning method for a Trex 450 with flybar

David Ardis

No. Flybar is really simple. Just set the P, I, D values to zero and turn up the VFF until you get the proper response on the cyclic for pitch and roll, make sure you have H_FLYBAR_MODE set to 1, and go fly and have fun. The flybar totally takes the place of the rate PID controller.

You can add in a bit of rate I for both pitch and roll if you want with a flybar. And it provides sort of an “autotune” to make it track really nice on auto flights. I use about .12 I gain for my flybar heli’s.

If the flybar heli is too responsive for your liking, or say you want to “soften” one axis or something, you can adjust the Stabilize P values down from the default of 4.5 for pitch and roll, and adjust the angular acceleration rate to your liking using the ATC_ACCEL_P_MAX and ATC_ACCEL_R_MAX params. Typically, for a 450 though, the default of 110000 is usually pretty close for the angular accels.

Being somewhat “old school” myself, I love flybar helicopters :wink:

1 Like

That’s really interesting and it will still to all the automatic stuff.

PS I consider myself very old school started with a Concept 30 28 years ago

Chris, I have been looking at my testing BIN files for setting up my rates, and I notice I did not get the two graphs sitting directly on top of each other. Going from VFF 0.15 to 0.20 it did not move very much, I reached VFF = 0.20 on pitch and roll, how high can I go with this value to obtain a good graph.?

Geoff, the only FBL heli I’ve had to go over .20 is a racing one I set up. Flybar will be in the mid 0.2’s.

Maybe you have reached the limit on what your servos can do for speed with really aggressive stick inputs? I look at the peaks of the rate graphs to see how close they are. If the actual rate peaks are going outside the desired, then it’s too much rate, and vice versa.

What you show in your graph is Attitude desired vs actual, not rate. You have to look further down in the column of logged items to find the Rate section.

What I would do is if adding more VFF doesn’t seem to increase the rate anymore, I would assume you are at the limit of what the servo and mechanical rate can do, and don’t increase it anymore. Probably leave it at the point where increasing it didn’t seem to make any more difference. Then tune the rate PID’s and see how it acts.

That rate is highly dependent on servo speed and mechanical linkage rate. As an example, when I set up my Synergy 626 I ended up below .15 because it has very fast Futaba HV servos on it. So I look at that adjustment as the tuning that compensates for whatever servo speed and mechanical linkage you have, before you tune the PID’s.

Hi Geoff,
Here is what you are looking at, which is attitude desired vs actual, in this case in the roll axis

What you want to look at when setting the fastforward is the Rate des vs actual as shown here. This is with APM Planner2, but I think it’s the same in Mission Planner.

This is the Rate graph for Pitch withonly the VFF set PID all 0

Excellent. You really have to look at the higher peaks to see how it matches up, because that is when you are using the maximum rate. And that graph looks pretty good. What ever you had for fastforward setting there is working. I would not mess with that anymore.

Now that you have it set for what the attitude controller and autopilot likes, you can adjust the aircraft to your liking for manual flying by setting the angular acceleration rates, and using the RC feel. The default for the angular rates is 110000, which I think is a bit fast for a 550 class UAV. Probably more in the range of ~85000 or so. And RC Feel should be at 50 by default. You can make it more more “sloppy” or more “crisp” with that too.

What you have done with the above is insure the aircraft is responding at the rate that the autopilot expects. Now you can tune your PID’s and go fly.

Keep in mind that there is no I gain in hover unless you use the ILMI param. I prefer to not use it myself because I don’t care if it tracks attitude exactly perfect in hover. I’ve tried it with that turned on, and turned off, and staring at the helicopter in hover it’s like big whoop if it’s 3-4 degrees off.

The I-gain for helicopters does not “kick in” until you are in “dynamic flight”, which I think without referring to the code, is something like 2m/s ground speed for more than 2 seconds (or something like that) before the rate integrator leak is turned off. That’s to prevent tipping your heli over on the ground because of I-term buildup.

I’m still waiting for the bolts to fix the gear wobble, due to-morrow, then Saturday looks good for wind, so will test again

When you put those in you’ll note there’s a taper in the holes in the hub and the self-tap bolts are tapered head. That is not a big deal. The nuts for your new bolts should pilot in that taper and put the button heads in from below so it clears the autorotation gear.

And before you put the gear on lay it on a flat glass surface to make sure it wasn’t permanently warped by that fastening method they use.

Did you figure out the cause of this yet? I have a 500 DFC that I recently tuned with 3.5.2, and I have the same problem, just a slight oscillation on pitch axis at random intervals, not constant. Everything else is working perfectly, its just this slight pitch oscillation that I cant seem to solve.

It will also happen if I bump the skids on the ground, it will oscillate for only about one second on pitch axis and then its gone.

The heli is sat in it’s bag waiting for a dry & low wind day to test it. How did you tune it, using the new method? Have you tried it in Auto Mode? Mine flew in Auto OK, except for this slight pitching. The weather forecast is still bad for the coming week. When I can test it, I’ll let you know, if my alteration worked

Ok great, yes please let me know, and I’ll be flying this weekend, I’ll let you know if I find anything that works on my end, my pitch issue looks exactly like yours.

To tune my 500, I tried about 3 different methods, none worked, then I just went back to use most of the methods outlined on the wiki page, and that finally worked. In short, here’s what I did:

  1. Installed 3.5.2
  2. Used Rob’s method for blade/swash setup, and made sure blades are perfectly balanced.
  3. Zeroed out all PIDs for pitch and roll
  4. Reduced Pitch and Roll filters to 10hz, I think I’m at 10hz for pitch and 12hz for roll now.
  5. Tuned Pitch P first, starting at zero with .01 increments, just lift about 2" off ground and see if there’s oscillation, when you find the oscillation point, back off at least .01, .02 is probably better.
  6. Tuned Roll P next, same as #5
  7. Then Tuned I values for Pitch, then Roll.
  8. I found I cannot use any D term at all on either Pitch or Roll, even a tiny amount results in a nasty oscillation immediately, so just left those zeroed, I think this is due to the speed of my servos, but not 100% sure.
  9. Adjusted initial VFF for Pitch and Roll, just took a stab at it, now that its flyable need to log some data and see how close it is for pitch and roll, and adjust both as needed.

And yes, it flies really nice already, I have no trouble hovering or doing slow maneuvers in 10-15mph wind, altitude hold works, so does position hold. Haven’t tried flying any waypoints yet, want to get the remaining tuning issue resolved first which is just the slight pitch oscillation same as yours.

Did you try Chris Olson method for tuning, (third post on this topic) I found it a lot better than the old way. It lines up your disired roll and roll a lot better, using the VFF to adjust it. You check it with the RATE param in the log file. You also end up with a D setting. Alter the settings in the full param list, not on the Mission Planner page.

Yes, I used pretty much the same method except I tuned the PIDs while hovering first, I want to try adjusting the VFF rates next using his method. I didn’t have much control over it with everything zeroed out, that’s why I tuned the PIDs first so its more flyable before I try to log some pitch/roll data. And yes I’m only adjusting values directly in the full parameter tree, not the setup tabs. I still don’t think I’ll be able to use any D term, it just won’t tolerate any damping at all, but we’ll see.

My CG was slightly tail heavy, so adjusted that, will find out this afternoon if that’s the cause of the remaining pitch oscillation. I do also have a little slop in the swash plate, wondering if that could be an issue as well, otherwise, upper and lower bearings on main drive shaft are fine, there’s really no play at all in them.

I had been using the wiki method. The method that Chris Olson outlined is much safer and produces great results. I was not able to increase my D gain all that much using the old method which is why I started playing with notch filtering. The notch filtering worked very well in my case but had varying results for others that had tried it. I retuned my heli without the notch filter using the method that Chris outlined above. If you zero the pitch and roll PIDs and start with the VFF gains at 0.15 (be sure FF_ENABLED is 1), you will have a very safe and flyable aircraft. Then tune the PID gains according to how Chris describes. I definitely ended up with being able to have a little D gain and P gain with this method.