433MHz radio loosing connection to Pixhawk 2.1 frequently

Hi,

TLDR:

My 433MHz SiK radio does not stay connected to my Pixhawk flight controller and it drops frequently. What could be the issue? I have tried a lot of things and nothing worked.

Long story description:

I have Pixhawk 2.1 Black Cube connected to HolyBro 433MHz 500mW telemetry radio. I made sure to place it far away from the flight controller and the other end is connected with the USB cable to my computer and the antenna is held high above the ground. I also made sure both devices have the latest firmware and both are transmitting the highest possible power. Also, I am using QGroundControl.

I keep losing connection frequently even though the quad is on the ground. When it takes off I may be connected for another 20s and then it drops. Sometimes it recovers briefly. I believe I should be able to clearly see all the telemetry information with no interruption unless the drone is more than 500m away from me, shouldn’t I?

What is the problem here?

In another thread, somebody has mentioned the telemetry radio should not be powered from the flight controller but rather externally. What does it mean? Should I cut the 5V and GND wired and connect it directly to a 5V source?

I am hesitant trying that because shouldn’t the Pixhawk Cube be able to power one device such as telemetry radio? (I have no other stuff connected to it) Also, I wouldn’t like to mess up a cable if I don’t have to.

Many thanks for all your help!

1 Like

Same brand (Holybro), same model (433Mhz 500mw), I have the same problem. I haven’t found a solution for now.

The solution is another radio. The 500mW Sik radios are cheap noise ridden craps. Get a 100mw one without the power amp, those supposed to work more than 500 meters.

Other things to try : Disconnect CTS/RTS wires, no need for them. power radios from separated power source, not from the FC. Check your antennas, get somebody with an antenna meter, usually the crappy ones that come with those radio are NOT tuned for 433Mhz. Also check output power with a power meter.
You can try lower power setting, perhaps full output power overdrive the power amp stage.

But frankly, the best solution is to get rid of them, get a 100mW one or if you want long range get an RFD900 or RFD868 modem pair.

1 Like

@Eosbandi many thanks for your reply man!

I have got the 500mW one thinking it would actually get me more range. Are you saying the 100mW are generally more stable, why? Could I maybe bring down the power from 500mW to 100mW on the one I have?

Or is it just that the radios made by Holybro are crap in particular?

Thee RF chip used in Sik radios are 100mW by design. higher power radios put a power amplifier at the output to get higher output, but there is two issue with these designs.

  1. They not matching and filtering the amplifiers to it, so it not only amplifies the signal but spitting out a tonne noise and distorting the signal as well.
  2. To handle the power amplifier correctly the firmware should be modified (counting with PA ramping time and a number of other things)
    The result is that these radios are actually provide shorter range than a 100mW version.
2 Likes

@Eosbandi has very good points about these cheap clones of 3DR’s original.
Get RFD if you want range and reliability.

In the short term you can help what you have with a couple of easy steps.
1: don’t power radios from the flight controller. Provide the radio with its own clean power supply.
2: they usually come with very crappy antennas, so putting on a decent antenna can help a lot.

The long term solution is to just get decent radios, and RFD radios we know give what is expected.

1 Like

@Eosbandi, @mboland, It was very useful. Thank you so much.

Delete, wrong thread…