4.4.0 beta4 MP mission, end up with GYRO NOT health warning, any idea?

I tried 4.4.0 beta4 MP mission, end up with GYRO NOT health warning, any idea?

FW: 4.4.0 beta4 (self build with VTX changes)
HW: H743 Dual BIM270(Matek H743 slim variant board) + BN880
LOG: 2023-08-02 17-09-06.zip - Google Drive
Video: Ardupilot 4.4.0 beta4 Mark4 + MP + 路点巡航_哔哩哔哩_bilibili

a) MP warning gyro not health at the end of mission
b) It can’t be armed again when landed.
c) cold boot tried it seems didn’t work.
d) warm boot again it seems ok.

NOT sure what’s going on here, any idea?

I googled but it seems quite different .

Don’t see this with a few Matek H743 boards. And a post from 2014 is irrelevant. That post was about an APM 2.5 Flight Controller…

I’ll venture a guess that it’s a hardware issue where the “variant” you’re using isn’t exactly matched with the Matek hwdef.


As there are quite a few points make me believe that it’s NOT a hwdef issue.

a) I have did a check of this variant board hwdef, SPI, orientation. And it can be recognized by ardupilot, working fine with acro.
b) I have configured to use both gyro. So if the there is something wrong with orientation, it should error from the begining. I think it can’t be armed.

— From this video, —
c) 80% of the mission, gyro works fine. And it reported warning message at the end of mission.
d) when landed, it can’t be re-armed, even cold boot.
e) with multi-reboots (cold boot, warm reboot), it works.
f) fly in acro mode without a problem.

Doesn’t sound convincing.

Doesn’t sound convincing.


Any logical analysis can give me a light?
Or log data shows that orientation conflicted?