4.3 DEV can't connect thru esp8266 wifi

Since i installed 4.3, latest to try the s-curves, the only way to connect to pixracer is thru the usb cable, wifi telemetry is not working anymore, tried the beta of mission planner, mission planner for android, qgroundstation mobile and desktop, no dice.
Anyone else with this problem?

I think the answer will be in this discussion…

Several responses have clarified the problem and resolution. The current firmware defaults to Mavlink2 protocols. Old ESP-8266 WifFi adapters including ESP-01 had firmware-1.1.1.bin which only supports Mavlink1. You either have to update the firmware on the ESP-01 to 1.2.2 or change the configuration on ArduPilot to support Mavlink1. The better solution is to update the firmware on the ESP-01 because firmware-1.2.2 provides better overall functionality. I am attaching the firmware and simple tutorial.
How to Update Pixracer firmware to ESP-01 (ESP8266) WiFi module

If you have firmware 1.0.4 or greater installed, you can update using the ESP’s Over The Air Update feature. Just connect to its AP WiFi link and browse to: You can then select the firmware file you downloaded above and upload it to the WiFi Module. IP adress in AP mode is used, because it is first IP adress in C type network that is using 24-bit mask. (Before you begin, download the current ESP-01 Pixracer firmware.) As of 20220729, that is firmware-1.2.2.bin.)

  1. Insert ESP-01 (ESP8266) in Pixracer.

  2. Power on Pixracer.

  3. Connect computer to ESP-01 WiFi

  4. Open Chrome or other suitable web browser.

  5. GoTo

  6. Choose file (firmware)

  7. Select “Update” and wait until complete.

  8. Useful links: (menu)

firmware-1.2.2.bin (325.0 KB)


That fixed it, Thanks!