4.1beta7 Crossfire support

Hi, not sure if it is normal but while I’m trying to get telemetry from crossfire nano rx connected to H743, I noted that if I set serial7_protocol to 29 (crossfire), I can get lot of informations back to my RC like GPS coordinates an so on. But then my FC does not recognize anymore my radio channels. Instead, if I set serial7 to 23 (RC IN), I can have my radio channels working but I got then less telemetry informations. Maybe it is normal as the receiver can’t manage lot of telemetry data in the same time of rc channels or maybe am I doing something wrong.
Thanks for help.

29 is only for VTX control via CRSF, you should always use 23 if you are using an RX

What you are seeing is likely as you suppose - a bandwidth limitation meaning not all data can be sent

Thanks a lot. Does that mean that I could be able to choose which telemetry data is being sent by RX ?

No - it should all get sent eventually. What is missing?

All those:

With protocol set to 23 I only got those:

Are you using yaapu passthrough?

Hi, I tried with and without with same result: If I set serial7_Protocol to either 10 or 23, I can’t get any telemetry into yapuu widget but if I set serial protocol to 29 then telemetry comes to the widget but I loose all RC channels like previously explained. What I did to test yapuu passthrough was:
set SERIAL7_PROTOCOL: tested with 10, 23 and 29 (I use Matek H743 FC with Crossfire nano RC connected to TX6/RX6 which is mapped to Arducopter SERIAL7 like described here: http://www.mateksys.com/?portfolio=h743-wing#tab-id-6 )
set RC_OPTIONS to 288 to add CRSF telemetry passthrough (was 32 initially and set it to 288 according to yapuu instructions here: Passthrough telemetry over CRSF (crossfire))
set CRSF support = ON on config page of widget
I tried with both current and beta yapuu builds without success. I’m using arducopter 4.1 beta 7.

Telemetry is limited when passthrough is enabled (RC_OPTIONS 256), but should not be when passthrough is disabled.

Well, I probably misunderstood something…I though that RC_OPTIONS=+256 was to enable CRSF custom telemetry. Could you please explain what do you mean by enabling throughput and disabling passthrough ? To be honest I’m a bit lost in this yapuu configuration, despite having read the thread multiple times.

Sorry, brain fart - passthrough in both cases. So yes you are right

Isn’t it the contrary ?

Telemetry is not limited when passthrough is enabled (RC_OPTIONS 256), but should *** be when passthrough is disabled.

The RX has fixed available bandwidth depending on mode, that bandwidth has to be shared between all of the telemetry needing to be sent to the TX. When passthrough is enabled we prioritize the passthrough frame (its a single jumbo frame containing a bunch of data decodable by the yaapu widget) at the expense of regular telemetry (so what the TX would usually see). When passthrough is disabled there are no jumbo frames and so we can send the maximum amount of regular telemetry.

1 Like

Thanks a lot, it’s more clear to me now. Will do more tests to check what is going wrong in my config.

I there Alex. I too have a Matek H743 and I am running ArduPlane V4.1.0dev (acfdf6a3). I am using crossfire on serial_7 with SERIAL_7_PROTOCOL=23 and RC_OPTIONS=256. On my TX16S transmitter, I’m running the “horus_crsf_190b_0.7” Yappu files and ensured that CRSF is turned on in the Yaapu config. I can see my GPS coordinates appear on the lower portion of widget, yet Yappu says “no telemetry data” and “NO GPS”. I can see telemetry values coming into EdgeTX (or OpenTX) such as Ptch and Roll in my telemetry page, yet the widget doesn’t show the pitch and roll. I must be missing a critical step or perhaps this doesn’t work yet. Have you had any luck? I would love to compare notes and appreciate any feedback from anyone. Perhaps I misread something in this blog but is there a tutorial on getting Yaapu working with CRSF? I started my journey from this post now dated back to 2020 Passthrough telemetry over CRSF (crossfire)

telem-sensors (Small) yaapu-config (Small) yaapu-main (Small)

I think you might need to update the widget

Andy thank you so kindly for the reply. Do you know where I can download it? I was under the impression given the web link I provided that I needed to use a specially compiled version of the widget for CRSF support. The newest widget does not have an option in the Yaapu settings to turn CRSF on or off. I thought the official new release was for Frsky receivers only. Any thoughts? Thanks again

@yaapu can confirm but I am pretty sure he has a single widget for all RX types

Hi, I do not use Yapuu Telemetry anymore. Don’t know if it’s due to it but my TX16s bricked few time after installing it (I wasn’t able to start my TX16s anymore despite flashing stock firmware in DFU mode). You can find latest beta Yapuu software for TX16s here (this is the one I used): https://github.com/yaapu/FrskyTelemetryScript/releases Just choose the right release for TX16s: the Horus one
Or you can download official release here: https://github.com/yaapu/FrskyTelemetryScripthttps://github.com/yaapu/FrskyTelemetryScript

Yes, single widget for all RX types!