4-1 ESC No output on motors

I am so tired of fighting this this thing. I have a new 4-1 esc i grabbed off amazon. Here is the link: https://www.amazon.com/SPYMINNPOO-Electronic-Controller-Connecting-Traversing/dp/B09TDCJW54/ref=asc_df_B09TDCJW54/?tag=hyprod-20&linkCode=df0&hvadid=650994118764&hvpos=&hvnetw=g&hvrand=626994289723053888&hvpone=&hvptwo=&hvqmt=&hvdev=c&hvdvcmdl=&hvlocint=&hvlocphy=1026305&hvtargid=pla-1995013681199&psc=1&mcid=dfdc3af0d6e53e2aa61810add38ccacc

I have my servo mapping done, set for dshot, cable made for the inputs, using M1, M2, M3, M4, Curr (connected to pixkawk AUX 1), Grnd (connected to Pixhawk m1 ground), i have tried everythinhg to get some output. I grabbed this due to me origanaly having hobbywing 45A esc that would not suppurt BLHeli.

What’s connected to Pixhawk AUX 1? Post your parameter file and a photo of the connections.

AUX 1 is connected to “C” on ESC.
parmlist.param (16.5 KB)

Very hard to see, but here you go. Thanks in advance.

A few things here:
Disconnect the C (current) pin of the ESC from AUX 1. This is an analog voltage level equivalent to current that Is connected to the Power connector current pin unless you already have a power module measuring current then don’t connect it. You do not want it connected to an output.
The motors, M1-M4 are connected to AUX 1-4.
Your Servo assignments are screwed up. Set SERVO09_FUNCTION thru SERVO12_FUNCTION to 33-36. You have 2 on 35.
SET MOT_PWM_TYPE to 6 (Dshot600)
Set this back to 0 SERVO_BLH_MASK

Then use Mission Planners Motor Test to test motor function, order and direction.

What you should really do is flash the Bdshot version of firmware to the Pixhawk and flash Bluejay firmware to the ESC and configure for Bdshot. Assuming that generic ESC supports it.

1 Like

OK, I have no clue why Motor 2 appeared away from SERVO10. Same result, not motor spin.
Latest.param (16.5 KB)
MSGardupilot.txt (1.5 KB)
Also attached is the Messages from data screen.


And you have the ESC Motor signal leads connected to AUX 1-4? Doesn’t look they were in that photo.

I setg that, but lol, no had motors connected to regular motors 1-4. what should the proper motor connections be, using the moter testg, am getting spin but not in proper order. so much conflicting info, i appreciate your help.

Try BetaflightX for frame_type and test again. But this depends on the 4-in-1 and its orientation. In any case it’s trivial to re-factor the outputs to correct it.

There is conflicting info outside of Ardupilot’s reference sources. Watching some clown’s YouTube channel for example :grinning: