3 pos switch for parachute dont work correctly anymore

Cube, Kore Carrier, AC 3.6.4 ChibiOS, MP1.3.62

With this actual build i wanted to install the 3 pos switch for a servo parachute. But in middle position ( parachute function activation ) the parachute deploy ! no matter if i set the min. alt to 0 or 10m…
i checked the pwm settings on futaba remote: low 950, middle 1540 , high 1940 ) but cannot find why this happen!
I noticed also, that parameters in: initial setup - optional hardware - parachute
dont get saved and get grew out after rebooting the cube…

gggggsdgds|550x500 .


THx for hints and help !

Is testing the master branch of ArduPilot a possibility?

I’ve spent some time this-morning looking at Parachute on master and wrote
these tests: https://github.com/ArduPilot/ardupilot/pull/10208

The tests seem to indicate the 3-pos parachute function is working OK on

If it works on master for you then we definitely know there’s a problem on
the 3.6 branch.

If the parameters not getting saved include the chute pin parameter
then that would certainly explain your problem!

Hi Peter,
Yes same here. test on master works.
i checked AC 3.6.3 & 3.6.2 on the build. same error.
somehow i got managed the parameters saved,
but not the chute pin parameter.

Thx for your help !

Best Regards

Parachute Parameter Pin cannot be Saved for 3pos SWITCH or Parachute Release Function.

Which board are you trying to do this on?

How are you trying to set it?

Note that the parachute parameter pin isn’t closely related to the 3pos
switch; there are several ways the pin can be used without those.

Cube on Kore Carrier 1.4B

i tried via initial setup - optional hardware ( parachute ) first - but only got grey out input boxes

or via

entry parameters in full parameter list - servo, ch and parachute .

no matter if i select 3pos switch or parachute release…

in extended or basic tuning i cannot see/get any parameter for configuring parachute parameters also, only parachute enabled/disabled.

only with switching of all relay outs in standard tuning, i can get servo shown up in parachute inital setup window…

no luck, servo out is not shown / saved.

OK, I don’t use MissionPlanner - so I don’t know how this is supposed to
work in the interface, sorry.

Thank You Peter,

The problem is still alive in AC 3.6.6 :frowning:

Now the Chute is disabled completly after reboot !!