3.7.0 Bad Frames with Dshot150

Hello !

Issue details

I had problems with weird soft crashes after about 3 min of flight. After about 3 min, the model falled down and (on the ground) only the left rear motor is rotating at idle speed, the others are off. I can disarm.
I tried stabilized/loiter/alt hold mode and autotune but always the same behaviour.
Log seems ok but I post it anyway.
I noticed several bad frames on my 4in1 Holybro Tekktro32 F3 escs plugging it to Blheli32suite.
I use Dshot150 and esc telemetry. I also use Yaapu telemetry wihtout inverter and therefore I use this dev version.


ArduCopter V3.7.0-dev ([eed19a9]) but I used the last ones since they are available.
I used 3.6.9 and it is the same behaviour.


[ ] All
[ ] AntennaTracker
[x] Copter
[ ] Plane
[ ] Rover
[ ] Submarine

Airframe type

Quad V

Hardware type

Kakute F7
Holybro Tekktro 32 F3 65 amp 4in1 in Dshot150 mode
Lipo 6s
Low Kv motors with 15" props


As a test try using just DShot. please remove the props when doing this I seen a motor power up when changing modes and recalabration the esc’s.

Thanks but I’m not sure to understand …
I already use Dshot …

try "dshot "not dshot150… I notice something odd with the motors powering down with 150.
WARNING remove props!

ok :wink:
I didn’t know “only Dshot” existed.

edit : I don’t see Dshot. I only see Dshot150,300,600,1200 …

ok let me look tomorrow getting late here.

ok i see what i did I using oneshot sorry about that.

Ok thank you for your help

something was odd when i used Dshot150 the motors where disarming so i changed to normal and they worked but not super smooth. then i tried oneshot and its very smooth now, not sure if you can get telemetry with oneshot could be you can try it a let us know.

No, I don’t think I can have telemetry with oneshot. It is a pity not using Dshot with those fantastic F3 escs. I can try it but it is not a final solution.