3.6.8 and 3.6.9 not flying straight

Since we have updated from Cube black 3.6.7 all subsequent versions do not fly straight lines anymore.

I started a discussion here but this forum seems more active so I thought I would post here

This has been tested on multiple flights (over 20)

We won’t go back to 3.6.7 because of the IMU failover not working.

We are flying a Cube Black (old version not affected by SB_0000002)

One notable change is we are using a Here 2 GPS because we can’t get the Here 1 anywhere anymore… which is super annoying. I hate changing hardware for this very reason.

Attached is a screen shot of logged vehicle paths. One is the onboard Pixhawk cube gps. This path shows that the drone THINKS it is exactly flying on the required waypoint path and it looks good (but it’s not)

The other track shows the path as recorded by an independent onboard GPS. You can see that the Pix “thinks” it’s flying straight but in fact it is not. The arcs in the paths are enough to cause serious issues with photo overlap.

The problem never existed on 100+ flights before 3.6.8

This can’t have anything to do with the version.
Check your magnetometer placement, orientation, calibration.
You need to post dataflashlog for people to be able to help you further.

Here is a screen shot of the actual path, as you can see it flies in an arc from waypoint to waypoint this results in very poor photo overlap.


Here is a screen shot of the Log taken from pix, as you can see it thinks that it is following the lines perfectly.

Note that this behavior has started only since changing firmware. We have multiple units flying many times without this issue before.

Now we have three units all flying in this strange “arc” from waypoint to waypoint. It’s happening every flight.

I don’t want to go back to pre 3.6.8 because IMU failover is not working properly on that version.

I will post a flight log or two as well shortly.

The only thing that has changed other than firmware is we are now using Here2 gps

Did you re-calibrate with the new Here2?

Yes multiple times. Actually these three drones only have had Here2 compasses on them. The previous ones had Here1.

Did compass calib on both “relaxed” and “Default”

The really strange thing is that the Pix logged path is straight but in reality it flies in arc. So unless you have a secondary GPS you will never know your drone is flying in arcs.

So in order to prove this I need to compare against someone who uses an independent GPS to log a flight.

Perhaps I need to strap a Here1 and Pix onto the same drone and log a flight then compare the two. That will remove the Here1/2 variable.

Does calibrating on site help?

Hi, we have tried on site calibration and it made no difference. It’s crazy. These drones flew straight as an arrow before… I did a file comparison of the parameters and nothing changed there either.

Only thing that has changed between the last drones and these is firmware and Here2 compass… We will get one drone rolled back to 3.6.x which was before the IMU switch over fix then try but that won’t be for a few weeks.

Logs will be coming shortly.

It could be more easier if you share a dataflash log.
Did you tried to plot the POS versus GPS_POS ? the POS is what the drone “thinks” about it’s position, and the GPS_POS is what the GPS sees. Based on that we can see it it is a GPS problem or an EKF problem.

Thank you I will plot this and see. I did not know there was a differnce between Pos and GPS Pos.
I believe the track you see is the POS.

I will also get the log when back at the computer that has it.

Edit, here is a lot from a different flight with the same issues. I don’t have access to the full log from the above flight. I do notice that it warns my compass offsets are high. The compass is only about 15cm off center from the drone. That has never been an issue in the past.

Here is the “pos message” and “flight path auto” from the autopilot
You can see they line up very well. The drone thinks it’s flying perfectly.

but the actual position of the drone is this, sorry it’s harder to read this version with just dots. Those are camera positions.

you can see though that there is more space between every other line and less space between every other line…

See GPS position(blue), POS(red) and ROUTE(purple). They all the same. So your drone is flying on the route based on the onboard GPS. If there is a problem, then it must be GPS related.
What constellations are enabled in your GPS ?

Thanks for your time in looking the logs.
We flew three more flights today, three separate drones but all set up exactly the same way.

I will see what results we have.

I have left the Pix GPS set up as is out of the box. Is there a way I can check to see what Constellations it is set up to be receiving?