Servers by jDrones

250 Quad with Pixfalcon help


(Henry Scheun) #21

Hi Leonard,

Ok I got lucky with the wind.

Here is the Autotune parameter file:
ZMR250 Autotune 6-8-2017.param (13.3 KB)

And here is the Autotune .bin file:
http://filegooi.co.za/get2/f3c092d775546efc4a23d6ba265c0710/2017-08-06+17-42-00.bin

I did not have a chance to fly it with these settings. A bit dark now and there is no wind. I will test fly it tomorrow and report back. I must say that the autotune went down differently this time. More crisp and purposeful.

Thanks for your help so far.


(Leonard Hall) #22

That tune looks good.

I would suggest dropping these parameters:

ATC_ANG_PIT_P,15
ATC_ANG_RLL_P,15

I have plans to make a change to do this automatically.

Let me know how it feels but as usual. Be very careful on the first take off.


(Henry Scheun) #23

Thanks Leonard,

Will do and see how it flies, I will only be able to do this later today, at work now.


(Giorgio Rinolfi) #24

Hi Leonard, Thanks so much
I made all the proposed changes and start with the below setting,

ATC_RAT_PIT_FILT,40
ATC_RAT_RLL_FILT,40
INS_GYRO_FILTER,80

to have a complete overview this is the full parameter list before autotune

correct parameter list 2650.param (13.2 KB)

and this is the autotune log

But really something strange happen, the autotune made only a “single step” and nothing more, it needs a robust radio input from me for making a second thiching, and so on… was really a pain to make the autotune in 1 axis completed this way.


(Dave) #25

Henry-I’m using that same mini mount with even softer balls with a PixRacer. Overkill I’m sure but I have been able to manually tune it (210 quad) for good flight characteristics. This photo shows 3S but it’s flying on 4S now which required a re-tune.


(Henry Scheun) #26

Thanks Dave,

Just one question. I notice everybody put the battery on top. I have the battery at the bottom. I don’t race or even fly very aggressively. Is the reason just for safety or maybe something else?


(Henry Scheun) #27

Hi Leonard,

I did my first flight this afternoon and it is a lot better if not perfect. Unfortunately there was not a lot of wind, but I hovered close to the road as cars drove by and could not detect any disturbance at the copter. I will do some more test flights when there is more wind and report back.

Here is the .bin file of the flight:
http://filegooi.co.za/get2/11cc841cec14b689a39064835ed47d44/2017-08-07+17-16-53.bin

Should I autotune the YAW axis as well?


(Dave) #28

Henry-I think either will work it’s just a matter of how you choose to build the quad. I actually have the PDB below the bottom plate protected with a plastic bash plate because there wan’t enough height with the FC mount and the ESP8266 radio without ridiculously long stand-offs.


(S) #29

I’ve done it both ways…
I’ll post pics of mine, in case it helps give anyone ideas about how to build one. I don’t know what the best way would be… My only design goals were to make everything fit, keep it as light as possible, and keep the antenna as far apart as possible.
Then they’ve both been crashed and repaired a lot since I built them, so they’re messy…



(Leonard Hall) #30

Hi Henwilsch,

Yes, now you have a reasonable tune on roll and pitch you can do a yaw tune.

I am glad it is flying well!!!

On the battery thing. I saw a paper that suggested that having the CG just above the propeller disk was beneficial to control performance but I have not seen any clear indication that it is the case. I have done both but having the battery below makes it easier to mount the GPS.


(Giorgio Rinolfi) #31

Hi Leonard,

The other day when I’ve set
ATC_RAT_PIT_FILT,40
ATC_RAT_RLL_FILT,40
INS_GYRO_FILTER,80
the copter seems to flight a lot better! but It can not perform the autotune for the rate noise as you explain me.

So I’ve set back:
ATC_RAT_PIT_FILT,20
ATC_RAT_RLL_FILT,20
INS_GYRO_FILTER,40
and the full parameter list in common for the below autotune session:
post 1 roll.param (13.2 KB)

FC Pixracer firmware 3.5.2 rc2 hard mounted
motors 1306 2400 kv
propellers gemfan 5030
total weight 220g
battery Li-Ion 2S 3300mHA

the 3 last one :
Autotune Roll and Pitch


resulting PID

another Autotune Roll and Pitch


and the resulting PID

another AT roll and pitch


and its PID

The pitch quite often is overshooting, and the last tune seems terrible, after this last one I’m trying new AT but the copter is so instable, fighting to be stabilize after small breeze, heavily on the roll… so I’ve stopped to make autotune and wait for your suggestions

Thanks!


(Leonard Hall) #32

yep, The noise in Autotune is kicking it around.

Lets do have a look at a manual tune. Start off with:

ATC_RAT_PIT_FILT,40
ATC_RAT_RLL_FILT,40
INS_GYRO_FILTER,80

Set Angle P to 10.
Increase Rate D until you see oscillation then drop until you don’t see oscillation.
Drop Rate D by 25%
Increase Rate P until you see oscillation then drop until you don’t see oscillation.
Drop Rate P by 25%
Increase Angle P until you see oscillation then drop until you don’t see oscillation.
Drop Angle P by 25%

Lets see where this takes us. I will look at a couple of changes in Autotune to address some of these issues and then we can compare what you get.


(Leonard Hall) #33

Here are two of my main development aircraft for a long time. The QAV was pretty much standard. The bigger one not so much:

Name: My kids call it Willy for some reason (don’t ask me!)
Weight: 940g
Motors: Sunny Sky 2208 2600 kV
Battery: 2200 mAh, 4s
Props: Gemfan 6x4.5, Gemfan 6x4 Bullnose, HQProp 6x4.5, APC 6x4E Speed, Quanum 6 x 4.5 Carbon (still experimenting)
Power: 1.4 kW continuous, 2 kW for short bursts
Current: 120 A continuous, 160 A for short bursts
Thrust: 4kg continuous, +6kg for short bursts
Has a custom 200A 4s power module based around the ACS758ECB-200U-PFF-T.

I did a bit of a write up here:


(S) #34

I have a question about manual tuning…
I understand the basics as you’ve posted… Increase until you see oscillation, then decrease until it’s gone.

I’ve done that and get similar results to auto-tune. The copter is stable in a hover and gentle flight.
But as others are saying, in the wind or after a fast run or turn, it wobbles. If I fly forward fast and let go of the sticks it rocks back and forth a few times.

I don’t know if that’s a sign of too high PID’s, or too low. Is there a definite answer, or could it be either one?


(Henry Scheun) #35

Hi Leonard,

Do i understand correctly - that quad draw 120A??!! That is 10 times more than mine at hover. Whow!

I did a autotune on the yaw axis this evening and here the result:
ZMR250 Autotune Yaw 6-8-2017.param (13.3 KB)

And .bin file is here:
http://filegooi.co.za/get2/9dcf492dd0b7ae810873a0430bc7e079/2017-08-08+17-53-17.bin

If you would be so kind and check if there is any changes you would recommend.

Thanks again for all your help.

Henry


(Giorgio Rinolfi) #36

Ciao Leonard,

I spend all afternoon making the in flight tune following the process you describe and with the setting u suggest:
ATC_RAT_PIT_FILT,40
ATC_RAT_RLL_FILT,40
INS_GYRO_FILTER,80

Yestarday already, when I’ve try these parameters seems to works so good on my light build (220g), but cannot works with autotune so today I’ve work with this manual tuning…
I’ve try indoor without any wind …but I cannot see any significant difference in a large spectrum from min to max, I’m trying to explain:
Apart from Stabilize P (its linked ROLL and PITCH), I’ve focus only on ROLL part for the RATE,
I try with rate D Roll from 0.001 to 0.006, in the end I set at 0.002-0.003 only because it seems so much 0.006, but to be honest I could see some slight slight oscillation only at 0.006 and more, maybe!
After I try several time with rate P roll from 0.05 to 0.12 and I really cannot see any difference (all autotune before sets this from 0.03 to 0.05), now infact I’m flying with 0.12! only because outdoor with some wind it seems to have little more authority, but still I’m not sure to have any perceptible difference.
So I’ve set this 0.12 and also for I rate ROLL; passing to Stabilize P from 10 to 18…and also here I cannot perceive any difference indoor and outdoor!

I’m lost, do I really have to make more extreme maximum?

Before during autotune I was seeing a huge impact from ATC_ACCEL_P_MAX and ATC_ACCEL_R_MAX, that we are not considering in this process.

This is the last full parameter list:
2400 kv manual tuning.param (13.2 KB)

In general I need to focus on wind ability PID, this is the important aspect because is the greatest and evident fault we have and I’m happy to see also other people are complaing here and in other theads.

Yours build seems so powerful, mine its hovering at 4A (220g) and at maximum arrives about at 10-12A, seems really different from yours example. My build have only 5mm clearance from every props, 5" 5030, really lightweight props
like 1,6 -1,7 gram each one.


(S) #37

Hi, Since you both mentioned Leonard’s 120A figure, I just want to mention, he means that is the max power he can sustain. That isn’t his hover throttle… He’s got 30A esc’s and motors/props capable of drawing that much power, so can run 120A continuously if he wants. (I doubt he’s usually flying around that fast, though)


(Leonard Hall) #39

Hi Wicked1,

This is probably one of two things,

ATC_ANG_PIT_P,
ATC_ANG_RLL_P,

are too high. Drop them back to 10 and see if you still have the same issue. Autotune can make these a little high sometimes. This is one of the things I want to fix.

If you have set these parameters manually:
ATC_ACCEL_P_MAX,
ATC_ACCEL_R_MAX,
then they may be too high. You could try dropping them back down to 110000 and see how you go there.

Yeh, I normally only see 120A as I punch out from a stationary start or in a turn. Most of the flight I am around the 60 to 80 amps. If I push really hard I can flatten the battery in under 2 minutes. Obviously hover is much lower.


(Leonard Hall) #40

Hi Giorgio,

Lets keep on going up until you clearly see oscillation on each step then back off until it goes away. And could you send me the log of your test so I can see how the aircraft performed.

Thanks and chat soon,
Leonard


(Leonard Hall) #41

Hi Henwilsch,

The tune on yaw looks good. I would suggest dropping the ATC_ANG_YAW_P to 9. Other than that it looks very good!

Please let us know how you find the flight characteristics.