Servers by jDrones

250 Quad with Pixfalcon help


(Henry Scheun) #1
Hi I upgraded to Ver 3.5

Here is a flight log if someone can look at it and point out problem areas please.

Did not use autotune. I used PID's that flew OK and based on other users settings.

It flies ok but seems that the slightest wind make it twitch. In no wind it is very stable


(Henry Scheun) #2

Can’t get the .log or .bin file to upload.
Should be availeble here:


(Dave) #3

The ratio of Rate Roll/Pitch I to P looks off. Typically I is equal to or less than P. At least with all of my multirotors that’s true.


(Henry Scheun) #4

Thanks, that is what I thought as well and that is the way my F450 and F550 is set up.
I tried that but still slightest breeze affect the Quad.
Do you own any small multirotors with pixhawk(clone)?


(Dave) #5

Yes, I have 210 quad with a Pixracer. The attached were manually tuned and it flies well.


(Henry Scheun) #6

These were the results from auto-tune for the Roll axis in Ver 3.4.6

Stabilize Roll = 4,873756
Rate Roll P = 0,03859347
Rate Roll I = 0,03859347
Rate Roll D = 0,001254361
Imax = 0,444
Filt = 20,000

Look close to yours. I think I will try auto-tune again and see how it flies.


(Giorgio Rinolfi) #7

Hi,

have you try to autotune with AC 3.5?
Is your copter able to fly stable also with some wind now?
Could you have a good position Hold performance?

After several autotune I’ve found some PID that are flying good in stabilize mode, but with wind its still not so stable and alt hold mode its moving up and down.


(S) #8

I’m having trouble tuning a small copter, too…
I thought I had a good tune, and even give out advice and my PID’s in the past. It is responsive and doesn’t oscillate.

BUT… Then I flew BetaFlight for a while… and that is just amazing… It’s like the copter is an extension of my thumbs.
And going back to my 250mm arducopter quad is bad… It’s like the copter is swinging on a pendulum, compared to betaflight. It doesn’t stop immediately when I let go of the sticks. It doesn’t move immediately when I tell it to move. I can hear the motors increasing and decreasing power in a hover (something people have called pulsing in another thread).

I have auto-tuned this copter 100x and tried tweaking from there, and this is the best I’ve gotten… (I don’t have my flight computer here, but my PID’s are similar to what people are posting here… Generally a tune ends up around .04 - .08 for P and I.)
So what else can I try? Is arducopter not capable of being as ‘tight’ as betaflight? (I think it’s safe to say they have different goals in mind) I probably just need to spend more time manually tuning…

It’s definitely not a concern on my bigger working copters where I like things to be nice and smooth, and I’m flying out in the open so don’t need split second response… But for a fun racer, I need to figure out how to get better performance.


(Henry Scheun) #9

Hi, I used a Naze 32 and Cleanflight on my ZMR 250 before and it was rock solid. I
decided to UPGRADE to Pixfalcon because my big copters is flying nice. But main reason
was because of Alitute Hold being very good. Altitude hold did not work properly on Naze
32 and Cleanfligt. I don’t use my ZMR 250 for racing. I want it to be nice and stable so I
can learn and practice FPV flying.

I tried Autotune and it is OK with no wind, but the slightest wind makes it warble
around(fighting to stay level). I have tried different PID settings, but nothing seem to
make it better.

I have found this on the internet "one thing i noticed after building a new 250 with
pixhawk is that I needed to change my INS filters from 20hz to 40 hz. made a huge difference." Can anybody comment on this please.

Is there anybody that build a small Quad with a Pixhawk(clone) that actually flies good or
are we wasting our time?!

The experts should feel free to jump in any time.


(Henry Scheun) #10

Hi Giorgio,

I have the same problem.
Yes I tried autotune and I am currently on Ver 3.5.
Position hold and Altitude hold is good with no wind, but with slightest wind it warble
around(fighting to stay level)


(Giorgio Rinolfi) #11

Thanks wicked1 and henwilsch to confirm how hard we are trying to build small capable arducopter quads and or we are all making wrong or AC 3.5 have problem with small copter, let’s say sub 250mm. I hope all these troubles could help experts, devs and @Leonardthall to see and solve this.

I’ve spend so many days to autotune in no wind condition, and the best PID I come up are these:

Stabilize Roll P 11.64006
Rate_Roll_P 0.06581955
Rate_Roll_I 0.06581955
Rate_Roll_D 0.002
ATC_ACCEL_R_MAX 247259

Stabilize Pitch P 18
Rate Pitch_P 0.06168013
Rate Pitch_I 0.06168013
Rate_Pitch_D 0.002548281
ATC_ACCEL_P_MAX 211818

I see stabilize P Roll and Pitch are so out of range! why?
ATC_ACCEL I have no idea about it, I could only accept this value and nothing more, but I see it makes a lot of difference.

And with this PID I have so bad performance in Alt Hold
see here also https://discuss.ardupilot.org/t/altitude-drifting-in-pos-hold-and-alt-hold/19540/10

I tried Autotune and it is OK with no wind, but the slightest wind makes it warble
around(fighting to stay level). I have tried different PID settings, but nothing seem tomake it better.

I can confirm here I have the same, with no wind its good, but with a small wind its really bad to see it always fighting and with no autostabilization power.

I have found this on the internet “one thing i noticed after building a new 250 with
pixhawk is that I needed to change my INS filters from 20hz to 40 hz. made a huge difference.” Can anybody comment on this please.

All the last tons of autotune I’ve made, and also the above PID are made with INS filters set to 40 hz, please try yourself and report how yours PID will change.
If we all are going to gave up with AC 3.5 and small copter, this platform is not going to solve this .

Please let’s work on small copter, we see a lot of potential, I could provide some platform to @Leonardthall or other expert for test and continue the testing and provide more datas.


(Leonard Hall) #12

Hi all,

Can I get a parameter file and your latest autotune logs?

I will do my best to help.

Leonard


(Henry Scheun) #13

Just don’t know what to do anymore.


This is autotune result.

This is where I am now.

In both cases it flies fine with no wind. Slight wind and I have to fight it not to crash. I hover in my front yard with a road about 10m away. It will hover fine, but if a car drives past at slow speed(30km/h) it will become very unstable, mostly the Roll axis.

ZMR250 Autotune 5-8-2017.param (13.3 KB)

The last flight .bin file can be found here. I unfortunatly deleted the autotune logs.
http://filegooi.co.za/get2/6df8b209c53aeb0d2eaf86569bf88faf/2017-08-06+11-48-54.bin


(Henry Scheun) #14

I just thought of something.
Can you over dampen the flight controller?

I use this with the Pixfalcon. Should I rather try the supplied foam patches?

It would be helpful if the other guys could share how they mounted their flight controllers please.


(Giorgio Rinolfi) #15

Hi Leonard! Thank so much for yours help.

I have the same frame with the same motors but in 3100 kv version and in 2650 kv version.
I’ll work more on the 2650kv version that seems better suited power/ total weight .
2650 kv
full parameter list 2650kv 8_3_2017.param (13.2 KB)

3100 kv
3100kv full parameter list 8_3_2017.param (13.2 KB)

As you could see autotune find Stab P really high and Rate PID really low, I need to re-done AT to supply the logs, do you suggest to change the PID or Filters or any other parameters before make it?

My FC is a pixracer and its hard mounted, but the vibes are good.


(Leonard Hall) #16

In your flight there I don’t really see any of the disturbances you are talking about.
Vibrations don’t seem fine.
Motor outputs are well matched meaning your CG is ok and nothing is twisted.
You have not set up your Mot parameters. Looks like you are running 3s and drawing about 12 A in a hover.
Looks like you hover at about 30%

MOT_BAT_VOLT_MAX,12.6
MOT_BAT_VOLT_MIN,10.5
MOT_THST_EXPO,0.6

I would then set the following:
AUTOTUNE_AXES,3
AUTOTUNE_MIN_D,0.001
INS_GYRO_FILTER,40 (You had this at 20, it should be 40 minimum for a small quad, I go as high as 80)
INS_ACCEL_FILTER,10

Do an autotune and get back to me. With your INS_GYRO_FILTER set to 20 you were never going to get a good result. If we don’t get a good tune here we may change these parameters:
INS_GYRO_FILTER,80
ATC_RAT_PIT_FILT,40
ATC_RAT_RLL_FILT,40
But we want the lowest filter settings we can have while getting good control.

To relieve any doubts you have, I have been flying crazy powered 250’s using Arducopter for about 2 years now (like 6:1 power to weight). Arducopter will do a good job of them but you need to change a lot of the parameters because our defaults are set up for our average copter and we have a very large range of aircraft we work with, one set of parameters doesn’t work with all of them.

Good luck and chat soon.


(Leonard Hall) #17

Hi Giorgio,

For your setup I would start with:
ATC_RAT_PIT_FILT,20
ATC_RAT_RLL_FILT,20
INS_GYRO_FILTER,40

If that doesn’t work I would then try:
ATC_RAT_PIT_FILT,40
ATC_RAT_RLL_FILT,40
INS_GYRO_FILTER,80
(I am tempted to start with these on your aircraft)

You should also set these parameters:

MOT_BAT_VOLT_MAX,0
MOT_BAT_VOLT_MIN,0

And for a small quad I generally set this:
MOT_THST_EXPO,0.6

Oh, and keep the yaw D zero:
ATC_RAT_YAW_D,0

It looks like you got a half decent pitch tune but your roll tune is crap. This normally happens when you are almost there with the filter setting because pitch is a little slower than roll.

You may also consider using oneshot as well.

We should get the output rate up for these smaller quads soon hopefully but this will still be a release or two away.

So let me know when you have some autotune logs for me. I think you are almost there though.


(Henry Scheun) #18

Thanks Leonard for your reply and help, I do appreciate it very much.

I see you mentioned that Vibrations don’t seem fine. Is there a specific axis that is a concern
or is it all of them?


(Leonard Hall) #19

Oops, that was supposed to be “Vibrations seem fine”.


(Henry Scheun) #20

Thanks Leonard,

It is a bit windy here now. I will wait for no wind and try autotune with the changes you made and get back to you. Maybe later this afternoon I will get lucky with the wind.