17 inch quad, cube black, weird yaw and throttle behavior

Hi guys,

I’m in the process of setting up a tarot 650 with extended arms. 17 inch propps 6s 6000mah. Cube black and here 2 gps. I’m really lost and it flies weird af.

To begin with, it lifts of at about 15% throttle. It weighs about 3kg and has a MTOW of 5 so it should not be lifting of at 15%. (stabilize mode)

The yaw is also behaving weird. It yaws to the right when I make a medium stick input on the roll axis and drifts alot on the yaw aswell. I’m really lost. The log should be attached to the post via a link to google drive.



You must do the Initial Parameters Setup in Mission Planner located in Setup>Mandatory Hardware. These are pre-1st flight changes from default. It would be a good idea to read thru the Tuning Wiki also as this is just the start to get a good performing craft.

One result often seen is motor output oscillation like this craft displays:

When this is resolved there is likely to be a mechanical yaw bias. You can see the trend here between the CW and CCW motors. Fairly common on frames like the Tarot when the arms or motor mounts are twisted (motor axis not vertical).

1 Like

I’ve tried the initial parameter setup tool in missionplanner as well as setting the parameters myself according to the tuning process instructions. It only made it worse. I found that the suggested mot_thst_expo recommended for 17 inch propps worked much worse than the preset 0.65 value.

I could set the initial parameters again and post that log as well. Thanks for the reply

Yes, do this again and then go from there. This isn’t expected to produce a perfectly flying craft, there are additional tuning step to be taken.

Also, you don’t want to leave Auto Tune aggression at .05 when you get to that point. I would set it back to default.

1 Like

yeah, I’ve had this aircraft flying perfect in this configuration on arducopter 3.5 Then I started experimenting but now I’ve ended up with the same configuration again. I’ve never seen this yaw behavior though. It drifts randomly and when I roll or pitch then let the stick center. It also yaws to the right.

I can’t see that my motors are twisted but I’ll check that and set the aircraft up with the initial parameters setup.

One more question, I use ESCs with simonK firmware on them. Are those ESCs to old for the newer versions or should it work??

They are old but should still work. I would suggest replacing them with some BLHeli_32’s. After the ouput oscillation is resolved plan on configuring the Notch Filter. It’s a normal process of tuning.

1 Like

Thanks! I’ll look into that. I’m a bit short of money right now since I have a larger drone coming up. This is more of a test rig to learn all the features of ardupilot before starting on my more expensive project.

1 Like

One reason could be that the CCW motors are bouncing off of minimum motor output which would cause yaw instability. Fixing the yaw imbalance and oscillation will help this. In the mean time check this out:
Motor range

I’ll check the motor setup. I’ve done the ESC calibration but the rest is left to the default values. Could it be the lighter weight of the aircraft, 3kg (MTOW 5kg) in combination with the yaw imbalance that causes the signal to hit the lowest value? Or should I be fine to fly at this weight if I get the imbalance sorted out?

here’s a picture as well, might help to analyse logs knowing the aircraft design features

I looked at the motor mounts. If any of them are tilted. It’s only by like 1 degree or something. I’ll try to see if I can correct them any but it feel like such a small variance wouldn’t cause this. In missionplanner, does the C1 out represent the motor 1 and C2 motor 2 etc if I look at the quad copter motor number and rotation template??

Yes, right. It doesn’t take much tilt to cause this.

Sorry for the late awnser. I’ve been on the road the whole day. I’ll try to test fly and get a new log tomarrow.

Hi, I havent got to fly yet. Raining alot here in Sweden right now. But I figured I could ask you some other questions I have. I saw a post about occilation and nois. That mounting was very important for nois reduction. My motors have some kind of soft mount.

Should I hard mount them or leav it?

Also my cube is mounted on sticky foam and on a plate attatched with rubber rings like tarot uses for gimbals.

Is that an issue aswell or should it be fine?

I know I need to setup my filters, the harmonic notch. But as of now the copter is flying so bad that I thaught I needed some tuning first. At least the yaw issue. Am I correct or should filters still be the prioroty??


I have seen soft mounts before but not that one. I would hard mount the motors.

You need to reduce motor output oscillation 1st then the yaw bias and then filters.

1 Like

I’ll hardmount the motors than!

Is the fc mounting ok? Maybe you havent seen such a mounting before.

I have seen a sub plate mount like that on a big X8 that didn’t work that well as the plate was causing the vibe problem being relatively thin. I’m not saying that’s the case here though. I would start over with tuning at default + Initial parameter setup.


When I set up the initial parameters. The missionplanne helper tool want’s to set the INS_ACCEL_FILTER to 20 Hz but the documentation says 10 Hz.

What should I set it to? And if you have the time, what does it do, like in what case should it be 100 or 50?? Just curious

Set it to 10Hz. It filters the accelerometer data going into the control loops. Never would it be in the range of 50-100Hz.

Hi Dave, I got my next test-flight done.

I had the accel_filter on 20 Hz for this test-flight. If it’s affecting the result much I can conduct further testing with the filter at 10 Hz.
All the initial parameter setup was done

Hardware fixes:
Two of the motors were not straight and the problem is now fixed. All motors are completely straight now.

Link to log file:

Test flight:
The yaw issue is now fixed, at least the drift and weird behavior. Yaw is still not tuned as well but it’s behaving like a normal yaw with a bad tune now. Not like before.

The test flight was conducted by doing a throttle push to see how the drone maintains attitude (before it would yaw aggressive when throttle was punched). It maintained its yaw and attitude.

After that I did some yaw inputs to see hoe it behaved. The tune was way out of place but it reacted normally without ant large drift.

Then I did some roll input to see how it reacted. As expected the roll and pitch axis is not well tuned but roll and pitch maneuvers did not cause yaw movements.

Lastly, I tried to hover in stabilize mode just to get some test data on a hover aswell.


This is looking much better! The yaw bias is gone and so is the bad output oscillation. As you say it needs tuning but that’s to be expected. The overall Vibe levels are a bit high with a few clipping events on Y.

You could either try to address that now or move forward with the Notch Filter Configuration and further tuning and see where you end up. Assuming you want to do the later set these:

Then do a simple Hover flight in AltHold for a minute or so, or until it’s hovering at mid-stick, and post that log.