15Hz Wobble - Can't filter out

Hi everyone,

I’m tearing my imaginary hair out now with a low frequency wobble when i’m doing the initial test flights of a new Quad i’ve built.

I’m running the Pixhawk Cube Black, on a mini carrier board, on a 3d printed frame, with a 4s 1.5Ah battery, 50A 4-in-1 Tmotor Pacer ESC, iFlight XING 2005 2550Kv Brushless motors running 3 blade 5030 props.

On my initial test flights its got a really weird low frequency wobble. I’ve done the gyro noise filtering procedure, and can see that my motor noise is around 150Hz. I’ve set the harmonic notch to filter this out and it disappears completely. However, i have a huge Gyro and Acc wobble at 15Hz.

I’ve mounted my FC on a 4 x rubber cushion plate, in a hope that this would help, but it hasnt.

I’ve put in a 15Hz center freq Static Notch Filter, with 7Hz BW and 20dB attenuation and this doesn’t really help either.

Any ideas on what i can do to stop it wobbling?

I can tell that once it stops wobbling its going to fly reaaaaally nicely. It flies pretty well even with this crazy wobble.

It wont let me upload my log, but i have taken a screenshot of the FFT noise POST filter.

Cheers everyone,


The flight controller on the soft mount is probably not doing you any favors, Cubes work great hard mounted.

Thanks Pete. I think i’ll go back to hard mounted.

But the 15hz wobble was just as bad with it hard mounted.

15hz is also way too low for any filtering, on a small quad such as that the true vehicle dynamics will be around there. 50hz is about as low as I would go with any filters. It could just be a I term oscillation. I would hard mount the cube, turn off all notch filters and get a log with PID logging turned and share it here.

Ah ok, cheers Pete - didn’t think that it might be PID related. I’ll give that a go and post back.

Hi Pete,

I’ve hard mounted the FC and had a quick flight with PID logging enabled. (ended in a horrific crash - but oh well haha)

What am i looking for in the Logs? I’ve reviewed the PID values of the PIDA, PIDR, PIDP and PIDY.

It still wont let me attach the log file, even though i’ve zipped it down to 3.2Mb.

Ignoring the rates at the moment of the crash, the PIDA.P and PIDR.P look suspect compared to the others?

chuck the log on drive/dropbox and link it here.

Cheers, done.


You vibrations are extremely low, which is unusual for a small quad. But if the flight controller is over-damped it wont be detecting all the frame movements, or worse, lagging and correcting out of sync.
Before removing the soft mount platform you could try the old trick of sticking some ear plugs inside the antivibration balls, see if that stiffens it up a bit. I’m not confident that will be of much help though.

Here’s a problem, maybe not THE problem but definitely something:
Reduce MOT_SPIN_MIN to about 0.12 or even less, where it’s just starting to produce thrust. It’s got to be significantly less than the hover thrust value. Or add a bit of weight.
Check MOT_SPIN_ARM too and see if it can go a lower, just so you can get that MOT_SPIN_MIN as low as possible.
You can see here motors are going to minimum frequently to try and maintain altitude and stability without heading to the moon

I’d try that, in the interests of testing one thing at a time to nail down the major problems.

If that doesnt help entirely, I’d probably try reducing these a bit and see how that changes things before going all out on PIDs

It’s a pity you didnt have BLHeli32 ESCs, then you’d have the harmonic notch filtering without any messing around.

Thanks xfacta. One thing I noticed is if I up the throttle a bit then the quad goes up like a rocket. Like nothing I’ve seen before. So maybe it is just overpowered? Which makes sense when thinking about my arm spin and min being too high? I did think about adding weight to see if that helped. I might try my bigger battery.

I followed the ardupilot basic tuning guide for the ATC RAT figures. But maybe I got something wrong there. I’ll have a look again and try the figures you suggest.

It’s really annoying, as the spec of the ESC says “BLheli 32” but none of the configurators will recognise it, and I can’t flash any new firmware.

Yes, add a bit of weight too.
If the ESCs do BLH32 then you’ll need to use the AUX outs on that Cube, and set up the BLH telemetry too. Then if your radio system allows it set up Yapuu telemtry - you wont go back!!
If you get those working you’ll be thinking about setting them up on your car, kettle, bicycle… Why doesnt everything have BLH telem and Yapuu telem? :rofl:

1 Like

Yea as Shawn says switch to the Aux outputs and configure a serial port for ESC telemetry. Assuming you have the ESC TX pin connected to a serial Rx input. You should only need to set the SERVO_BLH_AUTO parameter to 1. Set those others you changed back to default (0). And with that ESC and motors set MOT_PWM_TYPE to a Dshot protocol. 1200 will probably work but I would start at 300.

If ESC telemetry fails for whatever reason the next best reference for the dynamic Notch Filter is FFT. However that requires a Dev version of firmware so personal choice to use it.

Ah amazing, thanks Shawn and Dave. I’ll try the Aux outputs.

And I’ve got Yaapu telem on my big quad, your right, it’s amazing!! I’ve just given up on the non inverted s/fport support of the cube black F4.


What he said, I would remove it as well.

I recommend just starting over delete the config. Then keep the PID’s stock and fly it. if you get a twitch dial back the pid a tad manually with the slider, then go to the “roll” pid setting and reduce them numerically a few.

Thanks everyone - i’ve taken your points all on board. I’ve now got ESC telemetry set up - i can see RPM, Temp, Voltage etc being recorded in my Logs.

I’ve reset my whole params file to defaults, and only set the mandatory settings to fly.

I’ve set the Harmonic Notch Filter to use ESC telemetry.

I’ve gone to Dshot 600.

I’ve hard mounted the FC again.

I lowered to min spin to 0.1, and min spin arm to 0.05.

But sadly it seems worse than before now :sob: Here’s a photo of the FFT - the freq has moved down to about 10Hz, but the amplitude is way worse.

It’s basically like its doing a motorbike tank slapper in the air - which suggests PIDS arent right? It’s oscillating and overcompensating around the wanted level value, but never gets there?

Can anyone suggest some reasonable PIDS to try? I’m assuming autotune would be absolutely pointless with it in its current situation. :rofl:

Here is my log from my most recent flight - where it was at its worst, and randomly fell out of the sky.


Really appreciate your help guys.


I don’t see that you did that. The Rate and Gyro filters are at default. That won’t work for a 5" quad. Rate filters should be at 40Hz and Gyro at 75Hz to start. Run the Mission Planner plug-in (Alt>A) and use those values.

Hi dave, no I didn’t. I thought that might have some input into the PIDS somehow.

Anyway, I’ve set all the filter rates now and will try again tomorrow. Cheers

Smaller quads (6" and less) will not be stable with default filter settings no matter the PID values. Just setting the Gyro rate to 75 would probably make it flyable but set all of them as prompted. The Plug-in works great for props up to ~26". These are settings to be done before the maiden flight.


Hi Dave,

Cheers - never knew about that plugin, very useful. I followed that and halved all the PIDS (as recommended on the ardupilot wiki) and it flies much better, but still have the LF wobble (albeit much lower amplitude.

I then changed the battery pack out for my 750g 4s whopper and voila! Flies perfectly - no noticeable wobble or vibration. Motors are much cooler as well.

Trouble is, i really don’t want to add this huge battery to this small quad. I am going to be adding an FPV camera, and my GOPRO 6, and i suppose i could add another small 4s battery for longer flight times. But even with the 750g battery added, the Hover throttle is still only around 0.2.

Another problem i’ve got (which might have effected the plugin wizard calcs) is that my ESC telem is not reading correct battery voltage (it’s showing ~11.5V) instead of the 16.8V when battery plugged in. The mission planner battery monitor page always shows ~11.5V no matter what measured voltage or multiplier I put in. Strange.