ZR10 2K QHD 30X Hybrid Zoom Gimbal Camera - SIYI's first industry gimbal camera and it won't be the last

Please update all the new firmware online. The production firmware is a bit old

1 Like

Hi Frank,

I tried upgrading my camera firmware by following the manual and the youtube video posted in this forum. I waited for 3 minutes as instructed in the video but the camera did not respond. Moreover the LED started blinking like shown in the image:

Also the version number in the software shows as 0.0.0

Please do it again by using a different SD card

I flashed the camera and zoom and gimbal and now I can change camera’s IP and see an RTSP stream. Very cool! Two new questions:

  1. How do I tell the camera that I’m mounting it upside down? Can I do that through the PC assistant?
  2. I can view H264 stream on rtsp://192.168.144.25:8554/main.264 if I change “Coding Format” from H265 to H264. Is there a different URL for H265?

Thank you for your continuing support.

Ari.

If you power it in upside down position, it will always work as upside down till the next start

The text in the RTSP addresses is literally the text itself, related to nothing special or functional.

You are pulling the rtsp stream directly from the camera via the URL. Does not matter what the resolution, frame rate or the codec are set to. Just make sure you video player can handle the codec. Happy Time RTSP client works well

Thank you Frank and @Mark_Rosser. I was using an old version of VLC. I upgraded that and now I can view H265 1080 @ 30.

For some reason I was expecting for the video to rotate 180 degrees when the camera knew it was in inverted mode. I can do this in post-processing.

Hi anon,
did you manage to get any answer. i’m actually facing the same challenges.
kindly share if you got something. thanks

Hello. Is it possible to make the slider on the taranis x9d remote control control not the camera rotation speed, but the angle directly?

ZR10 Update Log

23-3-13

New Firmware

ZR10 Camera Firmware v0.2.7 svn544 svn543 2023-02-15

ZR10 Zoom Firmware v0.2.0 svn6375 2022-12-21

ZR10 Gimbal Firmware v0.2.4 svn6501 2023-03-06

Updates

  1. Fixed: ZR10 picture randomly reverse during flight
  2. Fixed: ZR10 gimbal occasionally drifts during flight
  3. Fixed: ZR10 picture occasionally tilts during flight
  4. New feature: Triple tap on screen to point the camera 90 degree downward (SIYI FPV). And a new S.Bus channel for the same function.
  5. New SDK Commands: Absolute zoom.
2 Likes

Frank, thank you for continuing improvements to firmware. I love the new SDK extensions.

I tried to upgrade the firmware on my camera, but failed. I was able to update the gimbal and zoom, but the camera still shows up as 0.2.6, and the camera’s LED blinks continuous red. I put ZR10_UpgradeSD.bin on an SD card, boot the camera and wait 10 minutes. The camera keeps blinking red. I shut it down and examine the card–it is empty. PC assistant shows FW ver 0.2.6

Is there something I need to do differently?

Please format the SD card and do it again or switch to a different SD card

I’m happy to try that, but this is the same card I used for the previous upgrade and it went without problems.

Ari.

Are there any special parameters for formatting the card?

Hello i bought siyi zr10 gimbal camera. I need raw image data for my UAV applications. Can i connect ethernet output cable direct to companion computer with static ip and get the image data? If i can, how can i do it? Or are there another way to do it? Companion computer’s os is Ubuntu. @SIYI

I think you will find the answer after trying to make the connection

Seriously? I don’t know how to connect? I need a useful answer.

Well, according to your description, you already told us the full instruction. I thought you just knew how to do it.

The first step is to make ZR10 the same gateway with your companion computer and make the connection.

@SIYI I was able to upgrade the camera FW. It took three different cards.

Now that the new FW is up, it appears that it overwrites the settings, including IP address, video resolution, etc. If it’s impractical to preserve settings between revisions, I encourage you to document this fact. It took me some time ti figure out why my camera wasn’t responding on UDP :=)

Ari.

I’m getting triple yellow blinks (“IMU temperature is abnormal”) and PC assistant is showing 65.97 degrees. The camera is stationary, I am not reading video or sending commands. Nothing is binding physically. Ambient temperature is about 20 C. What am I doing wrong?

Screenshot_2023-03-18_13-50-22