Servers by jDrones

ZED-F9P with Pixhawk 1 possible?

Hi,
I use a ublox ZED-F9P on my Pixhawk 4 and it works perfect with ArduPlane 4.0.4 firmware.
Now I tried to use the F9P also on my Pixhawk 1. I installed different ChibiOS firmwares on it (AC 3.6 and 4.0.3, AP 4.0.4) but none of them seem to recognize the F9P.
The Pixhawk settings should be correct (Serial 4 baud on 115 and Serial 4 protocol on 5. GPS Type 2 is set to auto.

@WickedShell: is it possible that the F9P is not supported by the old Pixhawk 1?

Just update your pixhawk with the new firmware version 4.0.3…, are you using the new mro zed f9p?

I tried both versions ArduPlane 4.0.4 and ArduCopter 4.0.3 and both do not work. But on my Pixhawk 4 the F9P works perfect! Did you manage to get it to work with Pixhawk 1?
I am using the Drotek ZED-F9P.

If i remember well your module can work on UART… SPI and I2c.
Did you check the correct pinout of the cable…?

Hi Dave,
thanks for the info. It obviously works on UART on Pixhawk 4 but not on Pixhawk 1. I checked the wiring again and I connected 4 wires:
F9P - Pixhawk 1
5V - 5V
RX - TX
TX - RX
GND - GND

So I think the wiring should be fine.

Also when I had the ArduCopter 3.5.3 previously installed, it was sometimes shown as NMEA on 115200 bauds in the messags window in Mission Planner (only sometimes because I tried to get it working and changed MSG settings in ucenter)

Which exact messages does Pixhawk need for navigation with RTK?
Can I only use UBX messages or do I need to have NMEA messages as well?

Before flight you must set all the parameters you need using MP on gps rtk., some info will be show in the hud.
My personal opinion is NMEA

Yes I know these infos. I see the gpsstatus2 changes from 3 to 5 or 6 and then you will see that GPS changes from “3D fix” to “rtk float” or “rtk fix”.

When Pixhawk 1 recognized the F9P as NMEA, I could send RTCM messages to the F9P but I never got a solution status in MP. Thats why I think it was not recognized corrtly by the Pixhawk 1. Normally it tells you in the messages window in MP GPS2 recognized as u-blox on 115200 baud or similar.
With Pixhawk 4 and ArduPlane 4.0.3 it says u-blox 2 HW: 00190000 SW: EXT CORE 1.00 (61b2dd) so it gets recognized correctly and shows also the correct status (rtk Float or rtk Fix).

try set a different baud rate on your pixhawk 1 but just change ir using MP

It does work on Pixhawk 1. Have you ever seen it work in any form on the Pixhawk 1, or is still a starting problem there? (Also when in doubt I just swap the pins between Rx-Tx just incase someone labeled something wrong, which has been more common then I’d have expected.

You definitely want to be using UBX instead of NMEA. The NMEA messages do not give us as much information as the UBX ones do, which causes you to feed a bit worse information into the EKF, as well as the fact that if GPS_AUTO_CONFIG is set to 1 we will fully enable all the required messages (and turn others off to save processing time and bandwidth on both sides), where as you are responsible for culling the messages to the correct set with NMEA.

The baud rate parameters on the Serial ports only have an effect on a limited number of the GPS drivers. The ublox (and NMEA) driver do auto bauding, which means they test a predefined list of baud rates and cycle through them automatically. This means changing/setting the SERIALx_BAUD parameter has no impact, even though it seems like it would.

You were problably right - the RX TX wires were wrong. I took another cabe and it seems to work now!
Thanks also for the baudrate and UBX protocol info! I didn’t know both!
Appreciate it!

Servers by jDrones