Yuri's Mower Updates

Is this the right data? I feel a little lost in this area of Ardupilot.

Yes, drop down the GPS2_RAW section and look for the yaw value.

Here is more detail.

Let me explain. What we are doing is proving that you have ANY kind of valid moving baseline configuration. And you do!

We used GPS_AUTO_CONFIG=1 to make sure the GPS modules are “talking” to the autopilot in a predictable manner. Setting GPS_DRV_OPTIONS=0 ignores the crossover cable between the modules and routes RTCM3 through the autopilot.

Using MAVLInk inspector, we see that GPS2_RAW.yaw now shows a valid value of 19135, which indicates a heading of 191.35°. Something works!

Next, we should get the crossover cable working properly. Set GPS_DRV_OPTIONS=1, reconnect the cable, and see what happens. If you do not get a valid yaw indication like we just saw, reverse the TX2 and RX2 connection between the boards.

I set GPS_DRV_OTIONS=1, put the cable back on the way we had it. Everything went back to 3D dgps on both GPS units. I then disconnected the RX to TX wire and put on the TX to RX wire. It made no change. Now there is no RTK fix and the heading seems to be pointed the wrong way.

I noticed some comment on the blog about serial3 and serial4 options. Mine are both showing zero. It seemed like they were 768 or something like that when GPS Yaw was being tested. I am grasping at straws here!

Don’t mess with those. That was a DMA developer debug setting that is no longer relevant for the use case.

There is no need for straw grasping. Things are beginning to work.

I think the next step is to revert both boards to default in uCenter and then try again (still without the XBee).

I selected for each board to go back to default settings the last time I had them on U-Center. Should I configure them on U-Center as a moving base and as a rover (the old manual way ArduSimple would have me do it). I thought about doing that but I wanted do what helps the most, plus there is probably stuff you guys are putting in the mix that Ardusimple is not doing. It might be good to configure the on U-Center and then run the Ardupilot software afterwards.

No. The strong preference is to let ArduPilot do the configuration. It’s best to have them set to defaults from the start because ArduPilot doesn’t touch every setting. When you set defaults, be sure to save the config to memory.

1 Like

I’m just catching up. Glad to see the progress, Steve! I can’t add anything right now except to second the motion from Yuri to work toward letting ArduPilot set everything up. Your life will be easier in the long run. So, to be clear, my videos that hopefully have helped you are obsolete in that when I made those, I did not think my telemetry radios supported 460800 baud, so I was doing all that manual config in Ucenter. None of that is necessary if you radios can be set to 460800. Of course, that is a bit down the road. Once everything is working with hard wires, the radios can be configured.

You’re getting there!

Kenny, I ask ArduSimple if we can just buy the LR ArduSimple radios that interface with the RTK2B GPS boards with the correct baud rate of 460,800 bps. I might seem like a way to go for people who have not bought radios yet. Here was the response they sent me.

Dear customer,

Note that we can only change the UART baurate to 460’800bps (bidirectional), the air datarate will continue at the maximum datarate which is in the range of 80’000bps (for both directions). If you use your UART only at 10% of its capability it will be possible to transmit over the air. If you use more than 10% of the UART datarate, you will run into overflow and radio will reset.

If you want to proceed we can do this for you with our configuration service: https://www.ardusimple.com/product/configuration-service/

I am still trying to figure out if it will work for our mowers or not? It doesn’t actually sound very good. It looks like they have optimized the data rates of all parts of the radio link to work together and changing the baud on each end might cause problems. I guess it depends on the data rate ArduPilot is actually using.

Interesting info! You cleared up a discussion we were having in a separate thread. I didn’t realize the air data rate was so slow. The good news is that you won’t have to change both radios. However, I think you should at least try setting 460800 on the radio for the moving base. I suspect it might work, which leaves you with GPS_AUTO_CONFIG intact.

Well Yuri, I did check the Firmware version numbers on both boards, just to make sure. They are both at version 1.32.
Moving Base Firmware version number

I then reverted both boards back to the default configuration.

I put the crossover wire back on UART2 from Moving base to Rover and still no Rover (GPS2) RTK Fix. I have rebooted the mower a few times. The radio is still not installed.

The sky seems clear and we are seeing a lot of satellites.

The GPS antennas are pointed right down that driveway.
I also have a RTK2Blight board if it could work to replace a board.

That looks like progress, nonetheless, since both are showing “3D dgps” instead of differing between fix types.

When you reverted to default, did you use this screen to save to flash (with the Send button)?


Worst case, we skip the crossover cable. It isn’t strictly necessary, and Tridge has often questioned the benefit of using it.

Yes I used that screen, but I selected (Revert to default configuration) and hit the send button. I didn’t select anything else (like the blue items in the devices list). I wasn’t sure how to do this.

I think it may be prudent to select the highlighted items, click “Save current configuration”, and hit send, though I don’t know that it’s strictly necessary.

Well I pulled both boards and ran them through U-Center again to make sure they started with the default configuration, No real change after I re installed boards and booted back up twice, they both still read “3D dgps”

Here are the configure settings in U-Center

Is the Firmware on the Cube OK at version 4.1.3? I keep seeing messages about Rover 4.2.2 is available.

Upgrading to 4.2.2 is probably wise, but it will not really change the outcome here.

Other than possibly swapping the TX2/RX2 connection again, I’m about out of ideas as to why your crossover cable isn’t working. I’ve always had good luck with that setup, and it really isn’t supposed to be rocket science!

Send another copy of your most recent parameters, just as a sanity check.

Here are the parameters:
Rover Paramater list 071622.param (14.9 KB)

How about I swap the boards and let the Auto Config set them up that way? If it is a board hardware problem it may show some kind of change.