Your Vehicle is not Responding

still new… (sorry wrong type)

Oh, I bought in February. I just can’t believe it just zapped and with everything still seemingly working fine.

I tried it on another computer, with fresh install of QGroundControl, and got the same error. Then I tried it on my android phone, and on the phone I do not get an error. I tried my other copter (Pixhawk1) with QGroundControl on the computer and I don’t get any error. So then I tried it connected via my 3dr radio and no error. So this means it’s my usb port. Whenever I connect it via usb I get the error.

Solution: My USB port is screwed up to some extent, but seems to work for all purposes.

I opened an RMA and sent it back. Unfortunately the people I bought it from are not familiar with QGroundControl and therefore could not test and reproduce the error. I think they will send it back to me, but I don’t feel safe flying a board that gives me a “Board stopped responding error” so it looks like I will just need to buy a new flight controller to fix it.

After the Orange Cube not even getting fully configured before it failed, I am not sure I want another orange cube or not. As far as I can tell, the blue cube is the same as the black cube, including using the same electronics inside, and I am not sure there is any improvement in construction. I don’t know of any flight controllers even comparable in features to what the Cube offers, and plus I have my copter pretty well configured for the Cube without having to reconfigure everything… So I’ll probably end up with another cube blue black or orange, but for now, I am putting the project on hold until I figure out what route to go.

I can advice you the mRo x2.1 red board or the mRo x2.1 777, fully customizable flight controller and friendly size.
Both are very well tested and supported… me I’ve the red version and the x2.1 777 and until now i don’t have found any issue.
In case of suggestions you have also the live chat…

I’ve decided this probably isn’t a QGroundControl issue, and have continued the conversation over here.

I can confirm this is USB driver related issue.
Once USB drivers are uninstalled, QGC is able to connect my Cube Orange (two of them).
If I reinstall back official MissionPlanner drivers:
QGC reverts back to the “Your Vehicle is not responding. If this continues, shutdown QGroundControl, restart your Vehicle letting it boot completely, then start QGroundControl.”

You can remove drivers via Device Manager or uninstall them via .msi installation, both solved issue for me.
(Win10 x64)

Connecting to a Cube Orange over USB requires the daily build to work correctly. The drivers thing is likely just a fluke of removing the composite USB device support which is likely in that driver definition. That composite USB support for Cube Orange is what requires a new QGC build to work.