Yet another ESC calibration nightmare

Distributor ID:Ubuntu
Description:Ubuntu 22.04.2 LTS

Mission Planner 1.3.79 build 1.3.8375.24878 ArduCopter V3.6.8 (2f409678)
Pixhawk 2.4.8

mono MissionPlanner.exe

I have generic ESC’s from an S500 kit. No idea if they are analog or digital. There is no brand name so I am just following the instructions here treating them as anolog: Electronic Speed Controller (ESC) Calibration — Copter documentation. I tried:

  • All at once calibration
  • Manual ESC-by-ESC Calibration
  • Semi Automatic ESC-by-ESC Calibration

Originally (before my attempt at calibration), they worked. The motor tests worked fine. They worked fine from the RC. But I decided to do the ESC calibration thinking this would fine tune them. Now they won’t work at all. Before I get into the myriad details:

  • is it possible I bricked them?
  • is there a way to restore them to their factory setting?

Generic unlabeled ESC’s will be some old tech cheap units. Perhaps during your attempts at calibration you entered a configuration mode and changed some basic settings. In any case in the bin and replace them with some Blheli_32 units or a 4in1