Yaw Input Broke - ArduPilot Mega 2.0 (V2.4.1), Docs? Software? Eagle Files?

Back in 2012 I bought an ArduPilot Mega 2.0 board. Printed on the board is V2.4.1. When I got it I had it setup and flying. I pulled it out a few years ago and the yaw input was not working (when I go to the GCS page all the controls from my R/C radio show movement except yaw. I have screwed around with everything so much I don’t know if its software or hardware and don’t remember the software version I had on it when it was working back in the day.

Last I tried I used mission planner 1.3.0 build 1.1.5224.30728 and the firmware on the board is Arducopter 3.2.1. As for the firmware there are APM1.0 and APM 2.0 options, is the 1.0 and 2.0 referring to the GCS software or the board?

Does anyone have a source for the setup documentation for this board? I can’t find it on the net anymore. Are there any eagle files or any type of board schematics anyone can share so I can check continuity for IN4 (yaw input from the rx) to the microchip? If its hardware problem with the board I’m hoping I can fix or jumper the trace. If the AMTEL chip is bad I’m thinking of trying to solder in a new one.

Does anyone have a good hex file for the board firmware that is confirmed to work with this board? I have tried compiling with Arduino but its not working because apparently its not supported and I can’t find the hacked Arduino IDE for compiling the firmware. Maybe I’ll try compiling with something else…

Thanks in advance.


You should be able to just flash it from Mission Planner and it will choose 3.2.1 for you as the last version for that board.
I still have some APM2.5’s around and they work well for just basic functions.
There are still documents on the Wiki for the APM here

Thanks for the reply. I re-flashed 3.2.1 and I have the same issue. Further investigation reveals the MEGA32u2 PPM chip is fried.