Servers by jDrones

Y6 crashing


(azrael_sk) #1

Hello everybody. I just finished building an Y6(B) and went to do some outdoor testing.
The copter was flying quite ok, It was not perfect but I thought it was mainly due to untuned PIDs and slight wind.
Tested stabilize, althold and loiter modes with no problems.

So I put on a new battery and tried the autotune procedure which crashed the copter immediately.
It seems as if the copter just roled over and crashed.

I had a similar crash two days before, while flying in althold. The copter slowed down from a fast flight and also rolled too much and crashed.

I checked the log but can not find any possible problems, vibrations seem to be ok, as well as power for the APM.
I have tested the APM also with a small DJI F330 frame, where autotune and generaly everything works OK.

Could this be an issue with ESC/motor sync?
Can someone please advise what to look for?

Video and log files:
[youtube]http://www.youtube.com/watch?v=RrhB1I9fmVU[/youtube]
https://www.dropbox.com/sh/p3c6f850hx96q49/FXgFvovmgF

Copter setup:
APM 2.6 with 3.1.2 FW and LEA-6 GPS with external compass, Y6B frame config
APM powered via 3A Turnigy switching BEC (no other electronics connected)
modified Tarot FY690 Pro frame
tarot 620kv motors
ZTW 30a spider opto ESC (simonk)
1355 Tarot carbon props
4S 5800 mAh Zippy battery
frsky x8r RX connected via sbus to cppm decoder
frsky Taranis radio

Any help is appreciated.


(jschall) #2

Probably a hardware (ESC sync) issue, possibly combined with the bug that we just found that could be exacerbating hardware issues (3.1.3 is being released to fix it).

Simonk does not work well with low KV motors, and is not necessary for copters of this size.


(azrael_sk) #3

[quote]Probably a hardware (ESC sync) issue, possibly combined with the bug that we just found that could be exacerbating hardware issues (3.1.3 is being released to fix it).
Simonk does not work well with low KV motors, and is not necessary for copters of this size.[/quote]

Thanks for the input.

I will flash the 3.1.3 fw when available. Going to check each ESC/motor pair for possible problems and will give it another try. Luckily the damage was minimal, just have to wait for new props to arrive.

Regarding the simonk esc. I know there is an issue with low KV motors, but according to my knowledge it should concern mainly sub 500 kV motors.
I chose ZTW because they have quite good build/components quality. Anyway I will consider changing them for a different type/brand, non simonk, BLheli maybe? (any recommendations?)


(jschall) #4

[quote=“azrael_sk”]Regarding the simonk esc. I know there is an issue with low KV motors, but according to my knowledge it should concern mainly sub 500 kV motors.
I chose ZTW because they have quite good build/components quality. Anyway I will consider changing them for a different type/brand, non simonk, BLheli maybe? (any recommendations?)[/quote]

I have no particular recommendation for ESCs, but I suspect 620kv and simonk is probably pushing it. You don’t need simonK at all with 13x5.5 props.


(azrael_sk) #5

I have ordered some HobbyWing Platinum ESCs. According to different forums they should work well with low KV and pancake motors. I will post info when I have tested them.

Is there any ETA on v3.1.3?


(jschall) #6

[quote=“azrael_sk”]I have ordered some HobbyWing Platinum ESCs. According to different forums they should work well with low KV and pancake motors. I will post info when I have tested them.

Is there any ETA on v3.1.3?[/quote]

3.1.3 is in beta and is available in the mission planner under beta firmwares, I believe.


(Gregmaan) #7

I tested today with 3.1.3. RC1. The sync issues still exist. With RC_Speed set to 200, I can´t note any sync problems. But reducing the RC_Speed should be no good solution. I use RCTimer 30A Opto ESCs and TMotor 2216 with 900kv. The strange thing is that after 5 min of slow flight the the sync issues are more worse than before a flight. Is the issue temperature related to the Pixhawk?


(jschall) #8

If setting RC_SPEED lower fixes your problem, then do it. 1/200th of a second is about half a revolution of a prop. Otherwise, it is quite simply not our fault that your ESC cannot handle valid input without sync issues. The devs, by and large, use 3dr ESCs that work absolutely perfectly with pixhawk at 400hz.


(Gregmaan) #9

Hi Jonathan, I changed from the old 3DR ESCs to the RCTimer SIMONK, hope to get rid of this issue. But If you´re shure there are no issues, with the 3DR when I will give them a try again. Maybe my crashes with the 3DR ESCs came from the problem which is fixed with 3.1.3 RC1.


(azrael_sk) #10

Hi,
I finally managed to do a test flight with new ESCs and v3.1.3 FW and the problem seems to be gone.
No problems even with fast direction and altitude changes.

Stabilize and AltHold are fine. I did not try any of the automated functions yet (loiter, RTL,…) except for autotune which worked, bud the adjusted PIDs were pretty aggressive so I reverted to the default 3DR y6b settings. The autotune procedure took about 10 minutes, is it not too long?


(Wilson Ernesto Frias Florez) #11

Hello Azrael

Can you please explain me what’s the problem with low Kv motors? I have 4 MN4004 T-motor kv400 with Z Spider ESC on a quad and have some issues getting the PID to work. The quad is too unstable specialy in alt hold and loiter mode.

Thanks in advance