Y4-Copter, nearly no yaw control after update to 3.4.4


I am flying a Y4-copter with tilted rear motors using the A-tail frame mixer.
Yesterday I updated it to 3.4.4 and tried to fly it today. Roll and pitch axis control is like before (3.3.x), but I have almost no control of the yaw axis. If I use full stick left or right, it ever so slowly turns in that direction, but it is unflyable. I did not test yet, if it stabilizes yaw at all, I will do this later. This is really strange, because it was almost like a tricopter before. Is there a new parameter I need to set or did I overlook something obvious?
Thank´s for your help!

I had a similar issue with versions 3.3.3 and 3.4.4 on my octacopter when setting AUTO and LOITER modes, my copter was really unresponsive on the yaw axis while in LOITER mode, AUTO mode worked fine on every axis except for yaw, the quad had a tendency to flight towards waypoints sideways or backwards due to the “sluggish” yaw axis. Even after several attempts at autotuning, the quad behaved in the same way.

I suspect the upgrade to 3.3.3 or 3.4.4 caused the issue due to some incompatible parameter from the old version.

Anyway, I fixed the issue by performing every calibration in the “compass” and “accel calibration” sections of mission planner, afterwards I performed another autotune for every axis on my quad. This solved the issue entirely for me.

Thank you for your reply. I will try to recalibrate everything. I never had to do this before. I always save the settings to a file, upgrade the firmware, reset to defaults and load the settings from the file. Worked flawlessly so far with every vehicle I have.

I did all calibrations again, but nothing changed. I removed the props and tested the copter on the bench. Ch1-4 outputs show some strange behaviour. Pitch is working ok, front and rear motors do what they should. Yaw input shows minimal change in output for motors 2 and 3 (the rear motors). Roll changes the output for the front motors as it should, but also increases/decreases the rear motors output together?! By together I mean, just like with pitch, roll left, both rear motors spool down, roll right both rear motors spool up. I had a look at the mixing table for frame type 5 (A-Tail) and everything seems to be correct. I have no idea where the problem might be. I will reflash 3.4.4 and see what happens.

I have 2 Octo’s that I have just upgraded to 3.4.4 and noticed a great decrease in yaw control.

I have tried autotune on yaw with no improvement.
During testing I spun the Octo at full yaw for 180deg and let go of the stick, whereupon it took nearly another 180deg before the October stopped rotating.
The only thing I can think of now is to try auto tunes with greater aggressiveness in the settings before resorting to manual filing of the PID’s.

For me the problem was loading the old settings after upgrading to 3.4.4. Something must go wrong there. I never had that kind of issue before.
Now that I have configured everything from scratch, the copter flies fine again. I will have to tune it again of course, but the default PID values are totally flyable.

What version of Arducopter did you upgrade from?

The copter flew with version 3.3.x before.