Xbee S3B Fail Connection

Hi, im trying to use a Xbee S3B modules with a Pixhawk and Mission Planner.

I use a Parallax module Xbee Usb module to connect to Ground Station, and i use the XBee Explorer Regulated to connect de Xbee to Pixhawk.

I’ve tried to connect to pixhawk like this tutorial:


I´ve tried this tutorial too:


I cannot connect this Xbee modules with the Mission Planner and Pixhawk, I’ve tried so many tutorials with the same result’s, don´t connect between PX4 and MP.

Anyboy use this Xbee to connect with Mission Planner and Pixhawk?

If I say right, you want to connect your Pixhawk by Xbee on Mission Planner?
Did you try on telemetry port? With tuning your params it will work maybe? If it’s not working try to make an USB cable connect on Pixhawk and your Xbee.

Let me know, Cdt LoriuQ

Hi, thanks for help me.

As I said in my previous post, im using those two tutorials, and made these:

I connect the Xbee Pro S3B like the file, and later i’m trying to configure to connect Mission Planner with Pixhawk but not connect.

I know in old versions of Xbee, you could connect the Xbee setting the parameter “Fuction Set” in the Xbee Software XCTU like “ZNET 2.5 COORDINATOR DEVICE AT or ZIGBEE COORDINATOR DEVICE AT” (To the Ground Station) and “ZNET 2.5 END DEVICE AT or ZNET 2.5 ROUTER/END DEVICE AT” (To the other in the Pixhawk), but in Xbee Pro S3B this options don`t appear, and i cannot set like in the tutorial this parameter.

Also I set others parameters like Destination Address Low, Pan ID , Node Identifier and the baudrate like 57600. I’ve been able to set this parameters without any problems,

Maybe someone have the same problem connecting the Xbee Pro S3B like me.