X8 RTF with px4 not recognizing throttle need help ASAP

So for a senior project I am helping an engineering company test out possible platforms for their new camera array for testing buildings, I was tasked with 3D Robotics X8. So when solely connected to the RC transmitter it was a beauty to fly, easy to control so on and so on. However once I connected it to the Mission Planner and APM 2.0 software in order to get more precise movements things started to get all out of whack. I have been able to fix each problem one by one but right now I am stuck on the fact that it doesn’t respond. Basically, after arming which I do not have a problem with, the motors remain the same speed no matter the position of the throttle stick. I have tried this on all the flight modes and the same result occurs. I know that it is a software problem and not a mechanical problem because when trying to re-calibrate the ESCs, which inherently bypasses the PX4 the throttle works fine. Also in Mission planner under the Radio Calibration tab, which I have calibrated multiple times, the throttle is completely responsive to the position of the throttle on the Spektrum DX7s controller. If you need any other information just ask, this project is due friday, and I still need to attach and learn how to operate the GoPro gimbal but that doesn’t seem that complicated.

[color=#00BF00]Please notice that unstable firmware releases should be only used by experienced users who help developers testing the code![/color]

Sorry about that here are some more information:

It is a RTF X8 that comes with a 925 Mhz telemetry system, the GPS is a 3DR GPS and the compass is also a standard 3DR, I am using a Spektrum DX7s radio that recognizes all the other commands including changing in flight modes besides the throttle. The only response that we do receive is the slow increase in throttle but it never reaches enough to take off, even when the throttle stick is at the highest position. I tried attaching a data flash log but when I clicked the Choose File button nothing happened. However like I said below because it never got off the ground I do not know how helpful it would be.

Got the file to work

I had the same problem after upgrading to Pixhawk from APM 2.5 on my roll-your-own hex built from 3DR parts.

Found this link:

diydrones.com/forum/topics/y6-no … 2#comments


Value for THR_MAX was set to 80. I changed it to 1000, per link above.

Fixed! :smiley: