Currently I am having issues flying my X-Plane using APM and Mission Planner. I have ArduPilot Mega 2.5 connected to Mission Planner on my laptop. My laptop is connected to a desktop computer that is running X-Plane 10. I’ve looked at all the guides and followed them step by step yet every time I switch the mode from Manual to Auto the plane nosedives straight into the ground.

The steps I took were:
Open Mission Planner
Download the HIL Simulator Plane software
Connect the ArduPilot to Mission Planner
Click the Xplane 10 box under Simulation
Check the Advanced IP Settings
Open Xplane 10
Check the Net Connections/Data Input & Output
Create Way Points
Write Way Points
Press Start Simulation

I am not sure if I am doing something incorrect or out of order. Any help would be greatly appreciated!

Austin J.

I suspect you’re missing a few configuration steps, things that are assumed and some that are spelled out, but you might be omitting in your description. If you are still seeking to get this up, please let me know and I would be glad to help. If needed, I can spin up a WebEx to help also.