X Plane 9 SITL support

Hi all, I am interested to know whether X plane 9 can support SITL as under network connections there is an option to transmit data, however I am not able to initiate the SITL from Mission Planner. Attached are some pictures for better understanding.

Yes Xplane 9 works with SITL and perfectly. You would need to use the same port configurations instructed for Xplane 10 and 11.

you may have to run beta upgrade for Mission Planner (it has some known issue) and also make sure that Xplane is active with a plane on the runway before you launch the simulation.

The only caveat is that there are 2 datarefs whose indices are shifted in Xplane 9 relative to Xplane10/11 and this leads to vehicle orientation, compass heading, gps errors. So you would need to go into the source code and edit SIM_Xplane.h file. Find the lines

AngularVelocities = 16,
PitchRollHeading = 17,

and shift the numbers by 1 (16->17, 17->18) and recompile the code and it will work.

if coding is not your cup of tea, I can send you the tweaked executable and instructions on how to use it with Mission Planner.

I am relieved to hear that X Plane 9 can work with SITL.
I did figure out the beta issue with mission planner and tried it with the demo version of X Plane 10, it was working seamlessly but not the simulator. That is the reason I wish to use X Plane 9 since it is not hard on the system (laptop anyway) and yes coding is not my strong suite since I have only worked with Matlab as an undergraduate.
I would be grateful if you could share the executable to run with mission planner :slight_smile:

we are in the same boat for our computer limitations. My development computer does not have the graphics card to run Xplane 10 or 11. I will send you the executable and the instructions when i get to my computer.

First off, these are my configurations on Xplane9.

Here is the link to the executables:

Assuming you are on Windows, you need to unzip and put the files in

…[your username]\Documents\Mission Planner\sitl

You will see that Mission Planner already downloaded the executables (including the dlls) you will overwrite.

  1. Make sure IP and port settings are as in the pictures
  2. Launch Xplane and put a plane on a runway
  3. Launch Mission Planner & go to Simulation tab
  4. From Model list select xplane
  5. Just to the right bottom of this list click the “Skip Download” box (this is important as Mission Planner will otherwise overwrite the executables you just copied above)
  6. Click the Plane icon below and the SITL should start.

The following channel assignments are assumed:

  Channel 1: aileron 
  Channel 2: elevator
  Channel 3: throttle
  Channel 4: rudder
  Channel 5: flaps
  Channel 6: retracts
  Channel 7: wheel brakes (important to disengage and take off)

Here is my servo layout and I use the servo/relay tab to control channels 6 and 7:

Let me know how it goes…

Ok thank you, will do try them and update you soon regarding the progress. However, the link provided says that the SITL files are no longer on the server :neutral_face: . If it is alright with you, can you share the link via email (saad.rehmanaftab@gmail.com).

One last thing I would like to ask, are you running X Plane 9.7? since I have 9.3 right now and I can’t see any tab that says UDP ports, the update servers are down ( I have notified X plane support ).

OK, I updated the link above - see if it works - in theory it should be active for 30 days.

I am running Xplane 9.7. I think you can update version 9 from the following page: https://www.x-plane.com/desktop/try-it/older/

Thank you for updating the link, i was able to download the file. I followed the steps and tried to run SITL on X Plane 9.3 but no luck, no “heart beat packets received”. I am waiting on Laminar’s Tech support to bring the update servers alive. Even the X Plane 9 demo installer servers are down. Will update you soon if I get the update.

Ok, so after almost a month the support guys at X Plane got the servers back online (yaaay!), and of course updated to ver X-Plane 9.7 but still can’t seem to connect to X Plane. I have set the exact udp port settings as shown in the picture you s1


One last thing I would like to share is that the packets are being delivered by X Plane, I used wireshark to monitor any activity on the network

Wait, the error was from my side I didn’t run mission planner with administrator privileges :sweat_smile:, now mission planner works flawlessly with SITL , thank you so much for the support.

excellent news! I guess I need to find a developer to get my adjustments pushed into the main code!

That would be amazing! Anyone with X Plane 9 could use SITL on mission planner with a laptop that will easily handle it.