WPNAV_SPEED limited to 20 m/s

Hello all, I have seen in the full parameter list that the parameter WPNAV_SPEED is limited to 20m/s I fly very powerful quadcopter that are able to fly faster keeping the altitude. Would it be possible to increase this speed?



WPNAV_SPEED don’t have upper limit. What you see it the recommended limit on the parameters but you can set more.

Thanks for replying

Would I have to remove any angle limitations in order to achieve higher speeds?

ANGLE_MAX, PSC_ANGLE_MAX, and LOIT_ANGLE_MAX control the maximum lean angle. Whether you will need to increase them to achieve your desired speed depends on your airframe.
If you’re going to be flying very fast in missions, don’t forget to increase your acceleration WPNAV_ACCEL also, or it will take forever for the drone to speed up and slow down.

Thanks a lot! I will see how fast I can go in AUTO mode.

I have another problem. I opened thread for that but I could not solve it yet. Since is related with this thread I guess there is no problem if I talk about it here.

I had a Radio failsafe and the quad changed to RTL. I recovered the radio link and I pressed continue mission, but the quad resumed the mission at 5 m/s and not the programmed speed.

Hm that sounds like a bug. Did the speed change back to the programmed speed after it reached the next waypoint?

No, this is what I expected, but did not happen. I was still 5 m/s.

Was your WPNAV_SPEED set to 5 at the time?

I think mission waypoints won’t set the speed, you need a DO_CHANGE_SPEED mission item. So I guess it must have reverted to your default speed and kept using that because your mission didn’t have any additional speed change commands.

I did not have any speed change commands, however, I use Qgroundcontrol (because I use HereLink) to plan the missions, and this app allows you to set the altitude and speed of every waypoint. That is how I set the mission speeds.

I looked at the way QGC makes waypoints. It leaves the speed parameter empty unless you check the box for Speed and enter a value. If you set the speed on the first waypoint, the following waypoints won’t change the speed unless you did that, so the drone will just use the default speed.

So I think this is intended behavior. Changing the default speed param to your desired speed will avoid the problem you encountered, otherwise QGC should have a way to send a speed change command while you’re flying.


Thank you very much!

Well, As far as I remember I changed the speed in ALL the points. So it should work right? Even if RTL is triggered and then I choose continue mission or I out the drone in auto again.

Do you still have the mission saved? You can double check by opening it with a text editor. You can see that the waypoint and speed settings are two separate commands. If you didn’t change the speed at a waypoint, it won’t add the DO_CHANGE_SPEED mission item (command #178). If every WP had a change speed, you will see a #178 after every waypoint.

Thanks again for your answers. I will do an experiment and do a mission with change speed commands and choosing the WP speed and try.

I have a question,

can PSC_ANGLE_MAX be bigger than ANGLE_MAX so I have more control when flying in Stabilized but when in AUTO the drone can reach its maximum speed?

I haven’t tried it or looked at the code, but the description for ANGLE_MAX says “all flight modes,” so I suspect not.