Wow, 3 hours to get my crossfire system working again

I was just trying to change my nano rx from crsf to rc over mavlink, but no matter what I did, no TBS agent software (x,m,lite) would load the RX settings. Updating to 6.17 from 6.16 beta, RX ota update, TBS agent x would still show the RX as 6.16. Downgrading the TX to 6.16 and it was gone. Windows would not recognize anymore. I do not know how I fixed it again, a combination of pressing the button on the module and plugging in the USB cable made it appear in bootloader mode. I then was able to flash 6.16, but since this was the firmware this started with, it still did not work. Then I flashed the last 4.xx firmware, RX ota update and everything was working. I am really not impressed with TBS. Binding was an issue from day one. I have four different nano RX and none of them just binds. I always have to press the little button to make it blink green and then they will eventually bind.
The reason for the whole mess was that my rover always goes to failsafe after some time. Crsf RC input is gone and only comes back after power cycling. Telemetry is still coming back to the TX though.
I will downgrade my other rovers too and stay away from touching this mess again.

1 Like

I had a real struggle with a new kit of Crossfire hardware too. I will say that support was good as both an Rx and Vtx had to be warranty replaced. It’s mostly working now but Agent Lite quit recognizing the Tx module in the radio (Radiomaster/EdgeTx) and there is some strangeness with the video settings configured in Arducopter. All the integration is a cool idea but it seems it needs a bit of work yet.

Man my first crossfire system failed during the update of the Micro TX wifi and was unrecoverable. Plus the whole update process was extremely painful…

And the retailer has still not gotten back to be after TBS approved the return ;(

So around 3 weeks and no CRSF.

I also learned the hard way it couldn’t update the RXs while being connected on serial to the AP even if the flight controller was off.

Yea, between the problems and the returns it took me about that long too. My goal is still to replace the Frsky R9 gear I have in almost everything but at a slower pace.

Note: I realized I said Agent M not recognizing the Micro Tx module; I meant Agent Lite running on the radio. That still doesn’t work although oddly it see’s the Rx and Vtx.

I really liked the idea of the system $130 for 3 RX the TX with mavlink and wifi. Hard to say no to that.

I’m really to the point of going out and buying another TX module.

I wish I had bought more of those Radio Master R161’s now…

I was going to do that too when the Micro Tx was stuck in Bootloader mode and wouldn’t flash. Even TBS support couldn’t help me with that but tried. Then after the umpteenth time trying it worked. That’s more annoying than not working at all but I’m using it.

Yes, I’ve said the same. The Jumper R8 has been a second choice, but it’s bigger and now almost as hard to get.

Nine days later and MYFPVStore.com still hasn’t even responded to TBS’s message.

FYI in case anyone decides to order from them… :frowning:

I’m hoping TBS will make it right and accept the return directly to them.

GetFPV was very responsive and soon after I forwarded them the email from TBS support they were shipping new stuff. I still have problems with this kit though and I’m not sure if it’s the Micro Tx or something else. I have a new Radiomaster Tx coming and if these problems persist I might just shelve it. The irony is I wanted to make a change from the Frsky R9 hardware because that system is so messy. But I have a lot of models flying with it and they all work…

So, after my initial success with the first rover (no more radio failsafes out of nowhere), I tried to change a second rover to “rc over mavlink”. The downgrade to firmware 4.xx went well, but no matter what I did, “rc over mavlink” just would not work. The first rover has a F765-Wing and the second a H743-Wing V1. I compared the settings between both, but changing the serial port to mavlink and 57600 baud is no black magic. I tried other receivers, but they would not even downgrade or bind, even after multiple tries.
The solution I found will not work for everyone, but it works for my rovers.
It involves Olliw’s OpenTX mavlink telemetry project. Someone posted a video about it a while ago, but it did not receive much attention. It is a OpenTX fork enabling complete native mavlink support.

So now I control my rovers over wifi via rc override, directly from my Radiomaster.
Ok, there might be a RaspberryPi zero W connected to the Radiomaster, running mavlink-router. I get 50m of range between two Raspberry Pi built in wifi modules and ca. 250m with Alfa network adapters.

just a hint: Crossfire since V6.x or so uses 115200 baud for mavlink communication.

Yes, I know, but I downgraded to 4.xx. With the 6.16/6.17 firmware, I was not even able to reliably get to the receiver settings. I tried different receivers, different antennas, moving close to the vehicle or further away, disconneting the vehicle UART lines, nothing helped. Sometimes it would load a few menu items, sometimes it only showed a loading bar forever in Agent lite.

This is one of the problems I see. Micro Tx not recognized at all by Agent Lite. The Rx and Vtx are but it’s very slow to load. I thought initially it might be an EdgeTX issue but I see others with the same kit working.