Works on BF, but not in Ardupilot

I’m trying to follow Ardupilot Tyro129 guide. It says there that target should be Matekf405.
However, I’ve tried all Matek f405 versions and I always get one of those errors BARO and INS initialization.
When I flash Betaflight MatekF405STD - works just fine. (I’m wondering what bf does different that same target works on it? :smiley: )

Anyway I’ve run out of ideas and planning to dump those fc.
Anyone has any idea what is the problem?

do you have a photo of the flight controller, its possible they changed it since that guide.

Hi, I did my own research in the mean time. Yes the hardware has changed, that is the problem, original matekf405 is with mpu6000, and this one is using BMI270. Is there an easy way for me to get source code and recompile?

this one

Here is a recent change I did to support a board with BMI270:

Good for you, mine is F4… :slight_smile:
So, if I’m not good in writing script, I’m screwed? :smiley:

p.s. I’ve tried compiling under Linux, but got stuck in part where I have to clone ardupilot, I couldn’t get authorization…

That’s not a MatekF405STD - it’s a clone. If they have replaced the IMU then you will have to do a new hwdef for the clone. Matek don’t make one with a BMI270 and the STD is EOL anyway, so the hwdef won’t get updated.

I can’t believe it, but I actually done it! :smiley: Thanks for guidance. :slight_smile:

1 Like