Wobbling only on decend

I have T.drone M690 quad with 18inch prop that runs with ardupilot.i was perform Hormonic notch filter but not done autotune yet.

Updated all initial parameters as you suggested too.

Flying perfectly fine with automode when set cruise speed 7m/s or below without EKF and vibe.but when I tried with 10m/s speed I got more vibe and EKF warning on position.


Above status keep changing between 0 and 1.

Specially I am getting wobble in decend on land .
Decending speed I set 1.2m/s only but it’s wobbling more while landing.


First up I have to say that it’s great your aircraft does fly so well with just initial parameters set, and maybe a few minor tweaks. This validates Leonard Halls graphs and data, and the whole tuning guide in case there’s any non-believers out there.
Also it validates that well chosen components should work (even if chosen by chance).

And secondly, it’s amazing it flies without heading to the moon - the Z axis vibrations are enormous and need some serious work. X and Y axis vibrations might be helped by prop balance. I wouldn’t fly again until you examine Z axis vibration solutions in detail and make some improvement. A CUAV V5 may still need some vibration isolation.

You can definitely see the instability in attitude control during descent

and in the Servo outs

You can see Servo outputs are almost (but not always) going down to MOT_SPIN_MIN,0.13
And MOT_THST_HOVER,0.1641125 is also close to MOT_SPIN_MIN.

I would check if MOT_SPIN_MIN can go a bit lower and still be reliable, maybe just 0.12 or 0.11
but mainly add some dummy payload to cause MOT_THST_HOVER to increase a little bit.

The other thing to experiment with is MOT_THST_EXPO,0.73
You’ve got PWMs set like you might have T-Motor Flame ESCs, and it might be worth trying MOT_THST_EXPO at 0.4 or 0.2
Here’s the general rule for MOT_THST_EXPO :

  • set too high you can see instability at low throttle <- you are here
  • set too low you can see instability at high throttle

EDIT: even try a smaller prop size too

This vibration i can see only on high forward speed not in hover position or slow forward speed(below 7 m/s).
Do you think Cuav v5+ controller need extra damping by adding tape on it

Ok i try to reduce it to how the motor reliably working

Current MOT_THST_EXPO = 0.73 is recommended by initial parameters setting and PWM range I was set based on T.Motor esc. This is not flame esc but inbuilt esc from T.Motor drone M690 itself.
so I’m little confusing about setting PWM ranges and MOT_THST_EXPO values.
shall I make PWM Min and Max as 0.

this was also keep changing while flying with high speed against wind.getting error on EKF pos bar keep intimating EKF

Don’t presume the vibrations are only an issue in forward flight, the quad will do a fly-away any time the IMUs lose track of vertical acceleration. You’ll need to solve the vibration issue no matter what.
It could be as simple as wires pulling on the FC or rubbing against it and vibrating, or the canopy vibrating. If the props are over-flying the canopy and centre structure of the quad that will induce extra vibrations too.

Yes, those T-Motor power systems have recently been bench tested and MOT_THST_EXPO was 0.4
The initial params spreadsheet and tuning guide assume ordinary ESCs that are not doing anything non-standard with the thrust linearisation. Leave your PWM range as it is though.

The EKF and IMU switching messages are because of the bad vibrations. You need to aim for never going over 30, preferably less than 20.

as per your suggestion i have added dummy payload of 300g and MOT_THST_EXPO set as 0.4 as well as 0.both did not worked as same result no improvement.

After added dummy payload the MOT_THST_HOVER value changed to 0.34(Twice compared to previous value) and performed Hormonic Notch Filter and done successfully.
post filter file also checked the amplitude signifyingly reduced compared to prefilter.

below log is EXPO set it as zero.

EXPO set it as 0.4

parameter file :m690.param (18.5 KB)

but still 0% improvement on my quad performance .
keep oscillating randomly and specially on descending.

I could only get the expo 0.4 file, but that’s OK for now.

The vibrations are much better, what did you do to fix it?

Set INS_HNTCH_REF to 0.298

You could do a cautious test flight with ATC_RAT_PIT_D and ATC_RAT_RLL_D at 0.0075 and see how that affects the oscillations. If worse just put it back to 0.0036
Then you are going to have to follow the manual tuning process as follows:
First this section
then this section
If you get it very stable and responsive you’d be able to run Autotune.

I think it’s hover flight only that’s why can’t able to see much vibration.if do forward flight will may cause vibe issue

This was my long term question and still unanswered by any one.i just caluculated MOT_THST_HOVER by holding in Althold mode for more than 1min and found 0.36 .

After set INS_HNTCH_ REF = O.36
performerd next flight that again changed to 0.29 and it’s keep changing to every flight .if keep changing how does INS_HNTCH_ REF will work correctly?.

It’s normal that MOT_THST_ HOVER value keep changing every flight.

Why straight way set to double the amount of D_term …can increase intermediate value and check .i.e 0.005 like that.

Stable in the sense decending also must be very very fine . because in stablize mode roll and pitch are perfect as when I fly with remote.can I perform now?

@xfacta as of parameter file my rate controller and angle controller values are ok?
I just checked Des roll and actual roll it’s seems to be more overshoots I think so.

yes, it is normal that it changes every flight.

Then how come Hormonic notch will work when MOT_THST_HOVER lower than INS_HNTCH_REF value ?

It changes very little. You can and should ignore the changes, if you do not change the hardware and payload of the vehicle.

If the hardware or payload of the vehicle cahnges, you need to update the INS_HNTCH_REF value.

I didn’t add or remove any extra weight but still it’s varry

One flight got 0.36 and next flight got 0.29

  1. Did you follow the tuning process instructions?
  2. Did you activated , and correctly configured, the dynamic notch filter?

Yes I have always following tuning process and Hormonic notch filter method also …based on that I was flown and attached log for reference of the above messages.