Wing FC-10 DOF, GPS detection and booting

Not sure if this is hardware problem, bad flight controller, issues in settings or just normal feature. This is my first fixed wing rc-plane so now trying and learning.

I’ve been using Wing FC-10 DOF
with my FMS trainer. It works ok, even automode was ok
with autolanding. I’m using latest Ardupilot F35Lightning, ChibiOS: d2030d88
ArduPlane V3.9.6 (a3fa359a) which was installed with Missionplanner.

But it has one issue, why booting takes so long when GPS is connected? Is it normal? Sometimes I have to wait 4 minutes and sometimes remove battery and try again. Tried different GPS too
(both M8N). Settings have “GPS autodetect”.

With my quadcopters Pixhawks and APM are detecting gps and booting processes are much faster.

I have connected GPS to RX2, TX2, GND and +5V pins of flight controller.
I have also tried so that GPS gets power from Matek 5V UBEC circuit.

@Finncopter could you be a bit more specific about what exactly takes long? is it the FC’s actual booting process or is it rather the time it takes for your GPS to acquire a good 3D satellite fix?
the latter would likely be due to reduced reception as a result of noise (HF components onboard?), noisy power supply or unfortunate placement rather than an issue with the FC’s software or settings.

cheers, basti.

I guess this is something which is caused by power issues. Seems to work now
ok when power comes to both FS-iA6B receiver (PPM) and GPS from Matek 5V UBEC… Blue led in controller flashes now maybe 10-20 seconds and then solid blue led and then it continues normally to acquire fix from GPS satellites. Before that when receiver got power from controller pins blue light in controller just flashed minutes… I ordered now also Matek F-405 Wing from official reseller as I think it’s better quality

ok, seems like there could be two separate issues actually:

1.: time to GPS fix likely isn‘t firmware related.

2.: the blue LED on your FC keeping flashing for minutes however might indicate your board hanging in bootloader mode, unable to boot to firmware runtime. this might be related to UART defines in that board’s ardupilot bootloader, causing the board to hang in BL as soon as there’s serial periphereals connected. i assumed that issue had been solved by a fix for PUPD handling, but admittedly i‘ve lost exact track of that issue and respective fixes.

edit: here it is