Wing did a flip and crashed

Please, can you look at my log. I have Arduplane 4.2.3, configured for wing (Elevon left, right and throttle). FC is Pixracer. Wing did a flip in 3:53 and then crashed. Difference between NavRoll/NavPitch and Roll/Pitch is growing from this time. What does it mean?


Hi Ivosch

A failure of one of the Elevon servos could be the cause. I once had several crashes with an Opterra wing where one of the servos simply showed failures at irregular intervals. Each time after a crash the servos worked. The defect was only noticed when I had to wait longer for statellite reception playing at the aileronstick noticed that one of the servos suddenly stopped working. Power disconnected and reconnected it ran again!!!. I have then exchanged the two servos against others and all was well.


Thanks Rofl,
both servos work fine now, as in your case. I will look closer on it. I was also wondering about wrong PIDs values. I run autotune in previous flight and didn’t finish it.


It happened again, again during takeoff. There are some oscillations in roll and pitch before crash, time 1:50. Then 2 or 3 flips around roll and crash in full speed :frowning: I have plane in 3 pieces.

The plane is not responding to the commanded servo function. The FC is demanding 0 roll and reasonable pitch angles, but the plane is rolling regardless. I don’t think the throw was bad. I think there was some kind of mechanical failure.

Thanks! I found out that left elevon was partially torn. It corresponds to the clockwise flip around roll axis. Hopefully bottle of glue and tape fix it.