Windows can't find Telemetry Driver

Have bought the holybro telemetry radio V3 and there is a warning triangle in the device manager. When clicked it says there is no drivers available (code 28) and to update drivers. But it can’t find the drivers automatically. Any links for places to download manually are out of date and no longer available.
I’ve also tried uninstalling the device then restarting the computing and plugging it in again and it still doesn’t recognize any drivers to update.
I’ve also tried this on a laptop and pc
There isn’t anything wrong with the telemetry device as it did work on someone else’s laptop who has been using mission planner and his own set of telemetry radios for a while.

yes, i think i had the problem also. i think it happens when you have other embedded hardware development IDEs with their own drivers packages installed. afair I found a install package by searching the net.
i could look if i kept it if the problem is still actual

That would be great if you could find it, so far I have it working on an old laptop running windows 7 but I’m not sure the battery is good enough to last out in a field while flying.

i used CDM21228_Setup
its available at

some documentation

hope it helps

1 Like

Thanks, I was able to download it and get it to work now

Thanks so much - solved the problem for me running Windows 10 in Parallels on my MacBook Air!