Servers by jDrones

Window 10 - not connecting pixhawk 2.4 on either MP or QC


(Anthony Johnson) #1

Hi, I am building a rover using defender tank with skid steering, and as far as I can tell have connected all the essential items. Two things happen. One the pixhawk after a while settles to double flash yellow. Second both qc and mp say they are essentially waiting to connect i.e. not seeing the pix connected to USB. I have read as much as I can and it seems from reading that this may be a w10 com issue but I have tried device manager (which looks different in 10 and does not show com ports). I tried rebooting and downloading software again but no joy. I realise this is newbie stuff but I am currently hung up on this and would appreciate a gentle guiding hand. I even looked at trying to configure com using command prompt but that looks fraught. I have also tried this on two computers a laptop and desktop same result. All the bits are connected except radio which I am not using. I am powering from lipo so not just usb.


(DonLakeFlyer) #2

Did you install the pixhawk usb driver as well? It should come with both the MP and QGC installers.


(Anthony Johnson) #3

Now that’s an interesting question. Unless the driver loads with QC or MP no, but I have searched and cannot find a separate windows usb driver for pixhawk. I do see its probably that as the device manager in windows 10 says there are no com or lpt ports (it says it by not showing any even when hidden clicked) I can load one using legacy and it pops up and interestingly if I try to assign a com it says 3-6 are already assigned which matches my printer, mouse and keyboard plus high gain wifi antenna. I contacted the supplier who suggested removing and reinstalling the micro sd which I will try but don’t think that’s the problem.


(Anthony Johnson) #4

see example no port shows so MP can go no further. Rover is powered up showing white continuous light and is connected to usb by tested cable.


(rollys) #5

Try this:

Hope this works for you.

Good luck.


(Anthony Johnson) #6

Rollys, thanks for that I learned a lot of stuff that I did not know, completed instructions in “disable” successfully but APM and MP still do not show any ports. However the installation of MP was better and all the drivers installed ok whereas before one or two failed. So all drivers ticked but still did not connect. Going into dM using windows x there are no com or lpt ports showing. The USB shows no failed or problematic connections.


(Anthony Johnson) #7

Thanks you all for your helpful suggestions. I have learned something new as well. A cable that provides power from USB does not necessary connect for data properly. So after hours of struggling with windows drivers I tried changing the cable to my Samsung phone cable that I know works and all of a sudden com8 pops up in the drop down and I am connected and working at last. Meanwhile my Lipo battery died and I suspect that the charger never worked. So I got both new and plugged the battery into the charger and thought it charged but in fact it didn’t so I was gradually discharging…lesson learned again.