Will telemetry work when plugged to Serial4/5 port

The Serial 1 port of my Pixhawk is occupied by OSD, while Serial 2 port is for telemetry for my Jumper R8 receiver for sending back signal to transmitter.

I now want to plug a telemetry module to Serial 4/5 port of Pixhawk, changing the function (mavlink 1 or 2) and baud rate (57600) in MP. But the module still cannot be connected to the ground module of telemetry.

Is there any way to work around ?

Thanks for help.

Yes, it must work fine on serial 4 or 5

It did not work for me. I tried setting both in Serial 4 and Serial 5 in MP to Mavlink 1, Mavlink 2, and baud speed to 57600, still won’t connect.

Did you try before and get it work ? What setting are in Serial 4 and Serial 5 of MP in your case ?


IT could be a BRD_CTSRTS issue. Do you have it set to auto? Are all wires used?

Both BRD Ser1 and Ser 2 are set to auto. All 4 wires are used. CTS and RTS are not used.

Before I try to connect CTS and RTS, I tried plugging the telem module to Serial 4/5 port again, it suddenly works without me changing anything from last time. Weird.

Also the BRD setting are for Ser 1 and Ser 2 port, not for Serial 4/5 port.

Anyway, thanks for your help.

Yeah it will be wiring. RTS and CTS are available on Telem1 and Telem2 ports. Usually RTS and CTS are not available on Serial4/5, and Serial4/5 are frequently combined in the one physical connector.

I would move your telemetry radio to Telem1 and it might work with its existing wiring. Try OSD and Jumper/Yaapu telemetry combined into Serial 4 and 5, they only need TX and RX.
This would free up Telem2 for something important that might need RTS/CTS in the future.

Do your telemetry radios have a green light on them? (I’m assuming SiK style radios). Is the light on each module on solid or blinking?

Good suggestion. Will modify to combine OSD and telem for Frsky wiring.

Both radios have solid green lights, meaning they managed to communicate one another.

Problem is now solved as mentioned in previous email in this thread.
Thank you,.

1 Like

Hi Shawn,

I try combining OSD and FrSky telem to Telem 4/5 port of Pixhawk.

Before I do that :–

---- I plug OSD alone to Telem 4/5 port and change Serial 4(or 5) protocol to 1 (For Mavlink 1), OSD works.
---- I then unplug OSD, and plug FrSky telem to Telem 4/5 port and change Serial 4 (or5) protocol to 10 (for FrSky telem),
FrSky telem works.

I reboot the FC everytime I change param.

But when I swap the port and Serial protocol, ie. OSD with Protocol 10, OSD does not work…no updating of flight data.,
also FrSky with Protocol 1, FrSky telem does not work.

Above are not surprising as OSD and FrSky telem have different protocol.

Any suggestion ?

Thank you.

In Serial4/5 there’s two groups of TX/RX pins - are you connecting OSD to one set and FrSky telem to the other?

I overlooked the details in the table. Combined the wires as listed in the table and set the respective
protocol in MP, and it works. Save 1 port in Pixhawk.

By the way, I also combined OSD and telem radio sometime before, plugged them to the MAIN port in Revo, and it works.
Not sure if I combine Telem radio to the OSD above, and plug them all to Telem 4/5 port, setting either 4 or 5 to
Mavlink 1 (for OSD and Telem radio), will it work ? I have not tried yet.

Thank you.

You want mavlink2 for the telemetry radio or you miss out on important features.

Yes, thank you. I note this in the wiki.