Why won't all my motors spin up together?

Well, I’m back…everyone was very helpful on my previous problem, I think this is my last one before I can start flying - hopefully someone can help me here.

This is an F550 hex frame (DJI 30A Opto ESCs with red DJI 2212/920KV motors) with APM 2.6 running firmware release 3.2, an AR8000 receiver, and a DX8 transmitter.

My problem? After I arm the system, when I raise the throttle to take off, only four of the six motors spin up. If I continue to raise the throttle the remaining two will start spinning, but by that point the copter is already beginning to tip over from the thrust of the four motors already going. A secondary problem is that the minimum throttle that gets the first four motors moving seems to have them going fast enough that the copter is close to liftoff; if all six were going, I’m pretty sure the copter would be in the air. If that were to happen, I don’t believe I could reduce RPM enough to land softly…but I’m less worried about this issue at the moment.

It’s worth pointing out that the DJI ESCs I’m using don’t support calibration - this certainly seems like a calibration issue, but calibration can’t be the answer.

Things I have done to troubleshoot:

  1. I’ve swapped motors around. If motor A doesn’t spin and motor B does, I can switch those two motors and the problem will stay on arm A. This suggests (to me) the motors aren’t at fault.

  2. I’ve run through the Motor Test function in Mission Planner. With throttle settings from 0%-20%, no motor will spin when I push the button. At 21% each motor will spin when its button is pressed. This suggests to me that the ESCs aren’t at fault, either.

  3. I’ve swapped output leads from the APM. If motor A doesn’t spin and is connected to output 1 on the APM, while motor B on output 2 does, I can switch the leads (putting A on 2 and B on 1) and the problem will move to arm B. This has me thinking the issue lies in the APM unit itself.

Does anyone have any ideas? I don’t know if it will help, but I’ve attached a dataflash log (LOG_BITMASK = 43006) below. For this test the copter was sitting on my table with no props. I armed it, ran the throttle up and down with stops at several points, and also threw in some yaw and roll here and there.

All help appreciated!

Isn’t 21% a bit high for motors to start spinning? Mine start at 5% and doesn’t stop util I go down below 2%

At arming your motors are at 1054 which should spin them all at a slow speed. If they don’t then you have a problem. There was a similar post to this one that also tried those ESC’s and gave up on them.

If none of them spin up try changing the THR_MIN percentage until they do.

diydrones.com/forum/topics/dji-o … 1#comments


You can try to callibrate one ESC at the time.
Disconnect the other 3 ESCs and do the callibration on the one that gives you problems

I agree, 21% seems awfully high to me as well. I’m not sure what’s going on there, but I was planning to address that after resolving the ‘togetherness’ problem.

Mike - I’ve had other people point a finger at the ESCs as well…and to be clear, I recognize you and they all know more about them than I do. The problem I am having with that is that those ESCs (along with all the rest of the hardware on the vehicle) worked perfectly well last year…so before I shell out to replace them, I need to be able to convince myself that they’re the problem. The one difference between last year and this year is that I’ve gone to firmware 3.2 on the APM…I don’t remember what I was running before, but I want to say it was a 2.x release. As an IT guy, I can’t help but wonder if that change has something to do with this.

Along those lines, I’ve tried doing some of my own log analysis, and have some questions about what I am seeing that I hope you can help me with. I’ve attached a graph from another engine run last night. In it, I am graphing what I believe to be the throttle input (C3 on RCIN - the red line) against what I believe to be the engine outputs (RCOU, Chan1-Chan6). Questions:

  1. Am I correct in my assumptions as to what each line is?

  2. For the RCOU values, are these the PWM values being generated at the output pins on the APM? In other words, this graph shows what the APM is telling my ESCs to do, and not what my motors are actually doing?

  3. Why are the motor values so divergent? The copter is sitting on my workbench, level, with no props. I would expect the APM to command the engines to all spin very close to the same speed. And yet, some of those lines are very far apart from each other.

  4. Finally, why are the rates of change so different in some areas? For example, right after the first throttle increase, two of the motors (1 and 4) continue increasing in speed (or, if I am right in #2 above, the APM is commanding them to increase in speed), two (3 and 6) seem to hold roughly steady, and two (2 and 6) begin to decline. Again, a steady, level copter sitting on a table.


Correct. That is what I saw as well. But that could be normal as level is not always copter level.

As far as the ESC’s are concerned they are factor calibrated to all be the same and if the are all given the same PWM they should all spin at the same speed. Now if you put the copter in calibration mode not to calibrate it but to apply the same PWM to all the motor at the same time do they all spin together.
If not then they are defective.

Also the timing loop that sends the pulse to the ESC’s may have changed causing a sync issue with the ESCs.
I believe the Pixhawk uses a 490Hz loop and the APM I think half that rate.

copter.ardupilot.com/wiki/config … errc_speed


I think you just need to set THR_MIN above 210

And also MOT_SPIN_ARMED at 210 if you want them to spin (default) or 0 if you don’t

Also the timing loop that sends the pulse to the ESC’s may have changed causing a sync issue with the ESCs.
I believe the Pixhawk uses a 490Hz loop and the APM I think half that rate.[/quote]

You may have hit on something important here. I checked the RC_SPEED parameter, and it was set to 490. The fine print on the label of my ESCs claims a frequency response range of 30-450Hz. So I dropped it down to 300 (to be well within the ESC range) and tried again. It may be wishful thinking on my part, but it seemed better than before…5 of 6 spun up, and I can accept that minute variations in level-ness can justify one engine not going. Picking the copter up and wobbling it about, all six motors were going at one point or another.

I’m out of play time for today, but tonight or tomorrow I am going to put props on it and see if it’s flyable. I feel like I’m making progress, so thank you (and everyone else!) for your continued assistance.

OK, things are somewhat better. Dropping RC_SPEED down to 300 seems to have the motors behaving much more consistently; all six motors start spinning before the copter tries to tip over, which is a big improvement. I’m going to tentatively say this part of my problems is solved.

However, I still have the issue that the minimum throttle that causes the motors to spin is very very close to takeoff speed; if I had to guess, I’d say that my throttle setting for hovering is no more than 10%, which seems ridiculously low. And the copter isn’t excessively light, either; I just weighed it at 1775g. These are the red DJI 2212/920KV motors, with 8045 props on them. Oh, and a 4S 5800mAh battery - is that too much juice, perhaps?

I did try the ESC calibration procedure, even through my ESCs don’t support it…and at the end, I was able to throttle all six engines smoothly, up and down…and the minimum RPM at which I could spin them at was well below what I can accomplish in normal operation. So I know the motors can spin at an appropriately low RPM if needed.

I’m sure there’s just a parameter or two that has been changed in the latest release, much like the RC_SPEED parameter. Any suggestions as to what to look at?

I’m marking this one solved, and I think it was lowering the RC_SPEED parameter that did it. After adjusting that I went through all the calibration processes again, and afterward everything seems to be behaving properly. I just got back from my first test flight, and the only problem I observed was my lack of skill. :laughing:

Thanks again to all who helped!

Wow. Thank you very much for this. This has solved my same problem. Again thanks for your detailed questions that has brought me to this page. Good Luck and More power!