Why only two motor outputs are working?

I loaded copter 4.1.4 freshly into my existing 5’’ quad previously running betaflight (with bidirectional dshot working) without any hardware change. Basic settings and calibration done, ESC protocol set to DSHOT600, outputs mapped to use the same wiring like BF, but only 2 of 4 motors are working (M4 & M1).
My board is Omnibus F4PRO (with onboard current sensor) and my ESC is 4in1 blheli-s running bluejay firmware.
Normal copter 4.1.4 firmware via DSHOT 600 works with 2 motors, -bdshot version doesn’t spin any motor at all (even servo output green bars in Mission Planner are moving)
I can’t test other servo protocols (normal, multishot125…) as the bluejay firmware doesn’t support them.
After reverting BF or iNAV all works again so not a wiring problem…
Isn’t it just anything stupid I forgot?
My config for reference is here

If it’s wired for Betaflight FRAME_TYPE 12 should work. But with what you have (3) all motors should still spin.

There is a bug on the omnibus which requires this: https://github.com/ArduPilot/ardupilot/pull/20005

Are you able to try 4.2-dev? That contains this fix as well as some fixes to the timers.

Thanks for the info!
Do I understand correctly, that I just take this firmware, load it and bidirectional dshot should work for all 4 motors?

Should do, yes

More words

I loaded 4.2.0dev with bdshot and with DSHOT600 all 4 motors are turing. Not testest to fly, neither RPM telemetry, but it’s definitely a good step forward!
Thanks for the anwer! Will possibly report how it flies.

Yes, great, after loading 4.2.0.dev and “settings / initial parameter setup” is copter flying nicely"out of the box" (so far only indoor tested).
Little strrange is that buzzer doesn’t work. I have connected an active buzzer (to work also with inav) and after the controller boot it starts emitting permanent tone, but not modulated with the AP tune and never ending.
Isn’t it another known problem for an Omnibus F4 Pro? Is there any help e.g. in logfiles? Or may I have something wrong set?
Previously in inav buzzer worked.
Thanks Roman

Buzzer is on same timer as bdshot so won’t work I am afraid

If you have a 3-pin active buzzer then you can use an alternate PWM output to drive it as of today

I see the reason now!
Isn’t it possible to assign board standard buzzer output pin using NTF_BUZZ_PIN to drive active buzzer via board embedded transistor in single tone pattern as described here? I guess this way doesn’t need timer, does it?
Never tried that so I don’t have idea how to assign this pin and so far didn’t find detailed description for “stupid users” like me :wink:
Can you point me right direction?