Servers by jDrones

Why no dataflash logs?

I have a Cube Orange with Arduplane 4.0.9. The SD card installed is the 16 GB card that came with the Cube.

For some reason, dataflash logging isn’t happening. I have tried swapping out the SD card, and I have tried messing with the LOGGER_BACKEND_TYPE parameter (I have tried setting to it 1, 4, and 6). I have tried enabling logging while disarmed. All to no avail.

Board voltage is around 5.2.

Two questions:

  1. What do the three different logger backend types actually mean? I can’t find any online doc that explains the choices. I have been assuming that the block type would be the correct one for writing a .bin file to the SD card, but that’s just a guess. I have no idea what “file” or “MAVlink” backends mean.

  2. What else can I try to get logging to work?

Additional info: At some point a year or so ago, some log files were in fact created – I could see them via the MP “dataflash logs” interface. But attempts to delete them via that interface silently failed. I ended up deleting them manually by plugging the SD card into my computer. But since then, no new logs. But even then, the logs present were quite old, so I don’t think the problem started at that point.

The backends are:

  • Mavlink: Stream logfile over MAVLink (usually to a connected companion computer. Requires a fast serial baud rate)
  • Dataflash: Log to on-board flash chip, if available
  • File: Log to SD card, if available.

In your case, you want “file logging”

Thank you. Is this information anywhere in the online docs? If so, where can I find it for future reference?

Despite having tried the “file” option, I still wasn’t getting any logs, so something else must still be wrong with my setup.

Make sure the SD card is formatted as FAT or FAT32, not EXFAT. Most 32GB and bigger SD cards are formatted as EXFAT from the factory.

Servers by jDrones