Why does airspeed not reset to 0 before takeoff and why did autocal make it worse?

I’m on the ground, apmplanner shows
Airspeed: 3.03
Goundspeed: 0.03

I have ARSPD_SKIP_CAL set to 0, so should arming my plane, not reset my airspeed to the groundspeed, i.e. 0?
It sure doesn’t.

Am I doing something wrong? Does it mean I’m flying with an incorrect airspeed the whole time?

@tridge, this is the airspeed problem that’s part of my blog answer to you

So, I see 2 problems, here’s the log
and flight OSD for quicker viewing: https://www.youtube.com/watch?v=NgUKE-YJfHg
Just before takeoff, my airspeed is already non 0 even when I’m not pointing into the wind (there was no wind on the ground). On my desk, I also get an airpseed of 3 or so.

I tried to set AUTOCAL to see if that would help, but it didn’t, I think it even made things worse.
shows when I’m landing wind 13kph coming from 90 degrees on the side. I’m not sure that was true, but even if so, why is my forward airspeed 52kph and ground speed 44kph. If that were true, it means I’d have an 8kph headwind, which I’m pretty sure I didn’t, and the wind component seems (WS arrow seems to say that I didn’t).
Worse, at https://youtu.be/NgUKE-YJfHg?t=14m14s just after touchdown, it shows a ground speed of 0, and an airspeed of 20kph!, so it looks like autocal broke my airspeed offset even more.

PARM, 651682841, ARSPD_ENABLE, 1
PARM, 651682894, ARSPD_USE, 1
PARM, 651682913, ARSPD_OFFSET, 131.589035
PARM, 651682933, ARSPD_RATIO, 2.6697344799999998
PARM, 651682993, ARSPD_PIN, 65
PARM, 651683016, ARSPD_AUTOCAL, 1
PARM, 651683057, ARSPD_TUBE_ORDER, 2
PARM, 651683082, ARSPD_SKIP_CAL, 0

My next flight, I took airspeed autocal off, and basically same thing, some airspeed on the ground, regardless of where I had my pitot tube pointed
Just before takeoff, my airspeed is 12, and ground speed is 0, and I wasn’t pointing into the wind.

Airspeed with the digital(!) sensor is very noisy, even in a wind still environment the sensor always shows around 4-8km/h, ours have always done this. It normally settles down and becomes fairly accurate once airborne.

Doing a once-off airspeed ratio calibration while loitering usually increases the accuracy (in the air).

I normally only do a preflight calibration if the airspeed is over 10km/h with a pitot tube cover on the pitot tube which ‘resets’ it back to 4-8km/h.

I’m not sure ARSPD_SKIP_CAL is a good idea, have never done or needed that in 500 hours of missions.

Thanks @Graham_Dyer. I agree about ARSPD_SKIP_CAL being probably not a good idea, which is why I didn’t enable it, and do the calibration at every boot.

I didn’t know that it was “normal” for the airspeed to show 4-8kph before takeoff with no wind. That sounded pretty bad to me :slight_smile:
Now that you tell me it’s expected, I won’t worry about it too much.

But still, weird, why would AP not reset it to 0?

In case someone finds this thread, in AP 3.6.0 it’s worse: my airspeed was showing 18 on the ground and I couldn’t get it to come to 0.
Apparently, according to Airspeed sensor unhealthy you can do “preflight calibration” in mission planner, and it’s supposed to fix this.
In my case, I manually changed ARSPD_OFFSET to bigger numbers randomly until the airspeed went down, and eventually it went back up. I honed in on a value (76, that seems high!) that got the airspeed back to 1.5 or so on the ground (never got it to less than 1).
Preflight calibration auto set it to 76.50

FWIW my logs have ARSPD_OFFSET values of around 100 from roughly the same firmware. I’m not sure if that is considered out of normal scale though. I have arrived at those numbers exclusively by doing the calibrations, without ever touching the parameter by hand.

The reason it’s not stuck at 0 is the noise on the sensor that @Graham_Dyer mentioned. I normally see something withing the range 1-2m/s on the ground once calibrated.

1 Like

@WickedShell you’re right about the noise, I kind of forgot about that, but still with noise I should expect the airspeed to change while the aircraft is on the ground, not moving, and yet it just stays at >1
That said, close enough :slight_smile: