Why did my drone crash? EKF3 IMU0 emergency yaw reset + GPS Glitch

I openned Bug to get help !

It looks like it could be a motor failure of the front right motor.

The reason I think so is that we see two symptoms of a motor failure:

  • the desired and actual roll and pitch are tracking OK and then suddenly diverge. In this case the roll becomes positive (vehicle rolls right) and pitch becomes negative (vehicle pitches forward). This is towards motor 1.

  • the presumably failed motor (1) goes high and it’s opposite motor (2) goes low.

I’ll continue to have a look though… there are a lot of features enabled including TCAL, bendy ruler, etc.

I build multicopter drone fo the first time and i did everything in the book about the setting
and when i am trying to fly the thing it want take off it will sake around and turn upside down
can someone help me to findout what is the problem?

Hi Ahmed,
You’ll need to start your own thread for your problem.
But with a multirotor trying to flip on takeoff is ALWAYS motor order, and the 2nd issue some have is pitch channel reversed.


thank you @rmackay9 !

Your indication was analyse, but other errors got observated before, EK3-YAW-RESET and GPS-2 ERROR.

obs: This same crash did 2 times in same conditions but in different flight board and battery ! Same frame, motors, GPS module, see below logs of first crash (first_crash_00000014.BIN), the battery connector AS150u was hot and kill the anti-spark !

After EK3 IMU1 MAG0 ground mag anomaly, see last message sequency just before to do crash:

07/02/2022 18:27:13 : PreArm: Compasses inconsistent
07/02/2022 18:26:37 : GPS Glitch cleared
07/02/2022 18:26:34 : PreArm: Compasses inconsistent
07/02/2022 18:26:29 : EKF primary changed:0
07/02/2022 18:26:24 : EKF3 IMU0 emergency yaw reset
07/02/2022 18:26:24 : EKF primary changed:1
07/02/2022 18:26:24 : EKF3 lane switch 1
07/02/2022 18:26:24 : EKF3 IMU1 emergency yaw reset
07/02/2022 18:26:21 : GPS Glitch
07/02/2022 18:26:20 : Mission: 1 Takeoff
07/02/2022 18:26:17 : EKF3 IMU1 MAG0 ground mag anomaly, yaw re-aligned
07/02/2022 18:26:17 : EKF3 IMU0 MAG0 ground mag anomaly, yaw re-aligned

I tried replay this condiction in frame without propellers, no got “emergency yaw reset” message ! And I did see message CRASH DISARMED: AngleErr: 40>30, and confirmed in parameters: ANGLE_MAX=3000 (30g), cutoff motors. I changed to 4000.

other curisity about parameter is about EXTERNAL COMPASS, because in CAUV v5Nano the COMPASS_ORIENT0 = 0 but in this actually flight board CUAV X7+ external compass is same and after calibration this COMPASS_ORIENT0 was automatically changed to 6 YAW 270, and same CUAV boards internal compass was Orientantion to 0.

I think this is a bug. But I will change the motor 1 and go to new flight test !


I thing this motor inconsistent fail is probality, but it worked for 2 flights, and work well on the table.


If I had motor fail, why not going to Crash event when angle was >30 ? Why didn’t see Pontential Thrust Loss message ?

This messages I did see after in simulation test.

This message is usually announced when a motor is consistently commanded to a set PWM (usually max) with no response. In the log its looks like the PWM out fluctuates between max and some other value. Maybe the motor/ESC was cutting in and out intermittently?

1 Like

I was tested this and all motors cables and pwm cables and pins, no inconsistent working.

When I do indoor test without propellers in arming mode, the drone work perfectly, I tested all situation, but never have return YAW RESET before, after this message, YAW orientation was change !!!

This graphic can see Motor1 going to max PWM in same time to touch down on the floor.

see next graphic, YAW variation is bigger after YAW reset message. I thing the YAW was change of Compass 0 to Compass 1 and they were different values and orientation !

I will try new flight with changes:

  1. change motor 1;
  2. change GPS Module (compass 0);
  3. Change AngleMax to 4000 (40);
  4. change disable internal compass, to EK3 no change on the flight !

I hope no get more crash ! Oh my God !!!

After that why not perform the usual, Pre-maiden flight, Configuration?
Initial Parameters Setup in Mission Planner.
Configure the Dynamic Notch Filter.
Do some tuning (Auto Tune or Manual).

I have some other drones using this same firmware. I think this situation is a bug of EK3.

this drones did some excellents flight before !!! I am not setting for first flight !

thank you

Most parameters are at Default and the Tuning looks poor. This is not the best place to start.
At a minimum go here and set these:

1 Like

Hi @rmackay9,

Yesterday I did good fligh again !!! 14 minutes on the fligh, no problems, no glitch, no EKF errors !

I did change of Motor1 like you review, and, change GPS/Compass module too !

I did see first flight was a spark and less energy power on the flight, why ? I discovery one screw in below battery connector AS150 !!! After that spark, the GPS module is not working propely, can see GPS Error and Compass Errors in secund flight ! I feel that is instable, I’ll try in little drone soons.

I will analize the function EK3_YAW_RESET, because, if have a bad return of compass and GPS, need a workaround function to stop and land drone, or change to ALTHOLD mode.

Thank you guys for quick return,

Have a nice flight !

I’ve just experienced the EXACT same thing today, resulting in a crash with a quadplane. We did a QSTAB no problem, landed and then tried QLOITER, the craft “jerked” then rolled / banked left and hit the ground, flipping over. Looking at the log, I see the same sequence - also one motor going low and another motor going high.

We’ve got no idea of the root cause. The motors and speed controllers seem 100% fine and have been flying for months. We’ve recently replaced the FC and loaded 4.3 QuadPlane.

Any ideas would be SO much appreciated!

Log here: 11.01 MB file on MEGA

Just at first glance, not an exhaustive investigation…

Latitude and longitude shift a bit and there’s a GPS Speed spike, causing the aircraft to try to follow that shifting GPS position…
The earlier part of the log in QStabilise wasnt affected because it doesnt rely on the GPS.
But this time you were in QLOITER , and it should have worked OK I think, but for the GPS position.

Try setting this to improve the GPS position
or other constellation combinations, whatever works most reliably in your area, but only ever select two at once.

and check the other fence params, radius and altitude.
This will prevent you from arming in ANY flight mode until the GPS 3D Fix is good and Home can be set.

this will allow the “copter” to rise to 2m height before navigating, not moving laterally like it did. The downside is it can be blown by wind and wont hold position until it passes 2m altitude. Experiment with this one, it might not be appropriate with a quad plane since you could do weather-veining too.

1 Like

Thank you very much. I never considered a GPS glitch because nsats were so high the whole time but of course that is no guarentee. Thanks for the Q_NAVALT_MIN also, might make sense to avoid this but yea - wind could be an issue.

Had 3 crashes over the last 40 days. twice with the same flight controller.

Incident 1 - 24th April 2023
flight controller: cube orange + running 4.3.2
Drone takes off in alt hold mode. when flight mode changed to loiter it starts to loose control and accelerates in roll axis at a steep angle with speeds reaching 11.5 m/s and crashes into a stationary vehicle.

Flight log: https://drive.google.com/file/d/1N9XH2_all8dzNc0mX1md6hJQhIKIT80g/view?usp=sharing

Incident 2 - 25th May 2023
flight controller: cube orange running 4.3.2
Mission uploaded. we arm drone and put in auto takes off to about 1 meter and suddenly accelerates in roll axis. immediately motor kill switch engaged.

flight log: https://drive.google.com/file/d/1I-zDqD4YrX3HmU681XzLBW7VNTowBesd/view?usp=sharing

Incident 3 - 5th June
Flight controller cube orange + running 4.3.2 (Same flight controller as the first incident)
Takes of in loiter modes loses control pitches steeply and accelerates. kill switch engaged.

Flight log https://drive.google.com/file/d/1gsuBAufOda4hBCm3w1NzdZVKqti5sPZg/view?usp=sharing
Video: Drone crash due to EK3 error (Arducopter 4.3.2) - YouTube

Fortunately all flights were only a few meters above the ground, minimising damage. The same flight controller and drone were involved in 2 incidents one on 24th April and again on 5th June. after the initial crash the drone was repaired and flew normally with about 15 hours of flight. In all 3 cases it had something to do with EK3. So as a precautionary measure I disabled EKF3 and enable EKF2. Will keep guys updated if anything else pops up.

1 Like