Which Ubuntu, which APM Planner with no dependency issues

Hi all.
As documented elsewhere, I’m having the usual dependency issues when trying to install APM Planner 2 on an Ubuntu machine. I’ve tried various Ubuntu releases with their corresponding deb packages but none seem to work. I just encounter missing libflite1 an QT stuff. I wish I knew more about Linux so I could get this thing installed but I’m only using it as a financial necessity (I’m unemployed) and don’t have much experience with it. Also, I don’t really want to waste valuable flight time trying to learn the workings of an OS when I literally just need it to run one program. So, my question. Which version of Ubuntu and Planner should I use so that I don’t encounter the same installation issues? Someone must have this thing working on a 64bit machine. I don’t care what Ubuntu I use as long as it works. When I google it I get people with the same problem from 2014 so I’m not overly confident I’m gonna get this resolved without some heavy research or friendly help.
Any suggestions?
Cheers

Use Ubuntu 16.04. You can grab the latest APM Planner 2 build here.
How to install here.

Hi carpy.
Cheers for taking time to reply. I’ve seen your name about and you’re obviously a busy man. I’ve followed the instructions above and I’m still facing the same problems. I apologise in advance if what I’m missing is ridiculously simple.
Here’s what I’m getting during the final stage of installation.

dpkg: dependency problems prevent configuration of apmplanner2:
apmplanner2 depends on libflite1 (>= 1.4-release-9~); however:
Package libflite1 is not installed.
apmplanner2 depends on libqt5core5a (>= 5.5.1); however:
Version of libqt5core5a:amd64 on system is 5.2.1+dfsg-1ubuntu14.3.
apmplanner2 depends on libqt5gui5 (>= 5.3.0) | libqt5gui5-gles (>= 5.3.0); however:
Version of libqt5gui5:amd64 on system is 5.2.1+dfsg-1ubuntu14.3.
Package libqt5gui5-gles is not installed.
apmplanner2 depends on libsdl2-2.0-0 (>= 2.0.4); however:
Package libsdl2-2.0-0 is not installed.
apmplanner2 depends on libstdc++6 (>= 5.2); however:
Version of libstdc++6:amd64 on system is 4.8.4-2ubuntu1~14.04.3.

Any help would be very much appreciated.

What does this command return:
cat /etc/os-release

To make sure Ubuntu is up to date:
sudo apt-get update
sudo apt-get dist-upgrade

I see I’m not the only one experiencing dependency issues.
https://github.com/ArduPilot/apm_planner/issues/961
These guys know what they’re doing much more than I do. I guess [for me anyway] I’m just going to have to wait for a fix. Can anyone point me in the right direction of an Ubuntu/Planner 2 version combination that works though? I don’t care how far back I go as long as I get something to use for now. I can check changelogs for bugs and work around them until I can get something more recent working.
Cheers

Sorry Carpy, didn’t realise you’d got back to me.

NAME="Ubuntu"
VERSION="14.04.4 LTS, Trusty Tahr"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 14.04.4 LTS"
VERSION_ID=“14.04”

Ok, I thought you were going to use Ubuntu 16.04?

Ignore me mate. I’ve booted the wrong drive haven’t I. I’ll try again and report back.

1 Like

Just tried again. This time with the correct Ubuntu version.
I did update, dist-upgrade and then followed the installation guide. I’m still getting this:

Unpacking apmplanner2 (2.0.23-rc1) …
dpkg: dependency problems prevent configuration of apmplanner2:
apmplanner2 depends on libflite1 (>= 1.4-release-9~); however:
Package libflite1 is not installed.
apmplanner2 depends on libqt5script5 (>= 5.0.2); however:
Package libqt5script5 is not installed.
apmplanner2 depends on libqt5serialport5 (>= 5.1.0); however:
Package libqt5serialport5 is not installed.
apmplanner2 depends on libsdl2-2.0-0 (>= 2.0.4); however:
Package libsdl2-2.0-0 is not installed.

Well, let’s see. What’s the output from this:
cat /etc/apt/sources.list

Try this:

sudo apt-get install gdebi-core
sudo gdebi apmplanner2.deb

If you’ve already installed the package by doing something like:

sudo dpkg -i apmplanner2.deb

Then you can retrospectively install the dependencies with:

sudo apt-get install --fix-broken --fix-missing
1 Like

First I most give a big thank you to all the developers contributing to this amazing software! Thanks!

Wouldn’t a PPA from the apm-team be a good idea? Then (hopefully) no one would suffer from broken dependencies.

1 Like

A PPA is a good idea–we just haven’t had the time. Here’s the future home:
https://launchpad.net/apmplanner2

Apologies for late response. I’ve had good results with the latest Linux Mint. It installed fine and everything works as far as I can tell.

Great news and fantastic work! :slight_smile:

1 Like

I’ve run APM Planner2 on both Debian and Ubuntu from 14 on. If it runs into a dependency problem I simply apt-get install the list of dependencies it comes up with and have never had a problem getting APM Planner up and running.

I’m running the latest beta on this machine I’m typing on, which is running Ubuntu 16.04LTS and was running the latest stable build on this same machine with Ubuntu 15 before I upgraded it to 16. When I went to 16 I just installed the beta over the top of the stable version and it went without a single hitch.

1 Like