Servers by jDrones

Which Pixhawk servo outputs should I use for BLHeli passthrough?

I have my 4 ESCs connected to the normal “main” outputs 1-4. I know I have to change the protocol to Dshot to do BLHeli passthrough but do I have to disconnect the connectors from “main” and plug them into “aux” on my Pixhawk?
Thanks

If you want to run Dshot on a Pixhawk you do. Then re-assign the Servo outputs.

1 Like

Ah bugger. Okay, good to know. Was hoping passthrough could work on “main”.
I know you need “aux” for Dshot.

Actually, I don’t want to run Dshot.

I just want to program the settings of the ESCs.

And the reason I am asking this question is because it is difficult for me to access the servo connectors so I can’t easily try it.

Try it. Set SERVO_BLH_AUTO to 1 and see if it will connect via BLHeli suite.ESC’s must be powered.

1 Like

see this topic for further information: blheli-32-passthrough-not-working

1 Like

Thanks, this is now solved in a related separate thread I made as linked above by Arne-W.

I was following this:

https://ardupilot.org/copter/docs/common-dshot.html

which implies that setting SERVO_BLH_AUTO is only needed for Arduplane but I found I needed it for my quadcopter.

That is in reference to Planes that have a mix of Motors running Dshot and servos requiring PWM. All you need is 2 parameters set if you want Dshot on the Pixhawk Aux outputs. MOT_PWM_TYPE and SERVO_BLH_AUTO (assuming you want to use passthru). All other parameters at default. Check it out. If the Banner massage says Dshot 9-12 you are good.

1 Like

Hi there, unfortunately those 2 settings didn’t work for me in that I was checking the message log in MP and it always said the outputs 1-12 were PWM. I discuss this over here:

where I mention those 2 params that didn’t get things working.

It’s a Pixhawk 1.

You were also saying you were on the main outputs but unless you are mixing protocol/timing groups you shouldn’t have to use the mask. If it’s working OK, I was just suggesting that it’s probably redundant.

1 Like

I had 1 ESC on pin 9 (AUX1) and the other 3 ESCs on pins 2-4 (MAIN2-4).

It was just to see whether I should be on MAIN or AUX.

Got it. When MOT_PWM_TYPE is set to a Dshot protocol all outputs are set to Dhsot, except for the ones on the IOMCU, unless otherwise configured. For FC’s w/o an IOMCU that would be All outputs. So with a Dshot protocol set on a Pixhawk, and with no other parameter changes you should see PWM1-8 Dshotxxx9-12.

I see where the discrepancy is. If you set MOT_PWM_TYPE to a Dshot protocol but don’t assign any motors to the Aux outputs then all outputs Main and Aux will be set to PWM. If you assign 1 or more Aux outputs then all Aux outputs will be configured for Dshot.

1 Like

Just to conclude this thread, the answer is yes, on the Pixhawk you must attach all ESC servo connections to the AUX ports.

Servers by jDrones