When booted w/o RC link, servos crazy moving on the ground

When I boot my plane without RC link, it’s naturally in RTL mode, but when GPS is getting fix, plane “navigate” like crazy on the ground and servos are dancing. Is there a way how to avoid it, e.g. to pospone navigation after first arm?
I have INITIAL_MODE set to 0 (so mannual).

I’m running a Matek F765-WING on 4.0.6. Even when I have a dozen sats, if I don’t have the transmitter turned on, I will get random servo movements. I’ve been working on FC config/setup the past several days and have noticed servo movement…not just chatter, but movements up to 90 degrees.

Then it’s similar to mine. I’m always afraid that servos will overheat and burn from overload. We’d need someone with deep knowledge of ardupilot to tell us if it can be avoided and how…
Is here anyone???
Thanks!

Switch on the RC radio first.
For testing on the bench power the AP by USB only.
Normally the servo’s are not powered in this situation.

The standard procedure is to turn on the RC TX first, then the aircraft. If you want to keep the servos outputs from moving before the vehicle is armed, use the ARMING_REQUIRE parameter with a value of 1 or 2. Then arm the aircraft using rudder or GCS.

Thanks! I don’t use conventional RC radio, but control plane over mavlink so plane is often booted before data transfer link is estabilished, this is why I’d like to calm servos until whole chain is connected.

How about setting the inital mode to something like FBWA? as I understand it, your servos would be still as long a the plane does not move

Is the plane going into a RC or GCS Failsafe? I’ve noticed that if you trigger RTL when the plane is unmoved on the workbench the servos will move to one extreme and then move around pretty erratically. It’s like the plane is trying to steer return home or at least point towards a home point that has only moved because of GPS noise.

My plane is in the RC failsafe, because there isn’t any RC at the time, GS was never connected since boot, so it shouldn’t be active.
I have the same feeling that plane is steering home depending on GPS noise and don’t understand that it actually isn’t flying at all.
@Simon_Exner I checked initial mode after boot and it’s set to manual, but regardless of this setting OSD shows RTL and servo behaviour corresponds to this.
Would be nice if RTL would be active only after valid RC was received and then lost.

Hi guys,
new season is here and still the same problem bothers me! I boot up the plane on the field and yet need to do some adjustments via USB or just wait for a good GPS fix so still radio off. As described above plane is in RTL mode (regardless that initial mode is set to “manual”) and after initial GPS fix starts crazy moving all servos as is “steering home” even disarmed and laying on the ground. This means I need to have transmitter always on. Really there isn’t any workabout?
Thanks
Roman

You could test if THR_FAILSAFE=2 solves your problem … (and does not create a new one).

Thanks for the idea, but just from reading the documentation it probably too dangerous to try THR_FAILSAFE=2. I often fly my plane on the edge of the range and I need to have RTL activated when RC link is lost. I’d only need RTL to be activated after there was RC link before and was lost. In the case when there never was RC link autopilot should remain in initial mode.
Logically it should work like this, but unfortunately it does not… :frowning:

Then you have to switch on your transmitter first as it is common practice …

I know that, but would be nice if I don’t have to. As I wrote before, on some planes I don’t use conventional radio but a digital link which needs some time to boot. Even where I use normal radio, why to have it on while I tune some parameters, testing something…
Just a wish, of course I can live without… :slight_smile:

As I said previously, setting ARMING_REQUIRE parameter with a value of 2 will prevent PWM from being output prior to arming the aircraft. If you are arming the aircraft prior to having an RC link, I would strongly recommend you revise your SOP.

Sorry Charlie, it’s whole a big misunderstanding. Of course I don’t want to arm aircraft without radio on. Point is something else - please try to re-read posts above.

Roman,

What happens when you set ARMING_REQUIRE = 2?

Radio on, but extreme servo movement, when powering a demo board here. None of the recommendations in this thread solved that problem, so I made a try with some other brand sevos.

What happens with these servos if you only connect voltage and ground? If they move to an extreme there is most likely nothing that ArduPilot can do. PWM outputs are not enabled until you tell the vehicle to enable them.

Which ones? The first ones are HITEC HS 55, where the starboard side servo moves excessively and the second set, which seems to be ok, are HXT900,

I still have those 2 HS-55 servos, where the starboard one did this extreme movements, here on my table and they have the color marked toothpicks. Both are in 1.5 ms position and connecting to 5V only , nothing happens. Both don’t show any movement.

What I would like to do in a next step, is to connect my oscilloscope, one channel on 5V to the FC, and the other channel to the signal of that starboard of servo …

I’ll come back later … :wink: