What to do when autotune is not the answer

Hi guys. My build is big QUAD, 28 inches folding prop, T-Motor Alpha 60 A HV ESC, T-motor U8-II, 12s cells battery, cube ORANGE, Herelink controller, firmware version COPTER 4.0.7.

I have followed the step by step procedure in this link (https://ardupilot.org/copter/docs/tuning-process-instructions.html ), as I have done plenty of time in the past with good results, even in larger drones. However this time, even in a windless scenario, I am not able to get a good tune after running autotune with default aggressiveness (which is the maximum). Look at these logs… even in the log corresponding to a flight in no wind scenario, real vs desired performance is not good at all (https://drive.google.com/drive/folders/1W19n_ZKa9luWl8eOQQsZBPbOFflp1q4M?usp=sharing). Looking at the reasons of what an Autotune may fail:

  • High levels of gyro noise: not in this case
  • Incorrect value of MOT_THST_EXPO: it was derived from ground test, and also compared to manufacturer data
  • Flexible frame or payload mount: nothing, the vibration performance of this dron is very good
  • Overly flexible vibration isolation mount: cube is hard mounted
  • Non-linear ESC response: MOT_THST_EXPO was 0.15 meaning almost linear
  • Very low setting for: motor start to spin at 0.04, son we set MOT_SPIN_ARM=0.06 and MOT_SPIN_MIN=0.09
  • Overloaded propellers or motors: MOT_THST_HOVER converge to 0.33, which is low

Having ruled out the previous sources of issues…. Here there are my questions:

1- Can anybody tell me if we are setting any parameters wrongly before AUTOTUNE (in the drive you can find params before tune)?

2- Is there any other not-listed issue that may be affecting my build?

3- What to do when autotune is not the answer? Any advise on how to proceed from this point?

I would configure the Dynamic Notch Filter and increase INS_ACCEL_FILTER. Try 15Hz perhaps. Then run another Auto Tune.